aboutsummaryrefslogtreecommitdiffstats
path: root/security/cryptopp
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2012-10-09 05:55:37 +0800
committerdelphij <delphij@FreeBSD.org>2012-10-09 05:55:37 +0800
commitf52924401fa31d3f6ca87b260f762c94cbdc3a66 (patch)
tree1bccadfe948aa35d9590a2afe1ab9d7040206ae9 /security/cryptopp
parentc4c2ade63f6d7792a291198b108658831f7124f5 (diff)
downloadfreebsd-ports-gnome-f52924401fa31d3f6ca87b260f762c94cbdc3a66.tar.gz
freebsd-ports-gnome-f52924401fa31d3f6ca87b260f762c94cbdc3a66.tar.zst
freebsd-ports-gnome-f52924401fa31d3f6ca87b260f762c94cbdc3a66.zip
Add a few casts to initializer of int array when the constant is greater
than 0x7fffffff, as they have exceeded the range of standard int. This makes the code to compile when -std=c++11. The resulting binary was not changed by this commit. PORTREVISION not bumped intentionally as this is a build fix. While I'm there, also convert the header to new style. PR: ports/171525 Submitted by: Michael Gmelin <freebsd grem de>
Diffstat (limited to 'security/cryptopp')
-rw-r--r--security/cryptopp/Makefile6
-rw-r--r--security/cryptopp/files/patch-wake.cpp20
2 files changed, 21 insertions, 5 deletions
diff --git a/security/cryptopp/Makefile b/security/cryptopp/Makefile
index 4bb248f44870..9741e1c005d5 100644
--- a/security/cryptopp/Makefile
+++ b/security/cryptopp/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: cryptopp
-# Date created: 18 January 2001
-# Whom: George Reid <greid@ukug.uk.freebsd.org>
-#
+# Created by: George Reid <greid@ukug.uk.freebsd.org>
# $FreeBSD$
-#
PORTNAME= cryptopp
PORTVERSION= 5.6.1
diff --git a/security/cryptopp/files/patch-wake.cpp b/security/cryptopp/files/patch-wake.cpp
new file mode 100644
index 000000000000..4f4e228189e3
--- /dev/null
+++ b/security/cryptopp/files/patch-wake.cpp
@@ -0,0 +1,20 @@
+--- wake.cpp.orig
++++ wake.cpp
+@@ -25,13 +25,13 @@ void WAKE_Base::GenKey(word32 k0, word32 k1, word32 k2, word32 k3)
+ CRYPTOPP_COMPILE_ASSERT(sizeof(x) == 4);
+ static int tt[10]= {
+ 0x726a8f3b, // table
+- 0xe69a3b5c,
+- 0xd3c71fe5,
+- 0xab3c73d2,
++ static_cast<int>(0xe69a3b5c),
++ static_cast<int>(0xd3c71fe5),
++ static_cast<int>(0xab3c73d2),
+ 0x4d3a8eb3,
+ 0x0396d6e8,
+ 0x3d4c2f7a,
+- 0x9ee27cf3, } ;
++ static_cast<int>(0x9ee27cf3), } ;
+ t[0] = k0;
+ t[1] = k1;
+ t[2] = k2;