aboutsummaryrefslogtreecommitdiffstats
path: root/security/cyrus-sasl/scripts
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-02-26 19:25:55 +0800
committeredwin <edwin@FreeBSD.org>2003-02-26 19:25:55 +0800
commit4c1439501fa98c6a2058f1576501a9a426564a16 (patch)
tree344d7cf9e33384acdd584468ffd78788b7369138 /security/cyrus-sasl/scripts
parente8fbc848f56fb0220d4bc13f614a9fbd9316601b (diff)
downloadfreebsd-ports-gnome-4c1439501fa98c6a2058f1576501a9a426564a16.tar.gz
freebsd-ports-gnome-4c1439501fa98c6a2058f1576501a9a426564a16.tar.zst
freebsd-ports-gnome-4c1439501fa98c6a2058f1576501a9a426564a16.zip
security/cyrus-sasl: Bento fails to build libkerberos + Upgrade
Bento fails to proberly package the port on -CURRENT due to -CURRENT no longer has libdes.* as the des functions have been moved to the libcrypto.* library. PR: 48442 Submitted by: Scot W. Hetzel <hetzels@westbend.net>
Diffstat (limited to 'security/cyrus-sasl/scripts')
-rw-r--r--security/cyrus-sasl/scripts/configure.sasl64
1 files changed, 44 insertions, 20 deletions
diff --git a/security/cyrus-sasl/scripts/configure.sasl b/security/cyrus-sasl/scripts/configure.sasl
index 5f0aa68d544a..5d3b662861b2 100644
--- a/security/cyrus-sasl/scripts/configure.sasl
+++ b/security/cyrus-sasl/scripts/configure.sasl
@@ -93,7 +93,7 @@ fi
${MKDIR} ${WRKDIRPREFIX}${REALCURDIR}
exec > ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc
-echo "PREFIX= ${PREFIX}"
+echo "PREFIX= ${PREFIX}"
while [ "$1" ]; do
case $1 in
@@ -133,6 +133,7 @@ while [ "$1" ]; do
\"MySQL\")
echo "LIB_DEPENDS+= mysqlclient.10:\${PORTSDIR}/databases/mysql323-client"
echo "CONFIGURE_ARGS+= --with-mysql=\${PREFIX}"
+ MYSQL_REQ=mysql
MSG=1
;;
\"OpenLDAP1\")
@@ -144,7 +145,9 @@ while [ "$1" ]; do
echo "LIB_DEPENDS+= ldap.1:\${PORTSDIR}/net/openldap12"
echo "LIB_DEPENDS+= lber.1:\${PORTSDIR}/net/openldap12"
echo "CONFIGURE_ARGS+= --with-ldap=\${PREFIX}"
+ LDAP_REQ=ldap
OPENLDAP=1
+ MSG=1
;;
\"OpenLDAP2\")
if [ "$OPENLDAP" ]; then
@@ -155,22 +158,22 @@ while [ "$1" ]; do
echo "LIB_DEPENDS+= ldap.2:\${PORTSDIR}/net/openldap20"
echo "LIB_DEPENDS+= lber.2:\${PORTSDIR}/net/openldap20"
echo "CONFIGURE_ARGS+= --with-ldap=\${PREFIX}"
+ LDAP_REQ=ldap
OPENLDAP=1
+ MSG=1
;;
\"PWCHECK\")
if [ "$PWCHECK" ]; then
echo "PWCHECK or PAMPWCHECK must be choosen seperately: Defaulting to PAMPWCHECK" > /dev/stderr
else
- echo "PWCHECK_SUB+= -e \"s;%%PWCHECK%%;pwcheck;g\""
- PWCHECK=1
+ PWCHECK=pwcheck
fi
;;
\"PAMPWCHECK\")
if [ "$PWCHECK" ]; then
echo "PWCHECK or PAMPWCHECK must be choosen seperately: Defaulting to PWCHECK" > /dev/stderr
else
- echo "PWCHECK_SUB+= -e \"s;%%PWCHECK%%;pwcheck_pam;g\""
- PWCHECK=1
+ PWCHECK=pwcheck_pam
fi
;;
\"SASLAUTHD\")
@@ -188,24 +191,35 @@ while [ "$1" ]; do
shift
done
-if [ ! "${PWCHECK}" ]; then
- echo "PWCHECK_SUB+= -e \"s;%%PWCHECK%%;pwcheck;g\""
-fi
-
-if [ "$SASLAUTHD" ]; then
- echo "PWCHECK_SUB+= -e \"s;%%ENABLEPWCHECK%%;no;g\""
- echo "PWCHECK_METHOD= saslauthd"
- echo "SASLAUTHD_SUB+= -e \"s;%%ENABLESASLAUTHD%%;yes;g\""
+if [ "${SASLAUTHD}" ]; then
+ ENABLE_PWCHECK=no
+ PWCHECK_METHOD=saslauthd
+ ENABLE_SASLAUTHD=yes
+ if [ -z "${PWCHECK}" ]; then
+ PWCHECK=pwcheck
+ fi
else
- if [ "$PWCHECK" ]; then
- echo "PWCHECK_SUB+= -e \"s;%%ENABLEPWCHECK%%;yes;g\""
+ if [ "${PWCHECK}" ]; then
+ ENABLE_PWCHECK=yes
else
- echo "PWCHECK_SUB+= -e \"s;%%ENABLEPWCHECK%%;no;g\""
+ ENABLE_PWCHECK=no
+ PWCHECK=pwcheck
fi
- echo "PWCHECK_METHOD+= pwcheck"
- echo "SASLAUTHD_SUB+= -e \"s;%%ENABLESASLAUTHD%%;no;g\""
+ PWCHECK_METHOD=pwcheck
+ ENABLE_SASLAUTHD=no
fi
+echo "PWCHECK= ${PWCHECK}"
+echo "PWCHECK_METHOD= ${PWCHECK_METHOD}"
+echo "ENABLE_PWCHECK= ${ENABLE_PWCHECK}"
+echo "ENABLE_SASLAUTHD= ${ENABLE_SASLAUTHD}"
+
+echo "RC_SCRIPTS_SUB+= PREFIX=\${PREFIX} \\"
+echo " PWCHECK=\${PWCHECK} \\"
+echo " ENABLE_PWCHECK=\${ENABLE_PWCHECK} \\"
+echo " ENABLE_SASLAUTHD=\${ENABLE_SASLAUTHD} \\"
+echo " MYSQL_REQ=${MYSQL_REQ}"
+
if [ ! "${DEFJAVA}" ]; then
echo "PLIST_SUB+= JAVASASL=\"@comment \""
fi
@@ -214,6 +228,16 @@ if [ ! "${DBLIB}" ]; then
echo "SASLDB_NAME= sasldb.db"
fi
-if [ "$OPENLDAP" ]; then
- echo "LDAP_MYSQL_MSG= \"See sysadmin.html in the Cyrus-SASL docs directory for informaion on using LDAP or MySQL for authentication.\""
+if [ "${MSG}" ]; then
+ if [ -n "${LDAP_REQ}" ]; then
+ METHOD="LDAP"
+
+ if [ -n "${MYSQL_REQ}" ]; then
+ METHOD="LDAP or MySQL"
+ fi
+ elif [ -n "${MYSQL_REQ}" ]; then
+ METHOD="MySQL"
+ fi
+
+ echo "LDAP_MYSQL_MSG= \"See sysadmin.html in the Cyrus-SASL docs directory for informaion on using ${METHOD} for authentication.\""
fi