aboutsummaryrefslogtreecommitdiffstats
path: root/security/cyrus-sasl2-saslauthd
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2005-11-09 00:51:08 +0800
committerume <ume@FreeBSD.org>2005-11-09 00:51:08 +0800
commit39ef4a0d182a1f160af5573cd2c171952221ad64 (patch)
treea71e4894237dbc3234a5006f9f103bea01a029d4 /security/cyrus-sasl2-saslauthd
parent9ff1d38a5d467dadb0562328a2cc4e6ddc82bbfe (diff)
downloadfreebsd-ports-gnome-39ef4a0d182a1f160af5573cd2c171952221ad64.tar.gz
freebsd-ports-gnome-39ef4a0d182a1f160af5573cd2c171952221ad64.tar.zst
freebsd-ports-gnome-39ef4a0d182a1f160af5573cd2c171952221ad64.zip
- use USB_BDB.
- add SHA256.
Diffstat (limited to 'security/cyrus-sasl2-saslauthd')
-rw-r--r--security/cyrus-sasl2-saslauthd/Makefile14
1 files changed, 4 insertions, 10 deletions
diff --git a/security/cyrus-sasl2-saslauthd/Makefile b/security/cyrus-sasl2-saslauthd/Makefile
index c57aa4d55f41..a8b99d5685d1 100644
--- a/security/cyrus-sasl2-saslauthd/Makefile
+++ b/security/cyrus-sasl2-saslauthd/Makefile
@@ -44,23 +44,17 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--with-saslauthd=${SASLAUTHD_RUNPATH}
.if defined(WITH_BDB_VER)
-.if ${WITH_BDB_VER} == 3
-BDB_MAJOR= 3
-.elif ${WITH_BDB_VER} == 4
-BDB_MAJOR= 0
-.elif ${WITH_BDB_VER} == 41
-BDB_MAJOR= 1
+.if ${WITH_BDB_VER} == 4
+USE_BDB= 40
.elif ${WITH_BDB_VER} == 42
BDB_SUFFIX= -4.2
-BDB_MAJOR= 2
.elif ${WITH_BDB_VER} == 43
BDB_SUFFIX= -4.3
-BDB_MAJOR= 0
-.else
+.elif ${WITH_BDB_VER} != 3 && ${WITH_BDB_VER} != 41
BROKEN= "WITH_BDB_VER must be 3, 4, 41, 42 or 43"
.endif
+USE_BDB?= ${WITH_BDB_VER}
BDB_SUFFIX?= ${WITH_BDB_VER}
-LIB_DEPENDS+= db${BDB_SUFFIX}.${BDB_MAJOR}:${PORTSDIR}/databases/db${WITH_BDB_VER}
CONFIGURE_ARGS+=--with-dblib=berkeley --with-bdb-libdir=${LOCALBASE}/lib \
--with-bdb-incdir=${LOCALBASE}/include/db${WITH_BDB_VER} \
--with-bdb=db${BDB_SUFFIX}