aboutsummaryrefslogtreecommitdiffstats
path: root/security/cyrus-sasl2/Makefile
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2002-10-16 04:30:25 +0800
committerume <ume@FreeBSD.org>2002-10-16 04:30:25 +0800
commit6be721ba9d87acdf60ffaa94d1f4bbbbfdc86f65 (patch)
tree0ad3122e5baac8317131a95c82c79159fa23f4cc /security/cyrus-sasl2/Makefile
parentb73441ea8ccf3921ecbfff2549dd9aa73299c124 (diff)
downloadfreebsd-ports-gnome-6be721ba9d87acdf60ffaa94d1f4bbbbfdc86f65.tar.gz
freebsd-ports-gnome-6be721ba9d87acdf60ffaa94d1f4bbbbfdc86f65.tar.zst
freebsd-ports-gnome-6be721ba9d87acdf60ffaa94d1f4bbbbfdc86f65.zip
- Add WITH_LDAP option which includes OpenLDAP2 support into
saslauthd(8). - Install saslauthd(8) related docs. OpenLDAP2 support is described in LDAP_SASLAUTHD.
Diffstat (limited to 'security/cyrus-sasl2/Makefile')
-rw-r--r--security/cyrus-sasl2/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index 0ebb29729f8a..fe70f63155a5 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cyrus-sasl
PORTVERSION= 2.1.9
-#PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/ \
ftp://ftp.westbend.net/pub/cyrus-mail/ \
@@ -63,6 +63,12 @@ CONFIGURE_ARGS+= --disable-otp
OTP= "@comment "
.endif
+.if defined(WITH_LDAP)
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap2
+LIB_DEPENDS+= lber.2:${PORTSDIR}/net/openldap2
+CONFIGURE_ARGS+= --with-ldap=${PREFIX}
+.endif
+
.if defined(KRB5_HOME) && exists(${KRB5_HOME})
CONFIGURE_ARGS+= --enable-gssapi=${KRB5_HOME}
.elif defined(HEIMDAL_HOME) && exists(${HEIMDAL_HOME})
@@ -92,6 +98,8 @@ DOC2= ONEWS TODO draft-burdis-cat-srp-sasl-06.txt \
rfc2444.txt rfc2595.txt rfc2831.txt rfc2945.txt rfc3174.txt \
server-plugin-flow.fig testing.txt
+SASLAUTHD_DOCS= AUTHORS COPYING ChangeLog INSTALL LDAP_SASLAUTHD NEWS README
+
HTDOCS= advanced appconvert gssapi index install macosx options \
plugprog programming readme sysadmin upgrading
@@ -143,6 +151,7 @@ post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${MKDIR} ${DOCSDIR}/html
+ @${MKDIR} ${DOCSDIR}/saslauthd
.for file in ${DOCS}
@${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
@@ -152,6 +161,9 @@ post-install:
.for file in ${HTDOCS}
@${INSTALL_DATA} ${WRKSRC}/doc/${file}.html ${DOCSDIR}/html
.endfor
+.for file in ${SASLAUTHD_DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/saslauthd/${file} ${DOCSDIR}/saslauthd
+.endfor
@${INSTALL_DATA} ${FILESDIR}/Sendmail.README ${DOCSDIR}
.endif
@PKG_PREFIX=${PREFIX} BATCH=${BATCH} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL