aboutsummaryrefslogtreecommitdiffstats
path: root/security/cyrus-sasl2/Makefile
diff options
context:
space:
mode:
authorjeh <jeh@FreeBSD.org>2000-10-24 10:03:09 +0800
committerjeh <jeh@FreeBSD.org>2000-10-24 10:03:09 +0800
commitb973e7be46d263603d40dcc49b413a24bba44fad (patch)
tree35afaffb869060a7e685a2aa9821a1fd634d561c /security/cyrus-sasl2/Makefile
parente68fac77ea4fe734afec2854c0262645c6ff2cc9 (diff)
downloadfreebsd-ports-gnome-b973e7be46d263603d40dcc49b413a24bba44fad.tar.gz
freebsd-ports-gnome-b973e7be46d263603d40dcc49b413a24bba44fad.tar.zst
freebsd-ports-gnome-b973e7be46d263603d40dcc49b413a24bba44fad.zip
autodetected DB3, but fails to find includes
PR: 21411 Submitted by: Scot W. Hetzel <hetzels@westbend.net> MAINTAINER
Diffstat (limited to 'security/cyrus-sasl2/Makefile')
-rw-r--r--security/cyrus-sasl2/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index 47a6cedd6e43..5ba8b55ad666 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -43,12 +43,18 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--enable-static \
--enable-login \
--with-pwcheck=/var/pwcheck \
+ --with-dblib=ndbm \
--with-rc4=openssl
SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
PREFIX="${PREFIX}" \
TOUCH="${TOUCH}" \
- MKDIR="${MKDIR}"
+ MKDIR="${MKDIR}" \
+ ENABLE_DB3="${ENABLE_DB3}" \
+ ENABLE_MYSQL="${ENABLE_MYSQL}" \
+ ENABLE_LDAP="${ENABLE_LDAP}"
+
+# ENABLE_* variables can be used by depending ports to enable options.
# JavaSASL needs someone to look at to get it to build
#JAVADIR= jdk1.1.8
@@ -65,16 +71,16 @@ SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
#.endif
.if defined(KRB5_HOME) && exists(${KRB5_HOME})
-CONFIGURE_ARGS+= --enable-gssapi=${KRB5_HOME}
+CONFIGURE_ARGS+= --enable-gssapi=${KRB5_HOME}
.else
-CONFIGURE_ARGS+= --disable-gssapi
+CONFIGURE_ARGS+= --disable-gssapi
GSSAPI= "@comment "
.endif
.if exists(/usr/lib/libkrb.a)
-CONFIGURE_ARGS+= --enable-krb4
+CONFIGURE_ARGS+= --enable-krb4
.else
-CONFIGURE_ARGS+= --disable-krb4
+CONFIGURE_ARGS+= --disable-krb4
EBONES= "@comment "
.endif