aboutsummaryrefslogtreecommitdiffstats
path: root/security/cyrus-sasl2/files
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1999-12-27 09:52:25 +0800
committersteve <steve@FreeBSD.org>1999-12-27 09:52:25 +0800
commitb7936a1f573828cb763b06f128bf5bed1e78d1bc (patch)
treea17ab0fd48959d0f02d44e0f53bfff3178f238ec /security/cyrus-sasl2/files
parentf94fe37abe272cba65b469310ae4b4ee1e019326 (diff)
downloadfreebsd-ports-gnome-b7936a1f573828cb763b06f128bf5bed1e78d1bc.tar.gz
freebsd-ports-gnome-b7936a1f573828cb763b06f128bf5bed1e78d1bc.tar.zst
freebsd-ports-gnome-b7936a1f573828cb763b06f128bf5bed1e78d1bc.zip
Adding cyrus-sasl version 1.5.13.
An RFC 2222 SASL (Simple Authentication and Security Layer). PR: 14619 Submitted by: Scot W. Hetzel <hetzels@westbend.net>
Diffstat (limited to 'security/cyrus-sasl2/files')
-rw-r--r--security/cyrus-sasl2/files/patch-ab21
-rw-r--r--security/cyrus-sasl2/files/pwcheck.sh28
2 files changed, 49 insertions, 0 deletions
diff --git a/security/cyrus-sasl2/files/patch-ab b/security/cyrus-sasl2/files/patch-ab
new file mode 100644
index 000000000000..f2fc798bd5c6
--- /dev/null
+++ b/security/cyrus-sasl2/files/patch-ab
@@ -0,0 +1,21 @@
+--- lib/Makefile.in.orig Thu Dec 2 14:11:14 1999
++++ lib/Makefile.in Sun Dec 26 16:54:42 1999
+@@ -75,6 +75,7 @@
+ INSTALL = @INSTALL@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@ $(AM_INSTALL_PROGRAM_FLAGS)
+ INSTALL_DATA = @INSTALL_DATA@
++INSTALL_LIB = @INSTALL_LIB@
+ INSTALL_SCRIPT = @INSTALL_SCRIPT@
+ transform = @program_transform_name@
+
+@@ -190,8 +191,8 @@
+ $(mkinstalldirs) $(DESTDIR)$(libdir)
+ @list='$(lib_LTLIBRARIES)'; for p in $$list; do \
+ if test -f $$p; then \
+- echo "$(LIBTOOL) --mode=install $(INSTALL) $$p $(DESTDIR)$(libdir)/$$p"; \
+- $(LIBTOOL) --mode=install $(INSTALL) $$p $(DESTDIR)$(libdir)/$$p; \
++ echo "$(LIBTOOL) --mode=install $(INSTALL_LIB) $$p $(DESTDIR)$(libdir)/$$p"; \
++ $(LIBTOOL) --mode=install $(INSTALL_LIB) $$p $(DESTDIR)$(libdir)/$$p; \
+ else :; fi; \
+ done
+
diff --git a/security/cyrus-sasl2/files/pwcheck.sh b/security/cyrus-sasl2/files/pwcheck.sh
new file mode 100644
index 000000000000..17c4597433bb
--- /dev/null
+++ b/security/cyrus-sasl2/files/pwcheck.sh
@@ -0,0 +1,28 @@
+#!/bin/sh
+#
+
+PREFIX=/usr/local
+
+case "$1" in
+
+start)
+ if [ -x ${PREFIX}/sbin/pwcheck ]
+ then
+ ${PREFIX}/sbin/pwcheck & && echo -n " pwcheck"
+ fi
+ ;;
+
+stop)
+ if [ -r /var/run/pwcheck.pid ]
+ then
+ kill `cat /var/run/pwcheck.pid` && echo -n " pwcheck"
+ fi
+ ;;
+
+*)
+ echo "usage: $0 {start|stop}" 1>&2
+ exit 64
+ ;;
+
+esac
+