aboutsummaryrefslogtreecommitdiffstats
path: root/security/cyrus-sasl2
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2006-04-16 23:49:24 +0800
committerume <ume@FreeBSD.org>2006-04-16 23:49:24 +0800
commitb839f320e29ebb7ef30acc2f11bd3813975a827e (patch)
tree59fe537b4c7de125cd4ddb3a02ede31a0a93c1ce /security/cyrus-sasl2
parentd31111461ac40790451c6f57473f7614ad69983f (diff)
downloadfreebsd-ports-gnome-b839f320e29ebb7ef30acc2f11bd3813975a827e.tar.gz
freebsd-ports-gnome-b839f320e29ebb7ef30acc2f11bd3813975a827e.tar.zst
freebsd-ports-gnome-b839f320e29ebb7ef30acc2f11bd3813975a827e.zip
Enable support for db-4.4.
Diffstat (limited to 'security/cyrus-sasl2')
-rw-r--r--security/cyrus-sasl2/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index e8f680b91e96..b388e1cba0d9 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -56,18 +56,14 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
.if defined(WITH_BDB_VER)
.if ${WITH_BDB_VER} == 4
USE_BDB= 40
-.elif ${WITH_BDB_VER} == 42
-BDB_SUFFIX= -4.2
-.elif ${WITH_BDB_VER} == 43
-BDB_SUFFIX= -4.3
-.elif ${WITH_BDB_VER} != 3 && ${WITH_BDB_VER} != 41
-BROKEN= "WITH_BDB_VER must be 3, 4, 41, 42 or 43"
+.elif ${WITH_BDB_VER} != 3 && ${WITH_BDB_VER} != 41 && \
+ ${WITH_BDB_VER} != 42 && ${WITH_BDB_VER} != 43 && ${WITH_BDB_VER} != 44
+BROKEN= "WITH_BDB_VER must be 3, 4, 41, 42, 43 or 44"
.endif
USE_BDB?= ${WITH_BDB_VER}
-BDB_SUFFIX?= ${WITH_BDB_VER}
CONFIGURE_ARGS+=--with-dblib=berkeley --with-bdb-libdir=${LOCALBASE}/lib \
- --with-bdb-incdir=${LOCALBASE}/include/db${WITH_BDB_VER} \
- --with-bdb=db${BDB_SUFFIX}
+ --with-bdb-incdir=${BDB_INCLUDE_DIR} \
+ --with-bdb=${BDB_LIB_NAME}
SASLDB_NAME= sasldb2
.else
CONFIGURE_ARGS+=--with-dblib=ndbm