aboutsummaryrefslogtreecommitdiffstats
path: root/security/cyrus-sasl2
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2004-10-09 02:09:16 +0800
committerume <ume@FreeBSD.org>2004-10-09 02:09:16 +0800
commit435aa1d814254fc6b5d4d15dc1c790fc285961c1 (patch)
tree52deeed4450da9b822dc31c19532552e35940638 /security/cyrus-sasl2
parent178d1c888a90bd18140e9ea572d5fe35bb9a76fc (diff)
downloadfreebsd-ports-gnome-435aa1d814254fc6b5d4d15dc1c790fc285961c1.tar.gz
freebsd-ports-gnome-435aa1d814254fc6b5d4d15dc1c790fc285961c1.tar.zst
freebsd-ports-gnome-435aa1d814254fc6b5d4d15dc1c790fc285961c1.zip
fix http://vuxml.freebsd.org/92268205-1947-11d9-bc4a-000c41e2cdad.html
Reported by: nectar Approved by: portmgr (krion) Obtained from: https://bugzilla.andrew.cmu.edu/cgi-bin/cvsweb.cgi/src/sasl/lib/common.c#rev1.104
Diffstat (limited to 'security/cyrus-sasl2')
-rw-r--r--security/cyrus-sasl2/Makefile2
-rw-r--r--security/cyrus-sasl2/files/patch-lib::common.c16
2 files changed, 17 insertions, 1 deletions
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index a8ac4a6a6263..fc374ad963a3 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cyrus-sasl
PORTVERSION= 2.1.19
-#PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/%SUBDIR%/ \
ftp://ftp.westbend.net/pub/cyrus-mail/%SUBDIR%/ \
diff --git a/security/cyrus-sasl2/files/patch-lib::common.c b/security/cyrus-sasl2/files/patch-lib::common.c
new file mode 100644
index 000000000000..76b66e7b5e86
--- /dev/null
+++ b/security/cyrus-sasl2/files/patch-lib::common.c
@@ -0,0 +1,16 @@
+Index: lib/common.c
+diff -u -p lib/common.c.orig lib/common.c
+--- lib/common.c.orig Wed Jul 7 01:03:05 2004
++++ lib/common.c Sat Oct 9 02:03:02 2004
+@@ -1838,7 +1838,10 @@ _sasl_getpath(void *context __attribute_
+ if (! path)
+ return SASL_BADPARAM;
+
+- *path = getenv(SASL_PATH_ENV_VAR);
++ /* Honor external variable only in a safe environment */
++ if (getuid() == geteuid() && getgid() == getegid())
++ *path = getenv(SASL_PATH_ENV_VAR);
++
+ if (! *path)
+ *path = PLUGINDIR;
+