aboutsummaryrefslogtreecommitdiffstats
path: root/security/denyhosts/Makefile
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2005-11-11 14:45:58 +0800
committervanilla <vanilla@FreeBSD.org>2005-11-11 14:45:58 +0800
commit639b7fe46283a12c0cd8c225605a992e2deb0898 (patch)
treec74285d88d5db1acf95f5359c94b85f7d33547cb /security/denyhosts/Makefile
parent470ece6d2b6a0dee0ac934e9d26880685a40598b (diff)
downloadfreebsd-ports-gnome-639b7fe46283a12c0cd8c225605a992e2deb0898.tar.gz
freebsd-ports-gnome-639b7fe46283a12c0cd8c225605a992e2deb0898.tar.zst
freebsd-ports-gnome-639b7fe46283a12c0cd8c225605a992e2deb0898.zip
Add denyhosts 1.1.2, script to thwart ssh attacks.
PR: ports/88781 Submitted by: Janos Mohacsi <janos.mohacsi.at.bsd.hu>
Diffstat (limited to 'security/denyhosts/Makefile')
-rw-r--r--security/denyhosts/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/security/denyhosts/Makefile b/security/denyhosts/Makefile
new file mode 100644
index 000000000000..e4ba941658a7
--- /dev/null
+++ b/security/denyhosts/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: denyhosts
+# Date created: 04 November 2005
+# Whom: Janos Mohacsi <janos.mohacsi@bsd.hu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= denyhosts
+PORTVERSION= 1.1.2
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= DenyHosts-${PORTVERSION}
+
+MAINTAINER= janos.mohacsi@bsd.hu
+COMMENT= Script to thwart ssh attacks
+
+USE_REINPLACE= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+DOC_FILES= CHANGELOG.txt LICENSE.txt README.txt
+
+pre-configure:
+ ${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' \
+ ${WRKSRC}/daemon-control-dist \
+ ${WRKSRC}/denyhosts.cfg-dist \
+ ${WRKSRC}/setup.py
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>