aboutsummaryrefslogtreecommitdiffstats
path: root/security/dirmngr
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2013-11-12 18:06:18 +0800
committertijl <tijl@FreeBSD.org>2013-11-12 18:06:18 +0800
commit39162f64856606c7ff60adba8e00c8a72f9a431a (patch)
tree3dd7bffce02d2cb1c79c15fa617371072cf308bc /security/dirmngr
parent482e467d9d3a9eec9ee2a217ed2cc72aa2679c2b (diff)
downloadfreebsd-ports-gnome-39162f64856606c7ff60adba8e00c8a72f9a431a.tar.gz
freebsd-ports-gnome-39162f64856606c7ff60adba8e00c8a72f9a431a.tar.zst
freebsd-ports-gnome-39162f64856606c7ff60adba8e00c8a72f9a431a.zip
- Patch configure script to fix detection of LDAP libraries. Both libldap
and liblber are needed. - New LIB_DEPENDS syntax, USES=gmake, staging, option helpers. PR: ports/181230 Approved by: maintainer timeout (2 weeks)
Diffstat (limited to 'security/dirmngr')
-rw-r--r--security/dirmngr/Makefile27
-rw-r--r--security/dirmngr/files/patch-configure11
-rw-r--r--security/dirmngr/pkg-plist2
3 files changed, 22 insertions, 18 deletions
diff --git a/security/dirmngr/Makefile b/security/dirmngr/Makefile
index 92ddf4836432..6a82e522aff0 100644
--- a/security/dirmngr/Makefile
+++ b/security/dirmngr/Makefile
@@ -13,35 +13,26 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= umq@ueo.co.jp
COMMENT= Client for managing and downloading certificate revocation lists
-LIB_DEPENDS= assuan.0:${PORTSDIR}/security/libassuan \
- gcrypt:${PORTSDIR}/security/libgcrypt \
- gpg-error.0:${PORTSDIR}/security/libgpg-error \
- ksba.19:${PORTSDIR}/security/libksba \
- pth:${PORTSDIR}/devel/pth
+LIB_DEPENDS= libassuan.so:${PORTSDIR}/security/libassuan \
+ libgcrypt.so:${PORTSDIR}/security/libgcrypt \
+ libgpg-error.so:${PORTSDIR}/security/libgpg-error \
+ libksba.so:${PORTSDIR}/security/libksba \
+ libpth.so:${PORTSDIR}/devel/pth
+USES= gmake iconv
USE_BZIP2= yes
-USES= iconv
USE_OPENLDAP= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
INFO= dirmngr
-MAN1= dirmngr-client.1 dirmngr.1
CONFIGURE_ARGS+= --docdir=${DOCSDIR}
LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext
verify: checksum
gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.sig
diff --git a/security/dirmngr/files/patch-configure b/security/dirmngr/files/patch-configure
new file mode 100644
index 000000000000..2c2a74433ee4
--- /dev/null
+++ b/security/dirmngr/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2010-06-14 09:44:03.000000000 +0200
++++ configure 2013-10-28 17:10:59.000000000 +0100
+@@ -8627,6 +8627,8 @@
+ int
+ main ()
+ {
++BerElement *berctx = NULL;
++ber_free(berctx, 0);
+ ldap_open("foobar",1234);
+ ;
+ return 0;
diff --git a/security/dirmngr/pkg-plist b/security/dirmngr/pkg-plist
index db50a3ab0d43..f2ba050e3cf3 100644
--- a/security/dirmngr/pkg-plist
+++ b/security/dirmngr/pkg-plist
@@ -1,6 +1,8 @@
bin/dirmngr
bin/dirmngr-client
libexec/dirmngr_ldap
+man/man1/dirmngr-client.1.gz
+man/man1/dirmngr.1.gz
%%DOCSDIR%%/examples/README
%%DOCSDIR%%/examples/bnetza-10r-ocsp.signer
%%DOCSDIR%%/examples/dirmngr.conf