aboutsummaryrefslogtreecommitdiffstats
path: root/security/doscan
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-07-08 19:47:14 +0800
committerpawel <pawel@FreeBSD.org>2014-07-08 19:47:14 +0800
commit237ae43ed6816b193d564c11ca2a1e6d5895b911 (patch)
treeb024fa102647c063dcdafc2b95ab16a6fe0e30aa /security/doscan
parentf89ec0616ae696d4075e75dd5f1efd4975180ecf (diff)
downloadfreebsd-ports-gnome-237ae43ed6816b193d564c11ca2a1e6d5895b911.tar.gz
freebsd-ports-gnome-237ae43ed6816b193d564c11ca2a1e6d5895b911.tar.zst
freebsd-ports-gnome-237ae43ed6816b193d564c11ca2a1e6d5895b911.zip
- Fix build with clang (add missing inlcudes in few files)
- Add staging support - Convert to new LIB_DEPENDS format, options framework - Fix spelling mistakes, remove old maintainer contact from pkg-descr MFH: 2014Q3
Diffstat (limited to 'security/doscan')
-rw-r--r--security/doscan/Makefile18
-rw-r--r--security/doscan/files/patch-src__event_queue_poll.cc10
-rw-r--r--security/doscan/files/patch-src__half_duplex.cc10
-rw-r--r--security/doscan/files/patch-src__proto_http_proxy.cc10
-rw-r--r--security/doscan/files/patch-src__tcp_server.cc10
-rw-r--r--security/doscan/pkg-descr6
6 files changed, 49 insertions, 15 deletions
diff --git a/security/doscan/Makefile b/security/doscan/Makefile
index d7c6fc05d452..d4838f0ca26a 100644
--- a/security/doscan/Makefile
+++ b/security/doscan/Makefile
@@ -7,29 +7,25 @@ PORTREVISION= 3
CATEGORIES= security net
MASTER_SITES= http://static.enyo.de/fw/releases/doscan/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Tool to quickly scan your network for machines listening on a TCP port
-LIB_DEPENDS= pcre.3:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
GNU_CONFIGURE= yes
USES= gmake
+
PORTDOCS= README
-MAN1= doscan.1
+PLIST_FILES= bin/doscan man/man1/doscan.1.gz
-PLIST_FILES= bin/doscan
+OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e 's|ony o|on yo|' \
${WRKSRC}/doc/doscan.1
post-install:
-.ifndef(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for file in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
-.endfor
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/security/doscan/files/patch-src__event_queue_poll.cc b/security/doscan/files/patch-src__event_queue_poll.cc
new file mode 100644
index 000000000000..b6e34705eff0
--- /dev/null
+++ b/security/doscan/files/patch-src__event_queue_poll.cc
@@ -0,0 +1,10 @@
+--- ./src/event_queue_poll.cc.orig 2014-07-08 13:37:17.446327398 +0200
++++ ./src/event_queue_poll.cc 2014-07-08 13:37:46.925961262 +0200
+@@ -22,6 +22,7 @@
+
+ #include <cerrno>
+ #include <cstdio>
++#include <cstdlib>
+ #include <unistd.h>
+
+ void
diff --git a/security/doscan/files/patch-src__half_duplex.cc b/security/doscan/files/patch-src__half_duplex.cc
new file mode 100644
index 000000000000..13b7a7036570
--- /dev/null
+++ b/security/doscan/files/patch-src__half_duplex.cc
@@ -0,0 +1,10 @@
+--- ./src/half_duplex.cc.orig 2014-07-08 13:35:10.175988570 +0200
++++ ./src/half_duplex.cc 2014-07-08 13:35:42.546019678 +0200
+@@ -22,6 +22,7 @@
+
+ #include <cerrno>
+ #include <cstdio>
++#include <cstdlib>
+ #include <fcntl.h>
+ #include <string>
+ #include <sys/fcntl.h>
diff --git a/security/doscan/files/patch-src__proto_http_proxy.cc b/security/doscan/files/patch-src__proto_http_proxy.cc
new file mode 100644
index 000000000000..20c76b495b65
--- /dev/null
+++ b/security/doscan/files/patch-src__proto_http_proxy.cc
@@ -0,0 +1,10 @@
+--- ./src/proto_http_proxy.cc.orig 2014-07-08 13:39:24.466003083 +0200
++++ ./src/proto_http_proxy.cc 2014-07-08 13:40:02.286093067 +0200
+@@ -36,6 +36,7 @@
+ #include <string>
+ #include <sys/types.h>
+ #include <sys/socket.h>
++#include <time.h>
+
+ static bool proxy_start(subnets&);
+ static void proxy_open(scan_host_t *);
diff --git a/security/doscan/files/patch-src__tcp_server.cc b/security/doscan/files/patch-src__tcp_server.cc
new file mode 100644
index 000000000000..84f5ca113cc8
--- /dev/null
+++ b/security/doscan/files/patch-src__tcp_server.cc
@@ -0,0 +1,10 @@
+--- ./src/tcp_server.cc.orig 2014-07-08 13:38:28.586070857 +0200
++++ ./src/tcp_server.cc 2014-07-08 13:38:54.175974881 +0200
+@@ -22,6 +22,7 @@
+
+ #include <cerrno>
+ #include <cstdio>
++#include <cstdlib>
+ #include <fcntl.h>
+ #include <netinet/in.h>
+ #include <sys/fcntl.h>
diff --git a/security/doscan/pkg-descr b/security/doscan/pkg-descr
index 3dea29469016..fdcd563489d4 100644
--- a/security/doscan/pkg-descr
+++ b/security/doscan/pkg-descr
@@ -6,19 +6,17 @@ are sparsely populated with hosts), with rather conservative timeouts.
Load distribution: doscan scans the addresses in a seemingly random
order. If your scan host is connected to a central router, this ensures
that the load is distributed across your network, and you are
-stress-tesing just a single router, and not your edge devices.
+stress-testing just a single router, and not your edge devices.
Low memory consumption: memory usage is proportional to the number
of hosts which have responded so far, and to the number of parallel
connections. The total number of addresses does not influence memory usage
in any way.
Can collect responses: doscan optionally records data which is sent
by the hosts which are being scanned. You can even specify a regular
-expresson to extract part of a server banner, and a message to send to
+expression to extract part of a server banner, and a message to send to
trigger a response (great for determining HTTP server versions).
Extensibility: It is possible to add special handlers for TCP-based
protocols, using a straightforward interface.
It supports scanning the vulnerable Microsoft DCOM implementation.
WWW: http://www.enyo.de/fw/software/doscan/
-
-Janos Mohacsi <janos.mohacsi@bsd.hu>