aboutsummaryrefslogtreecommitdiffstats
path: root/security/drweb
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>2001-08-25 07:23:36 +0800
committerache <ache@FreeBSD.org>2001-08-25 07:23:36 +0800
commit5fd446f8dbf6f5a4c5c175ad2b0393dba13766ad (patch)
treea31258ae03026732010a1805ff987baeac1ea2e8 /security/drweb
parent7fe14e848e8d3ba66f908a81e0ae2661e08328b8 (diff)
downloadfreebsd-ports-gnome-5fd446f8dbf6f5a4c5c175ad2b0393dba13766ad.tar.gz
freebsd-ports-gnome-5fd446f8dbf6f5a4c5c175ad2b0393dba13766ad.tar.zst
freebsd-ports-gnome-5fd446f8dbf6f5a4c5c175ad2b0393dba13766ad.zip
Some efforts to make update.pl working
Diffstat (limited to 'security/drweb')
-rw-r--r--security/drweb/Makefile3
-rw-r--r--security/drweb/files/update-patch14
2 files changed, 17 insertions, 0 deletions
diff --git a/security/drweb/Makefile b/security/drweb/Makefile
index c42a7bdd03a9..7946c7e4ae5d 100644
--- a/security/drweb/Makefile
+++ b/security/drweb/Makefile
@@ -16,6 +16,8 @@ MAINTAINER= anton@urc.ac.ru
NO_BUILD= YES
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/mach/String/CRC32.pm:${PORTSDIR}/devel/p5-String-CRC32
+
DRWEB_PREFIX= ${PREFIX}/${PORTNAME}
do-install:
@@ -23,6 +25,7 @@ do-install:
${TAR} -xzf ${WRKSRC}/${DISTNAME}.tar.gz -C ${DRWEB_PREFIX} --exclude *.ini
${TAR} -xzOf ${WRKSRC}/${DISTNAME}.tar.gz drweb32.ini >${DRWEB_PREFIX}/drweb32.ini.sample
${SED} 's#!!PREFIX!!#${DRWEB_PREFIX}#' < ${FILESDIR}/drwebd.sh >${WRKSRC}/drwebd.sh
+ cd ${DRWEB_PREFIX}/update; patch < ${FILESDIR}/update-patch
${INSTALL_SCRIPT} ${WRKSRC}/drwebd.sh ${PREFIX}/etc/rc.d
.include <bsd.port.mk>
diff --git a/security/drweb/files/update-patch b/security/drweb/files/update-patch
new file mode 100644
index 000000000000..f920850378ef
--- /dev/null
+++ b/security/drweb/files/update-patch
@@ -0,0 +1,14 @@
+--- update.pl.bak Tue Jul 31 18:42:13 2001
++++ update.pl Sat Aug 25 03:16:22 2001
+@@ -15,9 +15,9 @@
+ use String::CRC32;
+
+ my $version = '425';
+-my $url = $ARGV[1] || 'http://www.drweb.ru/ftp/update_free/linux/drweb32.lst';
++#my $url = $ARGV[1] || 'http://www.drweb.ru/ftp/update_free/linux/drweb32.lst';
+ #my $url = $ARGV[1] || 'http://www.drweb.ru/ftp/update_free/freebsd3/drweb32.lst';
+-#my $url = $ARGV[1] || 'http://www.drweb.ru/ftp/update_free/freebsd4/drweb32.lst';
++my $url = $ARGV[1] || 'http://www.drweb.ru/ftp/update_free/freebsd4/drweb32.lst';
+
+ my $fetch = ''; # autotest for fetch, wget
+ unless ( $fetch ) { $fetch.=" -q -o" if chomp ( $fetch = `which fetch` ); }