aboutsummaryrefslogtreecommitdiffstats
path: root/security/easypg
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-05-01 09:42:38 +0800
committeradamw <adamw@FreeBSD.org>2014-05-01 09:42:38 +0800
commit4193822cf8d93383dc8f9f6186609a67b2350005 (patch)
tree7d2afea24bed5487a0bed70a4ce863d70ee3d368 /security/easypg
parentad2f39a8b4fdf5d89647810e8a01030f3f768456 (diff)
downloadfreebsd-ports-gnome-4193822cf8d93383dc8f9f6186609a67b2350005.tar.gz
freebsd-ports-gnome-4193822cf8d93383dc8f9f6186609a67b2350005.tar.zst
freebsd-ports-gnome-4193822cf8d93383dc8f9f6186609a67b2350005.zip
STAGE support, and general cleanups. Some of the changes are a
bit more aggressive, but at this point, if I'm staging your port, you've likely stopped caring what's done to it.
Diffstat (limited to 'security/easypg')
-rw-r--r--security/easypg/Makefile30
1 files changed, 10 insertions, 20 deletions
diff --git a/security/easypg/Makefile b/security/easypg/Makefile
index 8f60162d4c10..484f6060f336 100644
--- a/security/easypg/Makefile
+++ b/security/easypg/Makefile
@@ -3,7 +3,7 @@
PORTNAME= easypg
PORTVERSION= 0.0.16
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= security elisp
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP}
MASTER_SITE_SUBDIR= epg/29289
@@ -17,31 +17,21 @@ RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg1
GNU_CONFIGURE= yes
USE_EMACS= yes
-NO_STAGE= yes
+PORT_OPTIONS= DOCS
+INFO= epa
+PORTDOCS= ChangeLog NEWS README
+
.include <bsd.port.pre.mk>
.if (${EMACS_PORT_NAME} == "emacs23") || (${EMACS_PORT_NAME} == "emacs24") || (${EMACS_PORT_NAME} == "emacs-devel")
IGNORE= easyPG has been part of Emacs 23 and Emacs 24
.endif
-INFO= epa
-.if !defined(NOPORTDOCS)
-PORTDOCS= ChangeLog NEWS README
-.endif
-
do-install:
- cd ${WRKSRC};\
- ${MKDIR} ${PREFIX}/${EMACS_SITE_LISPDIR}/epg;\
- ${INSTALL_DATA} *.el *.elc ${PREFIX}/${EMACS_SITE_LISPDIR}/epg
- cd ${WRKSRC};\
- ${INSTALL_MAN} epa.info ${PREFIX}/${INFO_PATH}
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR};\
- cd ${WRKSRC};\
- ${INSTALL_MAN} ${PORTDOCS} ${DOCSDIR}
-.endif
-
-post-install:
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${EMACS_SITE_LISPDIR}/epg
+ ${INSTALL_DATA} ${WRKSRC}/*.el ${WRKSRC}/*.elc ${PREFIX}/${EMACS_SITE_LISPDIR}/epg
+ ${INSTALL_MAN} ${WRKSRC}/epa.info ${STAGEDIR}${PREFIX}/${INFO_PATH}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_MAN} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
.include <bsd.port.post.mk>