aboutsummaryrefslogtreecommitdiffstats
path: root/security/execwrap
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-06-22 23:53:20 +0800
committersat <sat@FreeBSD.org>2007-06-22 23:53:20 +0800
commitb92880da13336ce04e58fdbe32a834c152c9c1a4 (patch)
tree0d4bcf2e0d7153d0211826b8659da6bc5adb0ae9 /security/execwrap
parentd2b58c527ad7558ae305007d868743816be3c199 (diff)
downloadfreebsd-ports-gnome-b92880da13336ce04e58fdbe32a834c152c9c1a4.tar.gz
freebsd-ports-gnome-b92880da13336ce04e58fdbe32a834c152c9c1a4.tar.zst
freebsd-ports-gnome-b92880da13336ce04e58fdbe32a834c152c9c1a4.zip
Add port security/execwrap:
ExecWrap is a super-user exec wrapper for the lighttpd web-server, but it can be used in any environment as long as arguments can be passed from the server to its children via the environment. WWW: http://cyanite.org/execwrap/ Author: Sune Foldager <cryo@cyanite.org>
Diffstat (limited to 'security/execwrap')
-rw-r--r--security/execwrap/Makefile50
-rw-r--r--security/execwrap/distinfo3
-rw-r--r--security/execwrap/pkg-descr6
3 files changed, 59 insertions, 0 deletions
diff --git a/security/execwrap/Makefile b/security/execwrap/Makefile
new file mode 100644
index 000000000000..a32ba83779d8
--- /dev/null
+++ b/security/execwrap/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: execwrap
+# Date created: 22 June 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= execwrap
+PORTVERSION= 0.4
+CATEGORIES= security
+MASTER_SITES= http://cyanite.org/execwrap/ CENKES
+DISTNAME= ExecWrap-${DISTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Super-user exec wrapper
+
+NO_WRKSUBDIR= yes
+PORTDOCS= README
+PLIST_FILES= bin/${PORTNAME}
+EXECWRAP_VARS= PARENT_UID TARGET_MIN_UID TARGET_MIN_GID \
+ TARGET_PATH_PREFIX DEFAULT_UID DEFAULT_GID
+EXECWRAP_TARGET_PATH_PREFIX?= "${WWWDIR:S|/${PORTNAME}$||}"
+.for _var in ${EXECWRAP_VARS}
+. ifdef EXECWRAP_${_var}
+_SED_LINE+= s|${_var}.*|${_var} ${EXECWRAP_${_var}}|;
+. endif
+.endfor
+
+post-patch:
+ @${REINPLACE_CMD} -e '${_SED_LINE}' ${WRKSRC}/execwrap_config.h
+
+pre-build:
+ @${ECHO_CMD} "============================================"
+ @${ECHO_CMD} "You can use the following variables to tweak"
+ @${ECHO_CMD} "compile-time options:"
+ @for opt in ${EXECWRAP_VARS:S|^|EXECWRAP_|};do ${ECHO_MSG} " $$opt";done
+ @${ECHO_CMD} "============================================"
+
+do-build:
+ @cd ${WRKSRC}/ && ${CC} ${CFLAGS} -o ${PORTNAME} ${PORTNAME}.c
+
+do-install:
+ @${INSTALL_PROGRAM} -m 4511 ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+.ifndef NOPORTDOCS
+ @${INSTALL} -d ${DOCSDIR}/
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/execwrap/distinfo b/security/execwrap/distinfo
new file mode 100644
index 000000000000..15b9712e6989
--- /dev/null
+++ b/security/execwrap/distinfo
@@ -0,0 +1,3 @@
+MD5 (ExecWrap-0.4.tgz) = 4b6ed65a2f72cfcc8a5d69410807ab57
+SHA256 (ExecWrap-0.4.tgz) = 4bb6c95aa8cb06fab90e595944e89c2e6f75eab0d8c6cf807b5fc477b1966dad
+SIZE (ExecWrap-0.4.tgz) = 7439
diff --git a/security/execwrap/pkg-descr b/security/execwrap/pkg-descr
new file mode 100644
index 000000000000..6b0334281110
--- /dev/null
+++ b/security/execwrap/pkg-descr
@@ -0,0 +1,6 @@
+ExecWrap is a super-user exec wrapper for the lighttpd web-server, but
+it can be used in any environment as long as arguments can be passed
+from the server to its children via the environment.
+
+WWW: http://cyanite.org/execwrap/
+Author: Sune Foldager <cryo@cyanite.org>