aboutsummaryrefslogtreecommitdiffstats
path: root/security/freebsd-update/Makefile
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2003-04-12 04:52:02 +0800
committernork <nork@FreeBSD.org>2003-04-12 04:52:02 +0800
commit8b065e30e1acb97344513c42ae7442dbd53dfb3d (patch)
tree78da8e330ca14023ffb941cc3c8d2b1c925c67cb /security/freebsd-update/Makefile
parent47f88f8365258c8c43aba248876c19c6bca7b100 (diff)
downloadfreebsd-ports-gnome-8b065e30e1acb97344513c42ae7442dbd53dfb3d.tar.gz
freebsd-ports-gnome-8b065e30e1acb97344513c42ae7442dbd53dfb3d.tar.zst
freebsd-ports-gnome-8b065e30e1acb97344513c42ae7442dbd53dfb3d.zip
Add freebsd-update 1.2, fetches and installs binary updates
to FreeBSD. This is the client half of the FreeBSD Update system; it fetches and applies binary security updates. PR: ports/50202 Submitted by: cperciva@daemonology.net
Diffstat (limited to 'security/freebsd-update/Makefile')
-rw-r--r--security/freebsd-update/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/security/freebsd-update/Makefile b/security/freebsd-update/Makefile
new file mode 100644
index 000000000000..c75d610967a1
--- /dev/null
+++ b/security/freebsd-update/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: FreeBSD Update Client
+# Date created: 21 March 2003
+# Whom: cperciva@daemonology.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= freebsd-update
+PORTVERSION= 1.2
+CATEGORIES= security
+MASTER_SITES= http://www.daemonology.net/freebsd-update/
+DISTNAME= freebsd-update-client-1_2
+
+MAINTAINER= cperciva@daemonology.net
+COMMENT= Fetches and installs binary updates to FreeBSD
+
+NO_WRKSUBDIR= yes
+ALL_TARGET= verify
+
+post-extract:
+ @${SED} -e "s=%%PREFIX%%=${PREFIX}=g" ${FILESDIR}/freebsd-update \
+ > ${WRKSRC}/freebsd-update
+
+do-install:
+ @${MKDIR} ${PREFIX}/freebsd-update
+ ${INSTALL_SCRIPT} ${WRKSRC}/freebsd-update ${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/verify ${PREFIX}/freebsd-update
+ ${INSTALL_DATA} ${WRKSRC}/Makefile ${PREFIX}/freebsd-update
+ ${INSTALL_DATA} ${WRKSRC}/CHANGELOG ${PREFIX}/freebsd-update
+ ${INSTALL_DATA} ${WRKSRC}/LICENSE ${PREFIX}/freebsd-update
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/freebsd-update
+ ${INSTALL_DATA} ${WRKSRC}/VERSION ${PREFIX}/freebsd-update
+ ${INSTALL_DATA} ${WRKSRC}/update.conf \
+ ${PREFIX}/freebsd-update/update.conf.sample
+
+post-install:
+ @${CAT} ${PKGDIR}/pkg-message
+
+.include <bsd.port.mk>