aboutsummaryrefslogtreecommitdiffstats
path: root/security/fsh/Makefile
diff options
context:
space:
mode:
authorsumikawa <sumikawa@FreeBSD.org>2004-12-07 00:05:19 +0800
committersumikawa <sumikawa@FreeBSD.org>2004-12-07 00:05:19 +0800
commit455306a7619acd2f5c395f72d5a38ce22081c257 (patch)
tree9ac6375754266591c0f1360fbec400de697f22ea /security/fsh/Makefile
parent46f595cf434518c4a901748c23da15ebd5273ad3 (diff)
downloadfreebsd-ports-gnome-455306a7619acd2f5c395f72d5a38ce22081c257.tar.gz
freebsd-ports-gnome-455306a7619acd2f5c395f72d5a38ce22081c257.tar.zst
freebsd-ports-gnome-455306a7619acd2f5c395f72d5a38ce22081c257.zip
Make it executable with python-2.4.
Submitted by: sf
Diffstat (limited to 'security/fsh/Makefile')
-rw-r--r--security/fsh/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/security/fsh/Makefile b/security/fsh/Makefile
index b5415b59de4f..83de1597cf25 100644
--- a/security/fsh/Makefile
+++ b/security/fsh/Makefile
@@ -13,8 +13,11 @@ MASTER_SITES= http://www.lysator.liu.se/fsh/
MAINTAINER= sumikawa@FreeBSD.org
COMMENT= Fast remote command execution
-BUILD_DEPENDS= python:${PORTSDIR}/lang/python
-
+USE_PYTHON= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
+post-patch:
+ ${REINPLACE_CMD} -e '/^[^#]/s/FCNTL/fcntl/g' ${WRKSRC}/fshcompat.py
+
.include <bsd.port.mk>