aboutsummaryrefslogtreecommitdiffstats
path: root/security/fsh
diff options
context:
space:
mode:
authorsumikawa <sumikawa@FreeBSD.org>2004-12-07 20:16:51 +0800
committersumikawa <sumikawa@FreeBSD.org>2004-12-07 20:16:51 +0800
commit075c0ba75e34e50aa8e40f45792869d140241e86 (patch)
treeba0c571349881b86b24dd18713bfcbc9a3256f8b /security/fsh
parent31c371aeabcb32bf4d861da667774eb6bb61a587 (diff)
downloadfreebsd-ports-gnome-075c0ba75e34e50aa8e40f45792869d140241e86.tar.gz
freebsd-ports-gnome-075c0ba75e34e50aa8e40f45792869d140241e86.tar.zst
freebsd-ports-gnome-075c0ba75e34e50aa8e40f45792869d140241e86.zip
Build and install *.pyc
Submitted by: sf
Diffstat (limited to 'security/fsh')
-rw-r--r--security/fsh/Makefile8
-rw-r--r--security/fsh/pkg-plist7
2 files changed, 14 insertions, 1 deletions
diff --git a/security/fsh/Makefile b/security/fsh/Makefile
index f76ba48c87ee..f9ef946f5839 100644
--- a/security/fsh/Makefile
+++ b/security/fsh/Makefile
@@ -6,7 +6,7 @@
PORTNAME= fsh
PORTVERSION= 1.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= http://www.lysator.liu.se/fsh/
@@ -20,4 +20,10 @@ GNU_CONFIGURE= yes
post-patch:
${REINPLACE_CMD} -e '/^[^#]/s/FCNTL/fcntl/g' ${WRKSRC}/fshcompat.py
+post-build:
+ ${PYTHON_CMD} -c 'import py_compile; py_compile.main()' ${WRKSRC}/*.py
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/*.pyc ${PREFIX}/share/fsh
+
.include <bsd.port.mk>
diff --git a/security/fsh/pkg-plist b/security/fsh/pkg-plist
index 251841285024..4c084a26564e 100644
--- a/security/fsh/pkg-plist
+++ b/security/fsh/pkg-plist
@@ -4,12 +4,19 @@ bin/fshd
bin/in.fshd
libexec/fcpwrap
share/fsh/fsh.py
+share/fsh/fsh.pyc
share/fsh/fshcompat.py
+share/fsh/fshcompat.pyc
share/fsh/fshconfig.py
+share/fsh/fshconfig.pyc
share/fsh/fshd.py
+share/fsh/fshd.pyc
share/fsh/fshlib.py
+share/fsh/fshlib.pyc
share/fsh/fshversion.py
+share/fsh/fshversion.pyc
share/fsh/infshd.py
+share/fsh/infshd.pyc
@unexec install-info --delete %D/info/fsh.info %D/info/dir
info/fsh.info
@exec install-info --section="Shells and utilities" --entry="* FSH: (fsh). fast remote command execution." %D/info/lsh.info %D/info/dir