aboutsummaryrefslogtreecommitdiffstats
path: root/security/ftimes
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-04-29 05:02:39 +0800
committerbapt <bapt@FreeBSD.org>2013-04-29 05:02:39 +0800
commit63cff4fb52ecbe8ce9260e04e0049980d8cb41d5 (patch)
tree933fd11da647dda8c169bc24693094174bdc0355 /security/ftimes
parent65f6091f0d07908b50e6042a48cdadec0073a2ac (diff)
downloadfreebsd-ports-gnome-63cff4fb52ecbe8ce9260e04e0049980d8cb41d5.tar.gz
freebsd-ports-gnome-63cff4fb52ecbe8ce9260e04e0049980d8cb41d5.tar.zst
freebsd-ports-gnome-63cff4fb52ecbe8ce9260e04e0049980d8cb41d5.zip
Convert security to new options framework
Diffstat (limited to 'security/ftimes')
-rw-r--r--security/ftimes/Makefile29
1 files changed, 14 insertions, 15 deletions
diff --git a/security/ftimes/Makefile b/security/ftimes/Makefile
index 5f6ad8b0c8d4..0fd53f149804 100644
--- a/security/ftimes/Makefile
+++ b/security/ftimes/Makefile
@@ -1,6 +1,5 @@
# Created by: Klayton Monroe <klm@uidzero.org>
# $FreeBSD$
-#
PORTNAME= ftimes
PORTVERSION= 3.8.0
@@ -17,22 +16,22 @@ USE_PERL5= yes
MAN1= ftimes.1
-OPTIONS= DIG_TOOLS "install dig tools" on \
- HASHDIG_TOOLS "install hashdig tools" on \
- MAP_TOOLS "install map tools" on \
- PCRE "PCRE support" on \
- SSL "OpenSSL support" on \
- XMAGIC "XMagic support" on
+OPTIONS_DEFINE= DIG_TOOLS HASHDIG_TOOLS MAP_TOOLS PCRE SSL XMAGIC
+OPTIONS_DEFAULT= DIG_TOOLS HASHDIG_TOOLS MAP_TOOLS PCRE SSL XMAGIC
+DIG_TOOLS_DESC= install dig tools
+HASHDIG_TOOLS_DESC= install hashdig tools
+MAP_TOOLS_DESC= install map tools
+XMAGIC_DESC= XMagic support
.include <bsd.port.pre.mk>
-.if defined(WITH_DIG_TOOLS) || defined(WITH_MAP_TOOLS)
+.if ${PORT_OPTIONS:MDIG_TOOLS} || ${PORT_OPTIONS:MMAP_TOOLS}
. if ${PERL_LEVEL} < 500703
RUN_DEPENDS+= p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5
. endif
.endif
-.if defined(WITH_DIG_TOOLS)
+.if ${PORT_OPTIONS:MDIG_TOOLS}
PLIST_SUB+= DIG_TOOLS=""
CONFIGURE_ARGS+= --with-dig-tools
MAN1+= ftimes-crv2dbi.1 ftimes-crv2raw.1 ftimes-dig2ctx.1 ftimes-dig2dbi.1 hipdig.1
@@ -41,7 +40,7 @@ RUN_DEPENDS+= p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1
PLIST_SUB+= DIG_TOOLS="@comment "
.endif
-.if defined(WITH_HASHDIG_TOOLS)
+.if ${PORT_OPTIONS:MHASHDIG_TOOLS}
PLIST_SUB+= HASHDIG_TOOLS=""
CONFIGURE_ARGS+= --with-hashdig-tools
MAN1+= hashdig-bash.1 hashdig-bind.1 hashdig-dump.1 hashdig-find.1 hashdig-filter.1 hashdig-harvest-sunsolve.1 hashdig-harvest.1 hashdig-make.1 hashdig-resolve-sunsolve.1 hashdig-stat.1 hashdig-weed.1
@@ -49,7 +48,7 @@ MAN1+= hashdig-bash.1 hashdig-bind.1 hashdig-dump.1 hashdig-find.1 hashdig-fil
PLIST_SUB+= HASHDIG_TOOLS="@comment "
.endif
-.if defined(WITH_MAP_TOOLS)
+.if ${PORT_OPTIONS:MMAP_TOOLS}
PLIST_SUB+= MAP_TOOLS=""
CONFIGURE_ARGS+= --with-map-tools
MAN1+= ftimes-cmp2dbi.1 ftimes-map2dbi.1 ftimes-map2mac.1 tarmap.1
@@ -57,14 +56,14 @@ MAN1+= ftimes-cmp2dbi.1 ftimes-map2dbi.1 ftimes-map2mac.1 tarmap.1
PLIST_SUB+= MAP_TOOLS="@comment "
.endif
-.if defined(WITH_PCRE)
+.if ${PORT_OPTIONS:MPCRE}
LIB_DEPENDS+= pcre.3:${PORTSDIR}/devel/pcre
CONFIGURE_ARGS+= --with-pcre=${LOCALBASE}
.else
CONFIGURE_ARGS+= --without-pcre
.endif
-.if defined(WITH_SSL)
+.if ${PORT_OPTIONS:MSSL}
# we can't use USE_OPENSSL=yes after including bsd.port.pre.mk
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE}
@@ -72,7 +71,7 @@ CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE}
CONFIGURE_ARGS+= --without-ssl
.endif
-.if defined(WITH_XMAGIC)
+.if ${PORT_OPTIONS:MXMAGIC}
PLIST_SUB+= XMAGIC=""
CONFIGURE_ARGS+= --enable-xmagic
.else
@@ -82,4 +81,4 @@ PLIST_SUB+= XMAGIC="@comment "
post-install:
${STRIP_CMD} ${PREFIX}/bin/ftimes
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>