aboutsummaryrefslogtreecommitdiffstats
path: root/security/ftpmap/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-04-01 10:41:34 +0800
committeredwin <edwin@FreeBSD.org>2003-04-01 10:41:34 +0800
commit5fce2e74c5bc0b3a33c6b315422b8734955029f4 (patch)
treee665ace577fc770eb6366ee2422fc2301770322a /security/ftpmap/Makefile
parent5303a7c4568424b4afa87883289e18a886a01e76 (diff)
downloadfreebsd-ports-gnome-5fce2e74c5bc0b3a33c6b315422b8734955029f4.tar.gz
freebsd-ports-gnome-5fce2e74c5bc0b3a33c6b315422b8734955029f4.tar.zst
freebsd-ports-gnome-5fce2e74c5bc0b3a33c6b315422b8734955029f4.zip
security/ftpmap: Identify remote FTP server software by fingerprinting
Ftpmap scans remote FTP servers to indentify what software and what versions they are running. It uses program-specific fingerprints to discover the name of the software even when banners have been changed or removed, or when some features have been disabled. IPv6 is fully supported. PR: ports/48899 Submitted by: Sergei Kolobov <sergei@kolobov.com>
Diffstat (limited to 'security/ftpmap/Makefile')
-rw-r--r--security/ftpmap/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/security/ftpmap/Makefile b/security/ftpmap/Makefile
new file mode 100644
index 000000000000..26c565625328
--- /dev/null
+++ b/security/ftpmap/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: ftpmap
+# Date created: 01 Nov 2002
+# Whom: Sergei Kolobov <sergei@kolobov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ftpmap
+PORTVERSION= 0.4
+CATEGORIES= security ftp
+MASTER_SITES= ftp://ftp.pureftpd.org/pub/pure-ftpd/ftpmap/
+
+MAINTAINER= sergei@kolobov.com
+COMMENT= Identify remote FTP server software by fingerprinting
+
+GNU_CONFIGURE= yes
+
+DOCS= AUTHORS NEWS README THANKS
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>