aboutsummaryrefslogtreecommitdiffstats
path: root/security/fwbuilder
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-04-11 23:21:23 +0800
committermat <mat@FreeBSD.org>2017-04-11 23:21:23 +0800
commitaf9c60625bda3e97370cc91b90ea306f292c209d (patch)
tree5a5d971bd61fde66fbaa1b8da9469708d182ffc8 /security/fwbuilder
parente0cd3420489573ca501c588fae760fa3739e168c (diff)
downloadfreebsd-ports-gnome-af9c60625bda3e97370cc91b90ea306f292c209d.tar.gz
freebsd-ports-gnome-af9c60625bda3e97370cc91b90ea306f292c209d.tar.zst
freebsd-ports-gnome-af9c60625bda3e97370cc91b90ea306f292c209d.zip
Make defining both PORTVERSION and DISTVERSION a DEV_ERROR.
There are two cases: - The upstream versionning is compatible with our versionning, or using DISTVERSION's magic leads to a compatible PORTVERSION, use DISTVERSION. If it is possible to use DISTVERSIONPREFIX and DISTVERSIONSUFFIX to make it compatible, use them. - The upstream versionning is not compatible with our versionning, and DISTVERSION's magic does not lead to a correct PORTVERSION, then set PORTVERSION to the equivalent of our versionning, and set DISTNAME. It is possible to use a third variable where you store upstream's version and use it to compute PORTVERSION and/or DISTNAME, like the dns/bind9* ports do. Sponsored by: Absolight
Diffstat (limited to 'security/fwbuilder')
-rw-r--r--security/fwbuilder/Makefile17
1 files changed, 5 insertions, 12 deletions
diff --git a/security/fwbuilder/Makefile b/security/fwbuilder/Makefile
index 5b5010ba8e4c..525fd32ea9da 100644
--- a/security/fwbuilder/Makefile
+++ b/security/fwbuilder/Makefile
@@ -2,26 +2,19 @@
# $FreeBSD$
PORTNAME= fwbuilder
-DISTVERSION= 5.1.0
-PORTVERSION= ${DISTVERSION}
+PORTVERSION= 5.1.0
+DISTVERSIONSUFFIX= .${BUILD}
PORTREVISION= 3
CATEGORIES= security
-BUILD= 3599
-# XXX in developement version of this port: PKGNAMESUFFIX= -devel
-.if defined(PKGNAMESUFFIX) && ${PKGNAMESUFFIX} == -devel
-MASTER_SITES= http://www.fwbuilder.org/nightly_builds/fwbuilder-5.0/current_build/
-PORTVERSION= ${DISTVERSION}.b${BUILD}
-PORTREVISION= 1
-.else
MASTER_SITES= SF/${PORTNAME}/Current_Packages/${PORTVERSION}
-.endif
-DISTVERSIONSUFFIX= .${BUILD}
MAINTAINER= cy@FreeBSD.org
COMMENT= Firewall Builder GUI and policy compilers
#OPTIONS_DEFINE= DOCS
+BUILD= 3599
+
.if defined(PKGNAMESUFFIX) && ${PKGNAMESUFFIX} == -devel
CONFLICTS= fwbuilder-[234].* fwbuilder-devel-[234].* \
libfwbuilder-[234].* libfwbuilder-devel-[234].*
@@ -32,7 +25,7 @@ CONFLICTS= fwbuilder-[234].* fwbuilder-devel-* \
LIB_DEPENDS= libxslt.so:textproc/libxslt \
libnetsnmp.so:net-mgmt/net-snmp
-PLIST_SUB= BUILD_VERSION=${DISTVERSION}.${BUILD}
+PLIST_SUB= BUILD_VERSION=${PORTVERSION}.${BUILD}
USE_QT4= corelib \
gui \
iconengines \