aboutsummaryrefslogtreecommitdiffstats
path: root/security/fwipe
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-09-25 05:19:48 +0800
committermiwi <miwi@FreeBSD.org>2006-09-25 05:19:48 +0800
commit9592916e86504bc41e60fe6a76e0ffba441bd96c (patch)
tree7d91e7926af514ac576b8409660c1ddccf516ac6 /security/fwipe
parent529dedda6144c4fc43d686a67453a6cc453cff03 (diff)
downloadfreebsd-ports-gnome-9592916e86504bc41e60fe6a76e0ffba441bd96c.tar.gz
freebsd-ports-gnome-9592916e86504bc41e60fe6a76e0ffba441bd96c.tar.zst
freebsd-ports-gnome-9592916e86504bc41e60fe6a76e0ffba441bd96c.zip
Fwipe is a secure file erasing program. fwipe0, which actually erases
your files, is immune to filenames containing spaces, carriage returns, dashes, or any other special characters. You can use it in place of rm in cron jobs, together with "find ... -print0". The output of fwipe0 is specially designed to be parsed easily by machine, so it can be embedded in other applications which need secure file erasure. WWW: http://jeenyus.net/~budney/linux/software/fwipe.html PR: ports/103488 Submitted by: David Thiel <lx(at)redundancy.redundancy.org>
Diffstat (limited to 'security/fwipe')
-rw-r--r--security/fwipe/Makefile29
-rw-r--r--security/fwipe/distinfo3
-rw-r--r--security/fwipe/files/patch-hier.c14
-rw-r--r--security/fwipe/pkg-descr8
4 files changed, 54 insertions, 0 deletions
diff --git a/security/fwipe/Makefile b/security/fwipe/Makefile
new file mode 100644
index 000000000000..05f4cbd07448
--- /dev/null
+++ b/security/fwipe/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: wipe
+# Date created: 2006-09-22
+# Whom: David Thiel <lx@redundancy.redundancy.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fwipe
+PORTVERSION= 0.36
+CATEGORIES= security
+MASTER_SITES= http://jeenyus.net/~budney/linux/software/fwipe/ \
+ http://redundancy.redundancy.org/mirror/
+
+MAINTAINER= lx@redundancy.redundancy.org
+COMMENT= A djb-style file wiping utility
+
+ALL_TARGET= it
+INSTALL_TARGET= setup check
+
+PLIST_FILES= bin/fwipe bin/fwipe0 bin/echo0
+MAN1= fwipe0.1 echo0.1 fwipe.1
+
+post-extract:
+ @${ECHO_CMD} "${CC} ${CFLAGS}" > ${WRKSRC}/conf-cc
+ @${ECHO_CMD} "${CC} -s" > ${WRKSRC}/conf-ld
+ @${ECHO_CMD} "${PREFIX}" > ${WRKSRC}/conf-home
+ @${ECHO_CMD} "${PREFIX}" > ${WRKSRC}/conf-root
+
+.include <bsd.port.mk>
diff --git a/security/fwipe/distinfo b/security/fwipe/distinfo
new file mode 100644
index 000000000000..0894f0d6f116
--- /dev/null
+++ b/security/fwipe/distinfo
@@ -0,0 +1,3 @@
+MD5 (fwipe-0.36.tar.gz) = c314238c9612b617edceb3eb07c00816
+SHA256 (fwipe-0.36.tar.gz) = 43394c23d47b3d895243b32ee0e6efb546b73350718c5b376b6e7c72e26571b2
+SIZE (fwipe-0.36.tar.gz) = 28296
diff --git a/security/fwipe/files/patch-hier.c b/security/fwipe/files/patch-hier.c
new file mode 100644
index 000000000000..7fbb91692abd
--- /dev/null
+++ b/security/fwipe/files/patch-hier.c
@@ -0,0 +1,14 @@
+--- hier.c.orig Fri Sep 22 07:11:47 2006
++++ hier.c Fri Sep 22 07:12:15 2006
+@@ -10,11 +10,7 @@
+
+ d(auto_home,"man",-1,-1,02755);
+ d(auto_home,"man/man1",-1,-1,02755);
+- d(auto_home,"man/cat1",-1,-1,02755);
+ c(auto_home,"man/man1","fwipe0.1",-1,-1,0644);
+- c(auto_home,"man/cat1","fwipe0.0",-1,-1,0644);
+ c(auto_home,"man/man1","echo0.1",-1,-1,0644);
+- c(auto_home,"man/cat1","echo0.0",-1,-1,0644);
+ c(auto_home,"man/man1","fwipe.1",-1,-1,0644);
+- c(auto_home,"man/cat1","fwipe.0",-1,-1,0644);
+ }
diff --git a/security/fwipe/pkg-descr b/security/fwipe/pkg-descr
new file mode 100644
index 000000000000..217c0ff459fa
--- /dev/null
+++ b/security/fwipe/pkg-descr
@@ -0,0 +1,8 @@
+Fwipe is a secure file erasing program. fwipe0, which actually erases
+your files, is immune to filenames containing spaces, carriage returns,
+dashes, or any other special characters. You can use it in place of rm
+in cron jobs, together with "find ... -print0". The output of fwipe0 is
+specially designed to be parsed easily by machine, so it can be embedded
+in other applications which need secure file erasure.
+
+WWW: http://jeenyus.net/~budney/linux/software/fwipe.html