aboutsummaryrefslogtreecommitdiffstats
path: root/security/gcipher/Makefile
diff options
context:
space:
mode:
authorkbyanc <kbyanc@FreeBSD.org>2003-07-30 03:33:58 +0800
committerkbyanc <kbyanc@FreeBSD.org>2003-07-30 03:33:58 +0800
commit2051e5341ad95cfe9a88f00c1a562fc34cbdc0f2 (patch)
treea6e40cc65153aeb00a3fbde8f9eac2918549a094 /security/gcipher/Makefile
parent3018837764eb05f643fb38722cec1044adf7f1e9 (diff)
downloadfreebsd-ports-gnome-2051e5341ad95cfe9a88f00c1a562fc34cbdc0f2.tar.gz
freebsd-ports-gnome-2051e5341ad95cfe9a88f00c1a562fc34cbdc0f2.tar.zst
freebsd-ports-gnome-2051e5341ad95cfe9a88f00c1a562fc34cbdc0f2.zip
Add gcipher 1.0, a simple encryption tool.
PR: 53738 Submitted by: Shannon -jj Behrens <jjinux@yahoo.com>
Diffstat (limited to 'security/gcipher/Makefile')
-rw-r--r--security/gcipher/Makefile59
1 files changed, 59 insertions, 0 deletions
diff --git a/security/gcipher/Makefile b/security/gcipher/Makefile
new file mode 100644
index 000000000000..9a93bfa73bc3
--- /dev/null
+++ b/security/gcipher/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: gcipher
+# Date created: 25 June 2003
+# Whom: Shannon -jj Behrens <jjinux@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gcipher
+PORTVERSION= 1.0
+CATEGORIES= security gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= jjinux@yahoo.com
+COMMENT= A simple encryption tool
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gtk-2.0/gnome/uimodule.so:${PORTSDIR}/x11-toolkits/py-gnome2
+
+USE_PYTHON= yes
+USE_X_PREFIX= yes
+USE_GNOME= libgnomeui
+
+GCIPHER_PREFIX= ${PREFIX}/share/gnome/gcipher
+
+MAN1= gcipher.1
+
+do-build:
+ (cd ${WRKSRC}/src; \
+ ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py .)
+
+do-install:
+ ${MKDIR} \
+ ${GCIPHER_PREFIX}/lib/cipher \
+ ${GCIPHER_PREFIX}/lib/ciphergui \
+ ${GCIPHER_PREFIX}/plugins/cipher \
+ ${GCIPHER_PREFIX}/plugins/ciphergui
+
+ (cd ${WRKSRC}; \
+ ${INSTALL_MAN} gcipher.1 ${PREFIX}/man/man1; \
+ ${INSTALL_DATA} CONTRIB LICENSE README "${GCIPHER_PREFIX}")
+
+ (cd ${WRKSRC}/src; \
+ ${INSTALL_SCRIPT} gcipher ${PREFIX}/bin/gcipher; \
+ ${INSTALL_DATA} gcipher.desktop ${PREFIX}/share/gnome/applications; \
+ for i in `find . -name '*.py' \
+ -o -name '*.pyc' \
+ -o -name '*.glade' \
+ -o -name '*.gladep'`; do \
+ ${INSTALL_DATA} "$$i" "${GCIPHER_PREFIX}/lib/$$i"; \
+ done)
+
+ (cd ${WRKSRC}/plugins; \
+ for i in `find . -name '*.py' \
+ -o -name '*.glade' \
+ -o -name '*.gladep'`; do \
+ ${INSTALL_DATA} "$$i" "${GCIPHER_PREFIX}/plugins/$$i"; \
+ done)
+
+.include <bsd.port.mk>