aboutsummaryrefslogtreecommitdiffstats
path: root/security/git-crypt
diff options
context:
space:
mode:
authorashish <ashish@FreeBSD.org>2017-02-06 05:21:18 +0800
committerashish <ashish@FreeBSD.org>2017-02-06 05:21:18 +0800
commit2ddb0944017368192943c4d737a1f07d99e19698 (patch)
tree2e9564780e10ca10dceabfdb66e0028ba8657b23 /security/git-crypt
parent766087b5ea83ecaaaffe737d90df248e9f40ef0d (diff)
downloadfreebsd-ports-gnome-2ddb0944017368192943c4d737a1f07d99e19698.tar.gz
freebsd-ports-gnome-2ddb0944017368192943c4d737a1f07d99e19698.tar.zst
freebsd-ports-gnome-2ddb0944017368192943c4d737a1f07d99e19698.zip
git-crypt enables transparent encryption and decryption of files in a
git repository. Files which you choose to protect are encrypted when committed, and decrypted when checked out. git-crypt lets you freely share a repository containing a mix of public and private content. git-crypt gracefully degrades, so developers without the secret key can still clone and commit to a repository with encrypted files. This lets you store your secret material (such as keys or passwords) in the same repository as your code, without requiring you to lock down your entire repository. WWW: https://www.agwa.name/projects/git-crypt/
Diffstat (limited to 'security/git-crypt')
-rw-r--r--security/git-crypt/Makefile43
-rw-r--r--security/git-crypt/distinfo3
-rw-r--r--security/git-crypt/pkg-descr11
3 files changed, 57 insertions, 0 deletions
diff --git a/security/git-crypt/Makefile b/security/git-crypt/Makefile
new file mode 100644
index 000000000000..7c48cc4c754a
--- /dev/null
+++ b/security/git-crypt/Makefile
@@ -0,0 +1,43 @@
+# Created by: Ashish SHUKLA <ashish@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= git-crypt
+PORTVERSION= 0.5.0
+CATEGORIES= security
+MASTER_SITES= https://www.agwa.name/projects/git-crypt/downloads/ \
+ LOCAL/ashish/
+
+MAINTAINER= ashish@FreeBSD.org
+COMMENT= Transparent file encryption in git
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= git:devel/git \
+ gpg:security/gnupg
+
+OPTIONS_DEFINE= DOCS
+
+LDFLAGS+= -L${OPENSSLLIB}
+MAKE_ENV+= PREFIX=${PREFIX} "CXXFLAGS=${CXXFLAGS}" \
+ "LDFLAGS=${LDFLAGS}"
+
+DOCS_BUILD_DEPENDS= xsltproc:textproc/libxslt \
+ docbook-xsl>=0:textproc/docbook-xsl
+DOCS_MAKE_ARGS= ENABLE_MAN=yes \
+ MANDIR=${MANPREFIX}/man \
+ DOCBOOK_XSL=${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl
+DOCS_PLIST_FILES= man/man1/${PORTNAME}.1.gz
+
+USES= gmake ssl
+
+PLIST_FILES= bin/${PORTNAME}
+
+post-extract:
+ @${GREP} -Rl '"gpg"' ${WRKSRC} |${XARGS} ${REINPLACE_CMD} -e 's,"gpg","${LOCALBASE}/bin/gpg",'
+ @${GREP} -Rl '"git"' ${WRKSRC} |${XARGS} ${REINPLACE_CMD} -e 's,"git","${LOCALBASE}/bin/git",'
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/git-crypt
+
+.include <bsd.port.mk>
diff --git a/security/git-crypt/distinfo b/security/git-crypt/distinfo
new file mode 100644
index 000000000000..f4ac3cc8c121
--- /dev/null
+++ b/security/git-crypt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1486329625
+SHA256 (git-crypt-0.5.0.tar.gz) = 0a8f92c0a0a125bf768d0c054d947ca4e4b8d6556454b0e7e87fb907ee17cf06
+SIZE (git-crypt-0.5.0.tar.gz) = 56412
diff --git a/security/git-crypt/pkg-descr b/security/git-crypt/pkg-descr
new file mode 100644
index 000000000000..856fa63833c5
--- /dev/null
+++ b/security/git-crypt/pkg-descr
@@ -0,0 +1,11 @@
+git-crypt enables transparent encryption and decryption of files in a
+git repository. Files which you choose to protect are encrypted when
+committed, and decrypted when checked out. git-crypt lets you freely
+share a repository containing a mix of public and private
+content. git-crypt gracefully degrades, so developers without the
+secret key can still clone and commit to a repository with encrypted
+files. This lets you store your secret material (such as keys or
+passwords) in the same repository as your code, without requiring you
+to lock down your entire repository.
+
+WWW: https://www.agwa.name/projects/git-crypt/