aboutsummaryrefslogtreecommitdiffstats
path: root/security/gnome-keyring
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2009-01-10 13:22:13 +0800
committermarcus <marcus@FreeBSD.org>2009-01-10 13:22:13 +0800
commit6d8ed8f7c7511223163de715a97ffc04bf6fada9 (patch)
tree40dc015efe383243b0880df377f73ee250da7de7 /security/gnome-keyring
parentc7f342a8d7b82e85b9625c4403600fc20ce41da6 (diff)
downloadfreebsd-ports-gnome-6d8ed8f7c7511223163de715a97ffc04bf6fada9.tar.gz
freebsd-ports-gnome-6d8ed8f7c7511223163de715a97ffc04bf6fada9.tar.zst
freebsd-ports-gnome-6d8ed8f7c7511223163de715a97ffc04bf6fada9.zip
Presenting GNOME 2.24 for FreeBSD.
See http://library.gnome.org/misc/release-notes/2.24/ for the general release notes. On the FreeBSD front, this release introduces Fuse support in HAL, adds multi-CPU support to libgtop, WebKit updates, and fixes some long-standing seahorse and gnome-keyring bugs. The documentation updates to the website are forthcoming. This release features commits by adamw, ahze, kwm, mezz, and myself. It would not have been possible without are contributors and testers: Alexander Loginov Craig Butler [1] Dmitry Marakasov [6] Eric L. Chen Joseph S. Atkinson Kris Moore Lapo Luchini [7] Nikos Ntarmos Pawel Worach Romain Tartiere TAOKA Fumiyoshi [3] Yasuda Keisuke Zyl aZ [4] bf [2] [5] Florent Thoumie Peter Wemm pluknet PR: 125857 [1] 126993 [2] 130031 [3] 127399 [4] 127661 [5] 124302 [6] 129570 [7] 129936 123790
Diffstat (limited to 'security/gnome-keyring')
-rw-r--r--security/gnome-keyring/Makefile22
-rw-r--r--security/gnome-keyring/distinfo6
-rw-r--r--security/gnome-keyring/files/patch-common_gkr-daemon-util.h11
-rw-r--r--security/gnome-keyring/files/patch-configure40
-rw-r--r--security/gnome-keyring/files/patch-keyrings_gkr-keyrings.c10
-rw-r--r--security/gnome-keyring/files/patch-library_gnome-keyring.c11
-rw-r--r--security/gnome-keyring/files/patch-pam_gkr-pam-client.c18
-rw-r--r--security/gnome-keyring/files/patch-pkcs11_gkr-pkcs11-daemon.c10
-rw-r--r--security/gnome-keyring/pkg-plist31
9 files changed, 107 insertions, 52 deletions
diff --git a/security/gnome-keyring/Makefile b/security/gnome-keyring/Makefile
index 68c0a9bf8128..3ad743250648 100644
--- a/security/gnome-keyring/Makefile
+++ b/security/gnome-keyring/Makefile
@@ -3,12 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/security/gnome-keyring/Makefile,v 1.59 2008/03/09 18:30:40 mezz Exp $
+# $MCom: ports/security/gnome-keyring/Makefile,v 1.71 2009/01/10 01:59:21 mezz Exp $
#
PORTNAME= gnome-keyring
-PORTVERSION= 2.22.3
-PORTREVISION= 2
+PORTVERSION= 2.24.1
+PORTREVISION= 1
CATEGORIES= security gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -16,8 +16,7 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A program that keeps passwords and other secrets
-LIB_DEPENDS= hal.1:${PORTSDIR}/sysutils/hal \
- tasn1.3:${PORTSDIR}/security/libtasn1 \
+LIB_DEPENDS= tasn1.3:${PORTSDIR}/security/libtasn1 \
gcrypt.16:${PORTSDIR}/security/libgcrypt
USE_BZIP2= yes
@@ -31,4 +30,15 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
GCONF_SCHEMAS= gnome-keyring.schemas
-.include <bsd.port.mk>
+OPTIONS= HAL "Use HAL for keys on removable drives" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_HAL)
+LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
+CONFIGURE_ARGS+=--enable-hal
+.else
+CONFIGURE_ARGS+=--disable-hal
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/gnome-keyring/distinfo b/security/gnome-keyring/distinfo
index 20ddac0b6c41..ca5144c4a5e6 100644
--- a/security/gnome-keyring/distinfo
+++ b/security/gnome-keyring/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-keyring-2.22.3.tar.bz2) = f9e5cd9efac383076aaefc1086520656
-SHA256 (gnome2/gnome-keyring-2.22.3.tar.bz2) = 1e14eed00d386763352896e540929760264885e1296ac11cfb8ca1c08dcea7f6
-SIZE (gnome2/gnome-keyring-2.22.3.tar.bz2) = 894308
+MD5 (gnome2/gnome-keyring-2.24.1.tar.bz2) = aa5552dc129f3509ee39145b7f0bf977
+SHA256 (gnome2/gnome-keyring-2.24.1.tar.bz2) = 3c9eb7f45dd0026340635b9e1ee18c36a47541610aa5a7ef604ca645aa4763f9
+SIZE (gnome2/gnome-keyring-2.24.1.tar.bz2) = 1125993
diff --git a/security/gnome-keyring/files/patch-common_gkr-daemon-util.h b/security/gnome-keyring/files/patch-common_gkr-daemon-util.h
new file mode 100644
index 000000000000..ebc3f9680b4c
--- /dev/null
+++ b/security/gnome-keyring/files/patch-common_gkr-daemon-util.h
@@ -0,0 +1,11 @@
+--- common/gkr-daemon-util.h.orig 2008-08-04 13:36:06.000000000 -0400
++++ common/gkr-daemon-util.h 2008-08-04 13:36:18.000000000 -0400
+@@ -26,6 +26,8 @@
+
+ G_BEGIN_DECLS
+
++#include <sys/types.h>
++
+ #include <glib.h>
+ #include <glib-object.h>
+
diff --git a/security/gnome-keyring/files/patch-configure b/security/gnome-keyring/files/patch-configure
index 235656df1b7e..75016a356fcb 100644
--- a/security/gnome-keyring/files/patch-configure
+++ b/security/gnome-keyring/files/patch-configure
@@ -1,7 +1,25 @@
---- configure.orig 2008-02-11 21:29:42.000000000 -0500
-+++ configure 2008-02-11 21:29:51.000000000 -0500
-@@ -23793,7 +23793,7 @@ else
- tests_status="no"
+--- configure.orig 2008-07-22 21:14:15.000000000 -0400
++++ configure 2008-07-22 21:14:35.000000000 -0400
+@@ -25963,7 +25963,7 @@ fi
+
+ dbus_status=$DBUS_VERSION
+ fi
+- if test "$enable_dbus" == "yes"; then
++ if test "$enable_dbus" = "yes"; then
+ WITH_DBUS_TRUE=
+ WITH_DBUS_FALSE='#'
+ else
+@@ -27001,7 +27001,7 @@ if test "${enable_tests+set}" = set; the
+ fi
+
+
+-if test "$enable_tests" == "yes"; then
++if test "$enable_tests" = "yes"; then
+ echo "building tests and unit tests"
+
+ cat >>confdefs.h <<_ACEOF
+@@ -27014,7 +27014,7 @@ else
+ tests_status="no"
fi
- if test "$enable_tests" == "yes"; then
@@ -9,12 +27,12 @@
WITH_TESTS_TRUE=
WITH_TESTS_FALSE='#'
else
-@@ -25228,7 +25228,7 @@ fi
+@@ -27029,7 +27029,7 @@ if test "${enable_coverage+set}" = set;
+ fi
- dbus_status=$DBUS_VERSION
+
+-if test "$enable_coverage" == "yes"; then
++if test "$enable_coverage" = "yes"; then
+ CFLAGS="$CFLAGS -fprofile-arcs -ftest-coverage"
+ LDFLAGS="$LDFLAGS -fprofile-arcs -ftest-coverage"
fi
-- if test "$enable_dbus" == "yes"; then
-+ if test "$enable_dbus" = "yes"; then
- WITH_DBUS_TRUE=
- WITH_DBUS_FALSE='#'
- else
diff --git a/security/gnome-keyring/files/patch-keyrings_gkr-keyrings.c b/security/gnome-keyring/files/patch-keyrings_gkr-keyrings.c
deleted file mode 100644
index 185e929dd298..000000000000
--- a/security/gnome-keyring/files/patch-keyrings_gkr-keyrings.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- keyrings/gkr-keyrings.c.orig 2008-02-11 21:30:10.000000000 -0500
-+++ keyrings/gkr-keyrings.c 2008-02-11 21:30:19.000000000 -0500
-@@ -35,6 +35,7 @@
- #include <unistd.h>
- #include <fcntl.h>
- #include <errno.h>
-+#include <string.h>
- #include <stdlib.h>
- #include <stdio.h>
- #include <sys/types.h>
diff --git a/security/gnome-keyring/files/patch-library_gnome-keyring.c b/security/gnome-keyring/files/patch-library_gnome-keyring.c
deleted file mode 100644
index 625a65cc72c0..000000000000
--- a/security/gnome-keyring/files/patch-library_gnome-keyring.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- library/gnome-keyring.c.orig 2008-02-26 22:05:10.000000000 -0600
-+++ library/gnome-keyring.c 2008-02-26 22:05:30.000000000 -0600
-@@ -50,6 +50,8 @@
- #include <dbus/dbus.h>
- #endif
-
-+extern char **environ;
-+
- typedef enum {
- CALLBACK_DONE,
- CALLBACK_GET_STRING,
diff --git a/security/gnome-keyring/files/patch-pam_gkr-pam-client.c b/security/gnome-keyring/files/patch-pam_gkr-pam-client.c
new file mode 100644
index 000000000000..05a0306e6913
--- /dev/null
+++ b/security/gnome-keyring/files/patch-pam_gkr-pam-client.c
@@ -0,0 +1,18 @@
+--- pam/gkr-pam-client.c.orig 2008-10-07 12:25:23.000000000 -0400
++++ pam/gkr-pam-client.c 2008-10-07 12:38:36.000000000 -0400
+@@ -96,12 +96,12 @@ check_peer_same_uid (int sock)
+ struct xucred xuc;
+ socklen_t xuc_len = sizeof (xuc);
+
+- if (getsockopt (sock, SOL_SOCKET, LOCAL_PEERCRED, &xuc, &xuc_len) == 0 &&
+- xuc_len == sizeof (xuc)) {
++ if (getsockopt (sock, 0, LOCAL_PEERCRED, &xuc, &xuc_len) == 0 &&
++ xuc.cr_version == XUCRED_VERSION) {
+ uid = xuc.cr_uid;
+ } else {
+ syslog (GKR_LOG_ERR, "could not get gnome-keyring-daemon socket credentials, "
+- "(returned len %d/%d)\n", xuc_len, (int)sizeof (xuc));
++ "(returned version %d/%d)\n", xuc.cr_version, XUCRED_VERSION);
+ return -1;
+ }
+
diff --git a/security/gnome-keyring/files/patch-pkcs11_gkr-pkcs11-daemon.c b/security/gnome-keyring/files/patch-pkcs11_gkr-pkcs11-daemon.c
deleted file mode 100644
index 4bd5a923f4f4..000000000000
--- a/security/gnome-keyring/files/patch-pkcs11_gkr-pkcs11-daemon.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- pkcs11/gkr-pkcs11-daemon.c.orig 2008-02-11 21:30:48.000000000 -0500
-+++ pkcs11/gkr-pkcs11-daemon.c 2008-02-11 21:30:58.000000000 -0500
-@@ -35,6 +35,7 @@
- #include <sys/types.h>
- #include <sys/socket.h>
- #include <sys/un.h>
-+#include <string.h>
- #include <errno.h>
- #include <unistd.h>
-
diff --git a/security/gnome-keyring/pkg-plist b/security/gnome-keyring/pkg-plist
index c91389e36cd8..2b3fe4715134 100644
--- a/security/gnome-keyring/pkg-plist
+++ b/security/gnome-keyring/pkg-plist
@@ -1,7 +1,12 @@
+bin/gnome-keyring
bin/gnome-keyring-daemon
include/gnome-keyring-1/gnome-keyring-memory.h
include/gnome-keyring-1/gnome-keyring-result.h
include/gnome-keyring-1/gnome-keyring.h
+include/gp11/gp11.h
+include/gp11/pkcs11.h
+include/gp11/pkcs11g.h
+include/gp11/pkcs11n.h
lib/gnome-keyring/gnome-keyring-pkcs11.a
lib/gnome-keyring/gnome-keyring-pkcs11.la
lib/gnome-keyring/gnome-keyring-pkcs11.so
@@ -9,10 +14,15 @@ lib/libgnome-keyring.a
lib/libgnome-keyring.la
lib/libgnome-keyring.so
lib/libgnome-keyring.so.0
+lib/libgp11.a
+lib/libgp11.la
+lib/libgp11.so
+lib/libgp11.so.0
lib/pam_gnome_keyring.a
lib/pam_gnome_keyring.la
lib/pam_gnome_keyring.so
libdata/pkgconfig/gnome-keyring-1.pc
+libdata/pkgconfig/gp11-0.pc
libexec/gnome-keyring-ask
share/dbus-1/services/org.gnome.keyring.service
%%DOCSDIR%%/ch01.html
@@ -39,6 +49,20 @@ share/dbus-1/services/org.gnome.keyring.service
%%DOCSDIR%%/right.png
%%DOCSDIR%%/style.css
%%DOCSDIR%%/up.png
+share/doc/gp11/GP11Object.html
+share/doc/gp11/ch01.html
+share/doc/gp11/gp11-GP11Call.html
+share/doc/gp11/gp11-gp11-test.html
+share/doc/gp11/gp11-pkcs11.html
+share/doc/gp11/gp11.devhelp
+share/doc/gp11/gp11.devhelp2
+share/doc/gp11/home.png
+share/doc/gp11/index.html
+share/doc/gp11/index.sgml
+share/doc/gp11/left.png
+share/doc/gp11/right.png
+share/doc/gp11/style.css
+share/doc/gp11/up.png
share/locale/ar/LC_MESSAGES/gnome-keyring.mo
share/locale/az/LC_MESSAGES/gnome-keyring.mo
share/locale/be/LC_MESSAGES/gnome-keyring.mo
@@ -73,6 +97,7 @@ share/locale/is/LC_MESSAGES/gnome-keyring.mo
share/locale/it/LC_MESSAGES/gnome-keyring.mo
share/locale/ja/LC_MESSAGES/gnome-keyring.mo
share/locale/ka/LC_MESSAGES/gnome-keyring.mo
+share/locale/kn/LC_MESSAGES/gnome-keyring.mo
share/locale/ko/LC_MESSAGES/gnome-keyring.mo
share/locale/lt/LC_MESSAGES/gnome-keyring.mo
share/locale/lv/LC_MESSAGES/gnome-keyring.mo
@@ -100,7 +125,7 @@ share/locale/sk/LC_MESSAGES/gnome-keyring.mo
share/locale/sl/LC_MESSAGES/gnome-keyring.mo
share/locale/sq/LC_MESSAGES/gnome-keyring.mo
share/locale/sr/LC_MESSAGES/gnome-keyring.mo
-share/locale/sr@Latn/LC_MESSAGES/gnome-keyring.mo
+share/locale/sr@latin/LC_MESSAGES/gnome-keyring.mo
share/locale/sv/LC_MESSAGES/gnome-keyring.mo
share/locale/ta/LC_MESSAGES/gnome-keyring.mo
share/locale/te/LC_MESSAGES/gnome-keyring.mo
@@ -112,8 +137,10 @@ share/locale/xh/LC_MESSAGES/gnome-keyring.mo
share/locale/zh_CN/LC_MESSAGES/gnome-keyring.mo
share/locale/zh_HK/LC_MESSAGES/gnome-keyring.mo
share/locale/zh_TW/LC_MESSAGES/gnome-keyring.mo
+@dirrm share/doc/gp11
@dirrm %%DOCSDIR%%
@dirrm lib/gnome-keyring
+@dirrm include/gp11
@dirrm include/gnome-keyring-1
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@dirrmtry share/locale/zh_HK
@@ -121,6 +148,8 @@ share/locale/zh_TW/LC_MESSAGES/gnome-keyring.mo
@dirrmtry share/locale/xh
@dirrmtry share/locale/te/LC_MESSAGES
@dirrmtry share/locale/te
+@dirrmtry share/locale/sr@latin/LC_MESSAGES
+@dirrmtry share/locale/sr@latin
@dirrmtry share/locale/si/LC_MESSAGES
@dirrmtry share/locale/si
@dirrmtry share/locale/rw/LC_MESSAGES