aboutsummaryrefslogtreecommitdiffstats
path: root/security/gnupg
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2011-08-05 08:35:25 +0800
committerkuriyama <kuriyama@FreeBSD.org>2011-08-05 08:35:25 +0800
commit86660c68b6d073aaa40a277ef361cfa7451e668f (patch)
tree6197c932b0e481a28bae4c925ae165c2d851f9d8 /security/gnupg
parent6e01a2bb5e9f9500a0eb4b617ca4ceaf6505745d (diff)
downloadfreebsd-ports-gnome-86660c68b6d073aaa40a277ef361cfa7451e668f.tar.gz
freebsd-ports-gnome-86660c68b6d073aaa40a277ef361cfa7451e668f.tar.zst
freebsd-ports-gnome-86660c68b6d073aaa40a277ef361cfa7451e668f.zip
- Upgrade to 2.0.18:
- Support the SSH confirm flag and show SSH fingerprints in ssh related pinentries. - Improved dirmngr/gpgsm interaction for OCSP. - Allow generation of card keys up to 4096 bit. - Improve for port: - Remove patch that was incorporated into this release. - Remove redundant BUILD_DEPENDS. - Patching should be done in a -patch target. Silence the REINPLACE. Submitted by: dougb PR: ports/159520
Diffstat (limited to 'security/gnupg')
-rw-r--r--security/gnupg/Makefile10
-rw-r--r--security/gnupg/distinfo8
-rw-r--r--security/gnupg/files/patch-g10__pkglue.c24
3 files changed, 8 insertions, 34 deletions
diff --git a/security/gnupg/Makefile b/security/gnupg/Makefile
index e5706a2ef746..e5a1dbb3bd02 100644
--- a/security/gnupg/Makefile
+++ b/security/gnupg/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnupg
-PORTVERSION= 2.0.17
-PORTREVISION= 3
+PORTVERSION= 2.0.18
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG}
MASTER_SITE_SUBDIR= gnupg
@@ -17,7 +16,6 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= The GNU Privacy Guard
-BUILD_DEPENDS= libksba>=1.2.0:${PORTSDIR}/security/libksba
LIB_DEPENDS= assuan.0:${PORTSDIR}/security/libassuan \
gcrypt.18:${PORTSDIR}/security/libgcrypt \
gpg-error:${PORTSDIR}/security/libgpg-error \
@@ -115,10 +113,10 @@ CONFIGURE_ARGS+=--with-libcurl=${LOCALBASE}
verify: checksum
gpg2 --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.sig
-pre-configure:
- ${REINPLACE_CMD} -e "s@-lpthread@${PTHREAD_LIBS}@g" ${CONFIGURE_SUB} \
+post-patch:
+ @${REINPLACE_CMD} -e "s@-lpthread@${PTHREAD_LIBS}@g" ${CONFIGURE_SUB} \
${WRKSRC}/acinclude.m4 ${WRKSRC}/aclocal.m4 ${WRKSRC}/configure
- ${REINPLACE_CMD} -e "/#include <utmp.h>/d" \
+ @${REINPLACE_CMD} -e "/#include <utmp.h>/d" \
${WRKSRC}/tools/symcryptrun.c
post-install:
diff --git a/security/gnupg/distinfo b/security/gnupg/distinfo
index 52577e46648f..e4238d376fe5 100644
--- a/security/gnupg/distinfo
+++ b/security/gnupg/distinfo
@@ -1,4 +1,4 @@
-SHA256 (gnupg-2.0.17.tar.bz2) = ea649d5ecb2f97cc8d81c5796c6ad8d7d8581f9554241c39d2b11ab12139eea6
-SIZE (gnupg-2.0.17.tar.bz2) = 3997356
-SHA256 (gnupg-2.0.17.tar.bz2.sig) = 27918acebd48f93e3042c3b6f6396182bee2c9a5f0448d2063ce73986bb748ff
-SIZE (gnupg-2.0.17.tar.bz2.sig) = 287
+SHA256 (gnupg-2.0.18.tar.bz2) = 48aedd762ca443fb952a9e859efe3c66706d7c2c9c77c32dbdbac4fe962dae5b
+SIZE (gnupg-2.0.18.tar.bz2) = 4016606
+SHA256 (gnupg-2.0.18.tar.bz2.sig) = 9238f90e17589a421e6ba5c5d7bd9f68fbd1f1553198a3448fbdc887a38b975d
+SIZE (gnupg-2.0.18.tar.bz2.sig) = 287
diff --git a/security/gnupg/files/patch-g10__pkglue.c b/security/gnupg/files/patch-g10__pkglue.c
deleted file mode 100644
index cd1a8c3aed89..000000000000
--- a/security/gnupg/files/patch-g10__pkglue.c
+++ /dev/null
@@ -1,24 +0,0 @@
---- g10/pkglue.c.orig 2011-01-09 14:06:16.000000000 -0800
-+++ g10/pkglue.c 2011-07-12 21:32:41.000000000 -0700
-@@ -34,10 +34,10 @@
- {
- gcry_sexp_t list;
- gcry_mpi_t data;
--
-+
- list = gcry_sexp_find_token (sexp, item, 0);
- assert (list);
-- data = gcry_sexp_nth_mpi (list, 1, 0);
-+ data = gcry_sexp_nth_mpi (list, 1, GCRYMPI_FMT_USG);
- assert (data);
- gcry_sexp_release (list);
- return data;
-@@ -293,7 +293,7 @@
- if (rc)
- return rc;
-
-- *result = gcry_sexp_nth_mpi (s_plain, 0, 0);
-+ *result = gcry_sexp_nth_mpi (s_plain, 0, GCRYMPI_FMT_USG);
- gcry_sexp_release (s_plain);
- if (!*result)
- return -1; /* oops */