aboutsummaryrefslogtreecommitdiffstats
path: root/security/gnutls-devel
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-01-07 22:02:30 +0800
committeredwin <edwin@FreeBSD.org>2003-01-07 22:02:30 +0800
commit7d17c36ca17c3d98bfd7e9c79504769fb6115b11 (patch)
tree4cf5773c11ce53af3b27eb8772304411f767ae96 /security/gnutls-devel
parent73c545e1a8128bf1466ddd8689d6cb5c08a61ca2 (diff)
downloadfreebsd-ports-gnome-7d17c36ca17c3d98bfd7e9c79504769fb6115b11.tar.gz
freebsd-ports-gnome-7d17c36ca17c3d98bfd7e9c79504769fb6115b11.tar.zst
freebsd-ports-gnome-7d17c36ca17c3d98bfd7e9c79504769fb6115b11.zip
GnuTLS is a portable ANSI C based library which implements the TLS 1.0 and
SSL 3.0 protocols. The library does not include any patented algorithms and is available under the GNU Lesser GPL license. Important features of the GnuTLS library include: - Thread safety - Support for both TLS 1.0 and SSL 3.0 protocols - Support for both X.509 and OpenPGP certificates - Support for basic parsing and verification of certificates - Support for SRP for TLS authentication - Support for TLS Extension mechanism - Support for TLS Compression Methods Additionaly GnuTLS provides an emulation API for the widely used OpenSSL library, to ease integration with existing applications. WWW: http://www.gnutls.org/ PR: ports/45348 Submitted by: Sergei Kolobov <sergei@kolobov.com>
Diffstat (limited to 'security/gnutls-devel')
-rw-r--r--security/gnutls-devel/Makefile38
-rw-r--r--security/gnutls-devel/distinfo1
-rw-r--r--security/gnutls-devel/pkg-comment1
-rw-r--r--security/gnutls-devel/pkg-descr17
-rw-r--r--security/gnutls-devel/pkg-plist27
5 files changed, 84 insertions, 0 deletions
diff --git a/security/gnutls-devel/Makefile b/security/gnutls-devel/Makefile
new file mode 100644
index 000000000000..b1e6a1a78d66
--- /dev/null
+++ b/security/gnutls-devel/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: gnutls
+# Date created: 13 Nov 2002
+# Whom: Sergei Kolobov <sergei@kolobov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnutls
+PORTVERSION= 0.5.11
+CATEGORIES= security net
+MASTER_SITES= ftp://ftp.gnutls.org/pub/gnutls/ \
+ ftp://ftp.gnupg.org/pub/gcrypt/alpha/gnutls/ \
+ http://www.mirrors.wiretapped.net/security/network-security/gnutls/ \
+ ftp://ftp.mirrors.wiretapped.net/security/network-security/gnutls/ \
+
+MAINTAINER= sergei@kolobov.com
+
+LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt \
+ tasn1:${PORTSDIR}/security/libtasn1
+
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_TARGET=
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+
+DOCS= AUTHORS NEWS README THANKS
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/doc/tex/*.ps ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/gnutls-devel/distinfo b/security/gnutls-devel/distinfo
new file mode 100644
index 000000000000..35b3aaddb42c
--- /dev/null
+++ b/security/gnutls-devel/distinfo
@@ -0,0 +1 @@
+MD5 (gnutls-0.5.11.tar.gz) = 9e86b8fb85be918a17c6734391de103f
diff --git a/security/gnutls-devel/pkg-comment b/security/gnutls-devel/pkg-comment
new file mode 100644
index 000000000000..2436d4683c53
--- /dev/null
+++ b/security/gnutls-devel/pkg-comment
@@ -0,0 +1 @@
+GNU Transport Layer Security library
diff --git a/security/gnutls-devel/pkg-descr b/security/gnutls-devel/pkg-descr
new file mode 100644
index 000000000000..eb3b18b04920
--- /dev/null
+++ b/security/gnutls-devel/pkg-descr
@@ -0,0 +1,17 @@
+GnuTLS is a portable ANSI C based library which implements the TLS 1.0 and
+SSL 3.0 protocols. The library does not include any patented algorithms and
+is available under the GNU Lesser GPL license.
+
+Important features of the GnuTLS library include:
+- Thread safety
+- Support for both TLS 1.0 and SSL 3.0 protocols
+- Support for both X.509 and OpenPGP certificates
+- Support for basic parsing and verification of certificates
+- Support for SRP for TLS authentication
+- Support for TLS Extension mechanism
+- Support for TLS Compression Methods
+
+Additionaly GnuTLS provides an emulation API for the widely used
+OpenSSL library, to ease integration with existing applications.
+
+WWW: http://www.gnutls.org/
diff --git a/security/gnutls-devel/pkg-plist b/security/gnutls-devel/pkg-plist
new file mode 100644
index 000000000000..8e7a4c6ab718
--- /dev/null
+++ b/security/gnutls-devel/pkg-plist
@@ -0,0 +1,27 @@
+bin/libgnutls-config
+bin/libgnutls-extra-config
+bin/gnutls-serv
+bin/gnutls-cli
+bin/gnutls-srpcrypt
+bin/gnutls-cli-debug
+include/gnutls/extra.h
+include/gnutls/openssl.h
+include/gnutls/gnutls.h
+@dirrm include/gnutls
+lib/libgnutls.so.6
+lib/libgnutls.so
+lib/libgnutls.la
+lib/libgnutls.a
+lib/libgnutls-extra.so.6
+lib/libgnutls-extra.so
+lib/libgnutls-extra.la
+lib/libgnutls-extra.a
+share/aclocal/libgnutls.m4
+share/aclocal/libgnutls-extra.m4
+%%PORTDOCS%%share/doc/gnutls/AUTHORS
+%%PORTDOCS%%share/doc/gnutls/NEWS
+%%PORTDOCS%%share/doc/gnutls/README
+%%PORTDOCS%%share/doc/gnutls/THANKS
+%%PORTDOCS%%share/doc/gnutls/gnutls-logo.ps
+%%PORTDOCS%%share/doc/gnutls/gnutls.ps
+%%PORTDOCS%%@dirrm share/doc/gnutls