aboutsummaryrefslogtreecommitdiffstats
path: root/security/gnutls-devel
diff options
context:
space:
mode:
authortmclaugh <tmclaugh@FreeBSD.org>2006-05-18 00:42:13 +0800
committertmclaugh <tmclaugh@FreeBSD.org>2006-05-18 00:42:13 +0800
commit2ba5d97be0acc48d904d938eb879c2bf8cf954b1 (patch)
tree4bdd26b8b0638c3044a747e5d14880eec5154649 /security/gnutls-devel
parente73270811f664042bd3fcc9253c1e02468fffa1f (diff)
downloadfreebsd-ports-gnome-2ba5d97be0acc48d904d938eb879c2bf8cf954b1.tar.gz
freebsd-ports-gnome-2ba5d97be0acc48d904d938eb879c2bf8cf954b1.tar.zst
freebsd-ports-gnome-2ba5d97be0acc48d904d938eb879c2bf8cf954b1.zip
Move opencdk and libtasn1 detection to after bsd.port.pre.mk so they can
be properly detected if already installed.
Diffstat (limited to 'security/gnutls-devel')
-rw-r--r--security/gnutls-devel/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/security/gnutls-devel/Makefile b/security/gnutls-devel/Makefile
index 45c366fea575..d63636367543 100644
--- a/security/gnutls-devel/Makefile
+++ b/security/gnutls-devel/Makefile
@@ -23,14 +23,6 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/makeinfo:${PORTSDIR}/print/texinfo
LIB_DEPENDS= gcrypt.13:${PORTSDIR}/security/libgcrypt \
gpg-error.2:${PORTSDIR}/security/libgpg-error
-.if defined(WITH_OPENCDK) || exists(${LOCALBASE}/lib/libopencdk.so.8)
-LIB_DEPENDS+= opencdk.8:${PORTSDIR}/security/opencdk
-.endif
-
-.if defined(WITH_LIBTASN1) || exists(${LOCALBASE}/lib/libtasn1.so.3)
-LIB_DEPENDS+= tasn1.3:${PORTSDIR}/security/libtasn1
-.endif
-
CONFLICTS= gnutls-[0-9]*
USE_BZIP2= yes
@@ -47,6 +39,15 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-included-lzo --disable-static --disable-nls
MANCOMPRESSED= no
+.include <bsd.port.pre.mk>
+.if defined(WITH_OPENCDK) || exists(${LOCALBASE}/lib/libopencdk.so.8)
+LIB_DEPENDS+= opencdk.8:${PORTSDIR}/security/opencdk
+.endif
+
+.if defined(WITH_LIBTASN1) || exists(${LOCALBASE}/lib/libtasn1.so.3)
+LIB_DEPENDS+= tasn1.2:${PORTSDIR}/security/libtasn1
+.endif
+
.if !defined(NOPORTDOCS)
PORTDOCS= AUTHORS NEWS README THANKS
.endif
@@ -67,4 +68,4 @@ post-install:
.endif
.include "Makefile.man"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>