aboutsummaryrefslogtreecommitdiffstats
path: root/security/gnutls
diff options
context:
space:
mode:
authortmclaugh <tmclaugh@FreeBSD.org>2006-05-18 00:42:13 +0800
committertmclaugh <tmclaugh@FreeBSD.org>2006-05-18 00:42:13 +0800
commit2ba5d97be0acc48d904d938eb879c2bf8cf954b1 (patch)
tree4bdd26b8b0638c3044a747e5d14880eec5154649 /security/gnutls
parente73270811f664042bd3fcc9253c1e02468fffa1f (diff)
downloadfreebsd-ports-gnome-2ba5d97be0acc48d904d938eb879c2bf8cf954b1.tar.gz
freebsd-ports-gnome-2ba5d97be0acc48d904d938eb879c2bf8cf954b1.tar.zst
freebsd-ports-gnome-2ba5d97be0acc48d904d938eb879c2bf8cf954b1.zip
Move opencdk and libtasn1 detection to after bsd.port.pre.mk so they can
be properly detected if already installed.
Diffstat (limited to 'security/gnutls')
-rw-r--r--security/gnutls/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/security/gnutls/Makefile b/security/gnutls/Makefile
index 07120466f8f3..15106092245c 100644
--- a/security/gnutls/Makefile
+++ b/security/gnutls/Makefile
@@ -21,14 +21,6 @@ COMMENT= GNU Transport Layer Security library
LIB_DEPENDS= gcrypt.13:${PORTSDIR}/security/libgcrypt \
gpg-error.2:${PORTSDIR}/security/libgpg-error
-.if defined(WITH_OPENCDK) || exists(${LOCALBASE}/lib/libopencdk.so.8)
-LIB_DEPENDS+= opencdk.8:${PORTSDIR}/security/opencdk
-.endif
-
-.if defined(WITH_LIBTASN1) || exists(${LOCALBASE}/lib/libtasn1.so.3)
-LIB_DEPENDS+= tasn1.3:${PORTSDIR}/security/libtasn1
-.endif
-
CONFLICTS= gnutls-devel-[0-9]*
USE_BZIP2= yes
@@ -46,6 +38,14 @@ CONFIGURE_ARGS+= --with-included-lzo --with-included-libtasn1
MANCOMPRESSED= no
.include <bsd.port.pre.mk>
+.if defined(WITH_OPENCDK) || exists(${LOCALBASE}/lib/libopencdk.so.8)
+LIB_DEPENDS+= opencdk.8:${PORTSDIR}/security/opencdk
+.endif
+
+.if defined(WITH_LIBTASN1) || exists(${LOCALBASE}/lib/libtasn1.so.3)
+LIB_DEPENDS+= tasn1.2:${PORTSDIR}/security/libtasn1
+.endif
+
.if ${OSVERSION} < 600000
BUILD_DEPENDS+= ${LOCALBASE}/bin/makeinfo:${PORTSDIR}/print/texinfo
.endif