aboutsummaryrefslogtreecommitdiffstats
path: root/security/gnutls
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-05-01 02:20:12 +0800
committertijl <tijl@FreeBSD.org>2014-05-01 02:20:12 +0800
commit8f4560bd19664eafe8286da19144a38042ab58d4 (patch)
tree0240ef3bb2725051e2911a4cdb7f58154b3866fd /security/gnutls
parent53ea8149c71ef3a53d62c459cf40eb505c9287e0 (diff)
downloadfreebsd-ports-gnome-8f4560bd19664eafe8286da19144a38042ab58d4.tar.gz
freebsd-ports-gnome-8f4560bd19664eafe8286da19144a38042ab58d4.tar.zst
freebsd-ports-gnome-8f4560bd19664eafe8286da19144a38042ab58d4.zip
- New LIB_DEPENDS syntax.
- USES=libtool:keepla tar:bzip2. - Remove -fPIC flag. Leftover from an old version.
Diffstat (limited to 'security/gnutls')
-rw-r--r--security/gnutls/Makefile19
-rw-r--r--security/gnutls/pkg-plist10
2 files changed, 14 insertions, 15 deletions
diff --git a/security/gnutls/Makefile b/security/gnutls/Makefile
index df799a47ae57..009e98c310a0 100644
--- a/security/gnutls/Makefile
+++ b/security/gnutls/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnutls
PORTVERSION= 2.12.23
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= security net
MASTER_SITES= \
ftp://ftp.gnutls.org/gcrypt/gnutls/v${PORTVERSION:C/.[0-9]+$//}/ \
@@ -14,24 +14,19 @@ COMMENT= GNU Transport Layer Security library
LICENSE= GPLv3
-LIB_DEPENDS= nettle:${PORTSDIR}/security/nettle \
- gpg-error:${PORTSDIR}/security/libgpg-error \
- p11-kit:${PORTSDIR}/security/p11-kit
+LIB_DEPENDS= libnettle.so:${PORTSDIR}/security/nettle \
+ libgpg-error.so:${PORTSDIR}/security/libgpg-error \
+ libp11-kit.so:${PORTSDIR}/security/p11-kit
CONFLICTS= gnutls-devel-[0-9]*
-USES= pathfix pkgconfig iconv gmake perl5 shebangfix
+USES= gmake iconv libtool:keepla pathfix perl5 pkgconfig shebangfix tar:bzip2
USE_PERL5= build
-USE_BZIP2= yes
-USE_GNOME= ltverhack
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_AUTOTOOLS= libtool
-LIBTOOLFILES= configure lib/configure libextra/configure
SHEBANG_FILES= doc/scripts/gdoc doc/scripts/sort2.pl
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CPPFLAGS+= -fPIC
CONFIGURE_ARGS+= --disable-guile
CONFIGURE_ARGS_PREFIX= ${STAGEDIR}${PREFIX}
@@ -48,13 +43,13 @@ OPTIONS_DEFAULT= LIBTASN1 CXX
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MLIBTASN1}
-LIB_DEPENDS+= tasn1:${PORTSDIR}/security/libtasn1
+LIB_DEPENDS+= libtasn1.so:${PORTSDIR}/security/libtasn1
.else
CONFIGURE_ARGS+= --with-included-libtasn1
.endif
.if ${PORT_OPTIONS:MLZO}
-LIB_DEPENDS+= lzo2:${PORTSDIR}/archivers/lzo2
+LIB_DEPENDS+= liblzo2.so:${PORTSDIR}/archivers/lzo2
CONFIGURE_ARGS+= --with-lzo
.else
CONFIGURE_ARGS+= --with-lzo=no
diff --git a/security/gnutls/pkg-plist b/security/gnutls/pkg-plist
index c8bb17925bf2..5c69083f7081 100644
--- a/security/gnutls/pkg-plist
+++ b/security/gnutls/pkg-plist
@@ -29,22 +29,26 @@ include/gnutls/pkcs11.h
include/gnutls/pkcs12.h
include/gnutls/x509.h
%%CXX%%include/gnutls/gnutlsxx.h
-%%CXX%%lib/libgnutlsxx.so.27
-%%CXX%%lib/libgnutlsxx.so
-%%CXX%%lib/libgnutlsxx.la
%%CXX%%lib/libgnutlsxx.a
+%%CXX%%lib/libgnutlsxx.la
+%%CXX%%lib/libgnutlsxx.so
+%%CXX%%lib/libgnutlsxx.so.27
+%%CXX%%lib/libgnutlsxx.so.27.0.0
lib/libgnutls-extra.a
lib/libgnutls-extra.la
lib/libgnutls-extra.so
lib/libgnutls-extra.so.26
+lib/libgnutls-extra.so.26.22.6
lib/libgnutls-openssl.a
lib/libgnutls-openssl.la
lib/libgnutls-openssl.so
lib/libgnutls-openssl.so.27
+lib/libgnutls-openssl.so.27.0.0
lib/libgnutls.a
lib/libgnutls.la
lib/libgnutls.so
lib/libgnutls.so.26
+lib/libgnutls.so.26.22.6
libdata/pkgconfig/gnutls-extra.pc
libdata/pkgconfig/gnutls.pc
man/man1/certtool.1.gz