aboutsummaryrefslogtreecommitdiffstats
path: root/security/go.crypto
diff options
context:
space:
mode:
authorjlaffaye <jlaffaye@FreeBSD.org>2013-07-07 18:02:54 +0800
committerjlaffaye <jlaffaye@FreeBSD.org>2013-07-07 18:02:54 +0800
commitf59fce61bd14964a94245ef49bee6f1682c353a8 (patch)
tree59bb5c23d70adde95a03ade6e16ddc13c87303ee /security/go.crypto
parentdc9cf1a28ac124bb53bb800ed84b57a24529c31c (diff)
downloadfreebsd-ports-gnome-f59fce61bd14964a94245ef49bee6f1682c353a8.tar.gz
freebsd-ports-gnome-f59fce61bd14964a94245ef49bee6f1682c353a8.tar.zst
freebsd-ports-gnome-f59fce61bd14964a94245ef49bee6f1682c353a8.zip
- Update to 20130706 snapshot.
- Fix build with go 1.1
Diffstat (limited to 'security/go.crypto')
-rw-r--r--security/go.crypto/Makefile5
-rw-r--r--security/go.crypto/distinfo4
-rw-r--r--security/go.crypto/pkg-plist18
3 files changed, 20 insertions, 7 deletions
diff --git a/security/go.crypto/Makefile b/security/go.crypto/Makefile
index cbcac6ce2ac4..549de23edeb0 100644
--- a/security/go.crypto/Makefile
+++ b/security/go.crypto/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= go.crypto
-PORTVERSION= 20121001
+PORTVERSION= 20130706
CATEGORIES= security devel
MASTER_SITES= http://jlaffaye.net/ LOCAL/jlaffaye
@@ -25,6 +25,7 @@ GO_TARGET= ${GO_PKGNAME}/bcrypt \
${GO_PKGNAME}/ripemd160 \
${GO_PKGNAME}/salsa20 \
${GO_PKGNAME}/scrypt \
+ ${GO_PKGNAME}/sha3 \
${GO_PKGNAME}/ssh \
${GO_PKGNAME}/twofish \
${GO_PKGNAME}/xtea \
@@ -35,8 +36,6 @@ do-install:
(cd ${GO_WRKDIR_PKG}/ && ${COPYTREE_SHARE} \* \
${GO_LOCAL_LIBDIR})
.for t in ${GO_TARGET}
- #${INSTALL_DATA} ${GO_WRKDIR_PKG}/${t}.a \
- # ${GO_LOCAL_LIBDIR}/${GO_PKGNAME}
${MKDIR} ${GO_LOCAL_SRCDIR}/${t}
(cd ${GO_WRKDIR_SRC}/${t}/ && ${COPYTREE_SHARE} \* \
${GO_LOCAL_SRCDIR}/${t})
diff --git a/security/go.crypto/distinfo b/security/go.crypto/distinfo
index 6db872962462..095d26db660a 100644
--- a/security/go.crypto/distinfo
+++ b/security/go.crypto/distinfo
@@ -1,2 +1,2 @@
-SHA256 (go.crypto-20121001.tar.gz) = eda7f931041b17e4ce6757819f7fea87edf2c0371d5d360eabb31f9d929134d6
-SIZE (go.crypto-20121001.tar.gz) = 233879
+SHA256 (go.crypto-20130706.tar.gz) = bbff726f916947a1ad89686b5cbd4caf394ac098ea90f071e75221488b23f7c2
+SIZE (go.crypto-20130706.tar.gz) = 265534
diff --git a/security/go.crypto/pkg-plist b/security/go.crypto/pkg-plist
index 667814ff8cd8..ab174c62dffa 100644
--- a/security/go.crypto/pkg-plist
+++ b/security/go.crypto/pkg-plist
@@ -21,6 +21,7 @@
%%GO_LIBDIR%%/%%GO_PKGNAME%%/salsa20.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/salsa20/salsa.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/scrypt.a
+%%GO_LIBDIR%%/%%GO_PKGNAME%%/sha3.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/ssh.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/twofish.a
%%GO_LIBDIR%%/%%GO_PKGNAME%%/xtea.a
@@ -83,6 +84,8 @@
%%GO_SRCDIR%%/%%GO_PKGNAME%%/openpgp/packet/ocfb.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/openpgp/packet/ocfb_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/openpgp/packet/one_pass_signature.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/openpgp/packet/opaque.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/openpgp/packet/opaque_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/openpgp/packet/packet.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/openpgp/packet/packet_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/openpgp/packet/private_key.go
@@ -129,6 +132,9 @@
%%GO_SRCDIR%%/%%GO_PKGNAME%%/salsa20/salsa20_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/scrypt/scrypt.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/scrypt/scrypt_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/sha3/keccakf.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/sha3/sha3.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/sha3/sha3_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/agent.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/buffer.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/buffer_test.go
@@ -139,7 +145,6 @@
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/client.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/client_auth.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/client_auth_test.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/client_func_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/common.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/common_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/doc.go
@@ -153,10 +158,17 @@
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/session.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/session_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/tcpip.go
-%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/tcpip_func_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/terminal/terminal.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/terminal/terminal_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/terminal/util.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/terminal/util_bsd.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/terminal/util_linux.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/test/doc.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/test/forward_unix_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/test/keys_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/test/session_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/test/tcpip_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/test/test_unix_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/transport.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/transport_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/twofish/twofish.go
@@ -175,8 +187,10 @@
@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/xts
@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/xtea
@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/twofish
+@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/test
@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh/terminal
@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/ssh
+@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/sha3
@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/scrypt
@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/salsa20/salsa
@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/salsa20