aboutsummaryrefslogtreecommitdiffstats
path: root/security/gpa
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2010-06-23 06:35:54 +0800
committerdougb <dougb@FreeBSD.org>2010-06-23 06:35:54 +0800
commitc5cf11974fcf2042c5adf6d7bd6911baa6d919f9 (patch)
tree0b9d3b93e8e9bb0b1051e8f8f6bfd29d860fb103 /security/gpa
parent91342df67bd504ed17b0800d4e34e369f383fd75 (diff)
downloadfreebsd-ports-gnome-c5cf11974fcf2042c5adf6d7bd6911baa6d919f9.tar.gz
freebsd-ports-gnome-c5cf11974fcf2042c5adf6d7bd6911baa6d919f9.tar.zst
freebsd-ports-gnome-c5cf11974fcf2042c5adf6d7bd6911baa6d919f9.zip
- Update security/gpgme to version 1.3.0.
- No shlib bump. - This version works with libassuan 2.x and is needed to fix the build of security/gpa due to dependency conflicts. - Add LICENSE PR: ports/148061 - Fix the build of security/gpa with libassuan 2.x - Patch for server.c taken from gpa svn. - Add LICENSE while here. PR: ports/148062 Submitted by: Jason E. Hale <bsdkaffee@gmail.com> (maintainer) Feature safe: yes
Diffstat (limited to 'security/gpa')
-rw-r--r--security/gpa/Makefile11
-rw-r--r--security/gpa/files/patch-configure13
-rw-r--r--security/gpa/files/patch-src__server.c374
3 files changed, 394 insertions, 4 deletions
diff --git a/security/gpa/Makefile b/security/gpa/Makefile
index dee694f78b5f..7d9d3bf2abc3 100644
--- a/security/gpa/Makefile
+++ b/security/gpa/Makefile
@@ -7,16 +7,16 @@
PORTNAME= gpa
PORTVERSION= 0.9.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= security
MASTER_SITES= http://wald.intevation.org/frs/download.php/603/
MAINTAINER= bsdkaffee@gmail.com
COMMENT= A graphical frontend for the GNU Privacy Guard
-LIB_DEPENDS= gpgme.18:${PORTSDIR}/security/gpgme
-BUILD_DEPENDS= gpgv2:${PORTSDIR}/security/gnupg \
- libassuan-1>=1.0.5:${PORTSDIR}/security/libassuan-1
+LIB_DEPENDS= assuan.0:${PORTSDIR}/security/libassuan \
+ gpgme.18:${PORTSDIR}/security/gpgme
+BUILD_DEPENDS= gpgv2:${PORTSDIR}/security/gnupg
RUN_DEPENDS= gpgv2:${PORTSDIR}/security/gnupg
USE_BZIP2= yes
@@ -27,6 +27,9 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib" \
GPGKEYS_LDAP="${LOCALBASE}/libexec/gpg2keys_ldap"
MAKE_JOBS_SAFE= yes
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
OPTIONS= NLS "Native language support" on
.include <bsd.port.pre.mk>
diff --git a/security/gpa/files/patch-configure b/security/gpa/files/patch-configure
new file mode 100644
index 000000000000..82791bea7020
--- /dev/null
+++ b/security/gpa/files/patch-configure
@@ -0,0 +1,13 @@
+--- ./configure.orig 2010-06-22 05:32:25.000000000 -0400
++++ ./configure 2010-06-22 05:33:16.000000000 -0400
+@@ -1808,8 +1808,8 @@
+
+
+ NEED_GPG_ERROR_VERSION=1.4
+-NEED_LIBASSUAN_API=1
+-NEED_LIBASSUAN_VERSION=1.0.4
++NEED_LIBASSUAN_API=2
++NEED_LIBASSUAN_VERSION=1.1.0
+ NEED_GPGME_API=1
+ NEED_GPGME_VERSION=1.2.0
+
diff --git a/security/gpa/files/patch-src__server.c b/security/gpa/files/patch-src__server.c
new file mode 100644
index 000000000000..e4547bd21463
--- /dev/null
+++ b/security/gpa/files/patch-src__server.c
@@ -0,0 +1,374 @@
+--- ./src/server.c.orig 2009-05-13 03:11:11.000000000 -0400
++++ ./src/server.c 2010-06-22 05:31:57.000000000 -0400
+@@ -568,7 +568,7 @@
+ the last command. A RESET command undoes the effect of this
+ command.
+ */
+-static int
++static gpg_error_t
+ cmd_session (assuan_context_t ctx, char *line)
+ {
+ conn_ctrl_t ctrl = assuan_get_pointer (ctx);
+@@ -594,7 +594,7 @@
+ validity right away; if it does not (as here) all recipients are
+ checked at the time of the ENCRYPT command. All RECIPIENT commands
+ are cumulative until a RESET or an successful ENCRYPT command. */
+-static int
++static gpg_error_t
+ cmd_recipient (assuan_context_t ctx, char *line)
+ {
+ conn_ctrl_t ctrl = assuan_get_pointer (ctx);
+@@ -615,7 +615,7 @@
+ Set the file descriptor to read a message which is used with
+ detached signatures.
+ */
+-static int
++static gpg_error_t
+ cmd_message (assuan_context_t ctx, char *line)
+ {
+ conn_ctrl_t ctrl = assuan_get_pointer (ctx);
+@@ -659,7 +659,7 @@
+
+ Encrypt the data received on INPUT to OUTPUT.
+ */
+-static int
++static gpg_error_t
+ cmd_encrypt (assuan_context_t ctx, char *line)
+ {
+ conn_ctrl_t ctrl = assuan_get_pointer (ctx);
+@@ -755,7 +755,7 @@
+
+ Dummy encryption command used to check whether the given recipients
+ are all valid and to tell the client the preferred protocol. */
+-static int
++static gpg_error_t
+ cmd_prep_encrypt (assuan_context_t ctx, char *line)
+ {
+ conn_ctrl_t ctrl = assuan_get_pointer (ctx);
+@@ -814,7 +814,7 @@
+ @code{RESET} command. A second command overrides the effect of
+ the first one; if EMAIL is not given the server shall use the
+ default signing key. */
+-static int
++static gpg_error_t
+ cmd_sender (assuan_context_t ctx, char *line)
+ {
+ conn_ctrl_t ctrl = assuan_get_pointer (ctx);
+@@ -867,7 +867,7 @@
+
+ Sign the data received on INPUT to OUTPUT.
+ */
+-static int
++static gpg_error_t
+ cmd_sign (assuan_context_t ctx, char *line)
+ {
+ conn_ctrl_t ctrl = assuan_get_pointer (ctx);
+@@ -943,7 +943,7 @@
+ If the option --no-verify is given, the server should not try to
+ verify a signature, in case the input data is an OpenPGP combined
+ message. */
+-static int
++static gpg_error_t
+ cmd_decrypt (assuan_context_t ctx, char *line)
+ {
+ conn_ctrl_t ctrl = assuan_get_pointer (ctx);
+@@ -1058,7 +1058,7 @@
+
+ The DISPLAYSTRING is a percent-and-plus-encoded string with a short
+ human readable description of the status. */
+-static int
++static gpg_error_t
+ cmd_verify (assuan_context_t ctx, char *line)
+ {
+ conn_ctrl_t ctrl = assuan_get_pointer (ctx);
+@@ -1143,7 +1143,7 @@
+ manager is brought into the foregound and that this command
+ immediatley returns.
+ */
+-static int
++static gpg_error_t
+ cmd_start_keymanager (assuan_context_t ctx, char *line)
+ {
+ gpa_open_key_manager (NULL, NULL);
+@@ -1157,7 +1157,7 @@
+ manager is brought into the foregound and that this command
+ immediatley returns.
+ */
+-static int
++static gpg_error_t
+ cmd_start_cardmanager (assuan_context_t ctx, char *line)
+ {
+ gpa_open_cardmanager (NULL, NULL);
+@@ -1172,7 +1172,7 @@
+ manager is brought into the foregound and that this command
+ immediatley returns.
+ */
+-static int
++static gpg_error_t
+ cmd_start_confdialog (assuan_context_t ctx, char *line)
+ {
+ gpa_open_settings_dialog (NULL, NULL);
+@@ -1191,7 +1191,7 @@
+ version - Return the version of the program.
+ pid - Return the process id of the server.
+ */
+-static int
++static gpg_error_t
+ cmd_getinfo (assuan_context_t ctx, char *line)
+ {
+ gpg_error_t err;
+@@ -1295,7 +1295,7 @@
+
+ Set the files on which to operate.
+ */
+-static int
++static gpg_error_t
+ cmd_file (assuan_context_t ctx, char *line)
+ {
+ gpg_error_t err = 0;
+@@ -1366,7 +1366,7 @@
+
+
+ /* ENCRYPT_FILES --nohup */
+-static int
++static gpg_error_t
+ cmd_encrypt_files (assuan_context_t ctx, char *line)
+ {
+ gpg_error_t err;
+@@ -1389,7 +1389,7 @@
+
+
+ /* SIGN_FILES --nohup */
+-static int
++static gpg_error_t
+ cmd_sign_files (assuan_context_t ctx, char *line)
+ {
+ gpg_error_t err;
+@@ -1412,7 +1412,7 @@
+
+
+ /* ENCRYPT_SIGN_FILES --nohup */
+-static int
++static gpg_error_t
+ cmd_encrypt_sign_files (assuan_context_t ctx, char *line)
+ {
+ gpg_error_t err;
+@@ -1474,7 +1474,7 @@
+
+
+ /* DECRYPT_FILES --nohup */
+-static int
++static gpg_error_t
+ cmd_decrypt_files (assuan_context_t ctx, char *line)
+ {
+ gpg_error_t err;
+@@ -1497,7 +1497,7 @@
+
+
+ /* VERIFY_FILES --nohup */
+-static int
++static gpg_error_t
+ cmd_verify_files (assuan_context_t ctx, char *line)
+ {
+ gpg_error_t err;
+@@ -1520,7 +1520,7 @@
+
+
+ /* DECRYPT_VERIFY_FILES --nohup */
+-static int
++static gpg_error_t
+ cmd_decrypt_verify_files (assuan_context_t ctx, char *line)
+ {
+ gpg_error_t err;
+@@ -1543,7 +1543,7 @@
+
+
+ /* IMPORT_FILES --nohup */
+-static int
++static gpg_error_t
+ cmd_import_files (assuan_context_t ctx, char *line)
+ {
+ gpg_error_t err;
+@@ -1567,7 +1567,7 @@
+
+
+ /* CHECKSUM_CREATE_FILES --nohup */
+-static int
++static gpg_error_t
+ cmd_checksum_create_files (assuan_context_t ctx, char *line)
+ {
+ gpg_error_t err;
+@@ -1591,7 +1591,7 @@
+
+
+ /* CHECKSUM_VERIFY_FILES --nohup */
+-static int
++static gpg_error_t
+ cmd_checksum_verify_files (assuan_context_t ctx, char *line)
+ {
+ gpg_error_t err;
+@@ -1614,8 +1614,8 @@
+ }
+
+
+-static void
+-reset_notify (assuan_context_t ctx)
++static gpg_error_t
++reset_notify (assuan_context_t ctx, char *line)
+ {
+ conn_ctrl_t ctrl = assuan_get_pointer (ctx);
+
+@@ -1639,6 +1639,7 @@
+ ctrl->session_number = 0;
+ xfree (ctrl->session_title);
+ ctrl->session_title = NULL;
++ return 0;
+ }
+
+
+@@ -1648,7 +1649,7 @@
+ {
+ static struct {
+ const char *name;
+- int (*handler)(assuan_context_t, char *line);
++ assuan_handler_t handler;
+ } table[] = {
+ { "SESSION", cmd_session },
+ { "RECIPIENT", cmd_recipient },
+@@ -1681,7 +1682,8 @@
+
+ for (i=0; table[i].name; i++)
+ {
+- rc = assuan_register_command (ctx, table[i].name, table[i].handler);
++ rc = assuan_register_command (ctx, table[i].name, table[i].handler,
++ NULL);
+ if (rc)
+ return rc;
+ }
+@@ -1692,7 +1694,7 @@
+
+ /* Prepare for a new connection on descriptor FD. */
+ static assuan_context_t
+-connection_startup (int fd)
++connection_startup (assuan_fd_t fd)
+ {
+ gpg_error_t err;
+ assuan_context_t ctx;
+@@ -1700,7 +1702,16 @@
+
+ /* Get an Assuan context for the already accepted file descriptor
+ FD. Allow descriptor passing. */
+- err = assuan_init_socket_server_ext (&ctx, ASSUAN_INT2FD(fd), 1|2);
++ err = assuan_new (&ctx);
++ if (err)
++ {
++ g_debug ("failed to initialize the new connection: %s",
++ gpg_strerror (err));
++ return NULL;
++ }
++
++ err = assuan_init_socket_server (ctx, fd, ASSUAN_SOCKET_SERVER_FDPASSING
++ | ASSUAN_SOCKET_SERVER_ACCEPTED);
+ if (err)
+ {
+ g_debug ("failed to initialize the new connection: %s",
+@@ -1712,7 +1723,7 @@
+ {
+ g_debug ("failed to register commands with Assuan: %s",
+ gpg_strerror (err));
+- assuan_deinit_server (ctx);
++ assuan_release (ctx);
+ return NULL;
+ }
+
+@@ -1736,8 +1747,8 @@
+ {
+ conn_ctrl_t ctrl = assuan_get_pointer (ctx);
+
+- reset_notify (ctx);
+- assuan_deinit_server (ctx);
++ reset_notify (ctx, NULL);
++ assuan_release (ctx);
+ g_free (ctrl);
+ connection_counter--;
+ if (!connection_counter && shutdown_pending)
+@@ -1805,14 +1816,23 @@
+ }
+ else
+ {
++ int done = 0;
+ ctrl->in_command++;
+- err = assuan_process_next (ctx);
++ err = assuan_process_next (ctx, &done);
+ ctrl->in_command--;
+- g_debug ("assuan_process_next returned: %s",
+- err == -1? "EOF": gpg_strerror (err));
++ if (err)
++ {
++ g_debug ("assuan_process_next returned: %s <%s>",
++ gpg_strerror (err), gpg_strsource (err));
++ }
++ else
++ {
++ g_debug ("assuan_process_next returned: %s",
++ done ? "done" : "success");
++ }
+ if (gpg_err_code (err) == GPG_ERR_EAGAIN)
+ ; /* Ignore. */
+- else if (gpg_err_code (err) == GPG_ERR_EOF || err == -1)
++ else if (!err && done)
+ {
+ if (ctrl->cont_cmd)
+ ctrl->client_died = 1; /* Need to delay the cleanup. */
+@@ -1868,14 +1888,14 @@
+ g_debug ("error accepting connection: %s", strerror (errno));
+ goto leave;
+ }
+- if (assuan_sock_check_nonce (ASSUAN_INT2FD(fd), &socket_nonce))
++ if (assuan_sock_check_nonce ((assuan_fd_t) fd, &socket_nonce))
+ {
+ g_debug ("new connection at fd %d refused", fd);
+ goto leave;
+ }
+
+ g_debug ("new connection at fd %d", fd);
+- ctx = connection_startup (fd);
++ ctx = connection_startup ((assuan_fd_t) fd);
+ if (!ctx)
+ goto leave;
+
+@@ -1911,7 +1931,7 @@
+
+ leave:
+ if (fd != -1)
+- assuan_sock_close (ASSUAN_INT2FD (fd));
++ assuan_sock_close ((assuan_fd_t) fd);
+ return TRUE; /* Keep the listen_fd in the event loop. */
+ }
+
+@@ -1929,7 +1949,7 @@
+ GIOChannel *channel;
+ unsigned int source_id;
+
+- assuan_set_assuan_err_source (GPG_ERR_SOURCE_DEFAULT);
++ assuan_set_gpg_err_source (GPG_ERR_SOURCE_DEFAULT);
+
+ socket_name = g_build_filename (gnupg_homedir, "S.uiserver", NULL);
+ if (strlen (socket_name)+1 >= sizeof serv_addr.sun_path )
+@@ -1974,14 +1994,14 @@
+ g_free (socket_name);
+ socket_name = NULL;
+
+- if (listen (ASSUAN_FD2INT (fd), 5) == -1)
++ if (listen ((int) fd, 5) == -1)
+ {
+ g_debug ("listen() failed: %s\n", strerror (errno));
+ assuan_sock_close (fd);
+ return;
+ }
+ #ifdef HAVE_W32_SYSTEM
+- channel = g_io_channel_win32_new_socket (ASSUAN_FD2INT(fd));
++ channel = g_io_channel_win32_new_socket ((int) fd);
+ #else
+ channel = g_io_channel_unix_new (fd);
+ #endif
pan class='deletions'>-0/+4 * Update to 20010817, with many improvements and some new features.knu2001-08-174-4/+4 * Update to 20010816b.knu2001-08-164-4/+4 * Sorry. Just repacked. I had something I forgot to change. ;)knu2001-08-162-2/+2 * Update to 20010816 with some enhancements and an important change.knu2001-08-164-4/+4 * Fix handling of unconditional dependenciesdes2001-08-142-4/+7 * Update to 20010814, with some enhanced support for coping with cyclicknu2001-08-144-4/+4 * Reword more.knu2001-08-122-12/+12 * Update to 20010812, just a minor update.knu2001-08-126-12/+6 * Update pkg-comment and pkg-descr.knu2001-08-124-32/+26 * Add a hotfix to support the "MD5 (file) = IGNORE" case.knu2001-08-112-0/+6 * Update to 20010811.knu2001-08-116-4/+12 * Update to 20010809.knu2001-08-094-4/+4 * Update to 20010802, only a minor update.knu2001-08-026-4/+12 * Update to 20010730 with some enhancements.knu2001-07-304-4/+4 * Update to 20010727 with a couple of new commands added. (No changesknu2001-07-278-28/+40 * Update to 20010714, a maintenance release.knu2001-07-144-6/+6 * Update to 20010627. Enhance the behaviors of some flags:knu2001-06-274-4/+4 * Update to 20010622, a maintenance release with better diagnosticknu2001-06-224-4/+4 * Whoops, 20010617 had an installation problem.knu2001-06-174-4/+4 * Revise pkg-descr.knu2001-06-172-26/+38 * Update to 20010617.knu2001-06-176-4/+8 * Update to 20010615.knu2001-06-154-4/+16 * Oops, wrong checksum.knu2001-06-112-2/+2 * Update to 20010611, with many changes and enhancements.knu2001-06-118-8/+14 * Add experimental pkg_version(8)-like functionality.des2001-06-093-59/+124 * Clarify that portupgrade can do upgrade by means of both the port andknu2001-06-094-8/+8 * Change pkg_tarup to ${LOCALBASE}/sbin/pkg_tarup in RUN_DEPENDS.knu2001-06-092-2/+2 * Update to 20010607b.knu2001-06-074-4/+4 * Update to 20010607.knu2001-06-076-4/+8 * Update to 20010606b.knu2001-06-064-4/+4 * From now on I use release dates for this port's version numbers, andknu2001-06-0610-24/+34 * Update portupgrade to 1.42.knu2001-06-024-6/+6 * De-typo (s/priviledge/privilege/g) with no PORTREVISION bump.knu2001-06-012-0/+6 * Update portupgrade to 1.40. A bug with pkgdep has been fixed.knu2001-06-014-6/+6 * Update portupgrade to 1.39.knu2001-06-014-6/+6 * Update portupgrade to 1.36.knu2001-06-016-32/+6 * Apply a hotfix against a critical bug that +CONTENTS are lost when youknu2001-05-314-0/+26 * Update to 1.34. Now it never tries to yield root priviledgesknu2001-05-314-6/+6 * Update to 1.33. More operations need root priviledges.knu2001-05-314-6/+6 * Update portupgrade to 1.31 and portversion to 1.7.knu2001-05-316-30/+12 * Update to portupgrade 1.29.knu2001-05-304-8/+10 * Update to 1.28 which fixes a bug when a package does not have @pkgdepknu2001-05-304-6/+6 * Update to portupgrade 1.27.knu2001-05-306-98/+6 * Apply a hotfix to fix a couple of bugs/misfeatures.knu2001-05-304-0/+92 * Update portupgrade to 1.26 and portversion to 1.4.knu2001-05-306-6/+8 * Fix a rmdir line so it never fails.knu2001-05-182-2/+4 * Update to 1.25.knu2001-05-184-6/+6 * Change the order in which we check out the ports root and index to workdes2001-05-162-11/+20 * Notate more detailed functionarity of this script.sada2001-04-251-1/+17 * - minor update of the script.sada2001-04-243-11/+45 * Update to 1.23.knu2001-04-194-6/+6 * Update to 1.20.knu2001-04-186-20/+10 * Get rid of the mention of portversion in pkg-descr.knu2001-04-112-6/+0 * Say good-bye to portversion. Now we have new pkg_version(1) whichknu2001-04-114-4/+14 * Forgot to update porteasy's idea of its own version number.des2001-04-052-1/+2 * Overhaul QT/KDE support:will2001-04-031-1/+1 * Reword pkg-comment and pkg-descr to make it clearer. (README will beknu2001-03-244-10/+10 * Update to 1.19.knu2001-03-234-6/+6 * Update portupgrade to 1.18. Now it comes with portversion, which isknu2001-03-228-16/+16 * Update to 1.16.knu2001-03-214-6/+6 * Bring in the enhancements I submitted to mharo some time ago and bumpknu2001-03-212-17/+48 * Fix a bug when the origin of a package is unknown.knu2001-03-184-8/+10 * D'oh, the checksum was not the correct one's. Sorry.knu2001-03-182-2/+2 * Add portupgrade, a tool to upgrade installed packages with ports.knu2001-03-1810-0/+138 * Add forgotten file.des2001-03-111-0/+1 * Porteasy 2.3: cvspass magic for anoncvs.freebsd.org; new -w option fordes2001-03-114-26/+85 * o stop checking blank lines for files/patch-*sf2001-02-172-3/+3 * Fix docsmharo2001-02-142-10/+25 * Style fixes for sysutils.olgeni2001-02-061-1/+1 * Add qtpkg 1.0, a Qt based package removal tool.sobomax2001-01-246-0/+53 * fix some typos, make some warning messages more verbosemharo2001-01-011-4/+4 * Update to version 2.3.knu2000-12-123-245/+164 * Fix up a port that somehow got missed in The Great Conversion Processade2000-11-151-0/+47 * bump versionmharo2000-11-101-1/+1 * fix a bug, $i = -> $i eqmharo2000-11-101-1/+1 * Previous commit was incomplete.des2000-11-031-2/+2 * Don't build master ports unless they were explicitly required!des2000-11-031-2/+2 * Update to PIB 1.2, which fixes the reported issues so far with the newmsmith2000-10-282-2/+2 * Porteasy 2.2 (getting close to a new minor version every day...)des2000-10-233-23/+101 * Update version number.des2000-10-211-1/+1 * Document PORTEASY_OPTIONS.des2000-10-211-0/+10 * Add a copyright statement to the version and help texts.des2000-10-211-25/+25 * Much-enhanced Porteasy 2.0.des2000-10-203-177/+476 * Add support for the new PORTEPOCH/PORTREVISION variables, so it won'twill2000-10-111-10/+11 * Look for pkg-descr rather than pkg/DESCR.des2000-10-092-7/+7 * sync with bsd.sites.mk, bump version to 2.2.3mharo2000-10-042-11/+96 * Fix cut'n'paste bogon.des2000-09-221-1/+1 * Fix portlint bug where it thinks that missing a files/md5 is fatal but thewill2000-09-221-1/+1 * Style and mdoc fixes.des2000-09-201-27/+38 * Argh! forgot to fix this before adding the port.des2000-09-201-10/+12 * A tool for fetching and building ports.des2000-09-206-0/+921 * Move the stragler's www.freebsd.org/~user distfiles to the officalobrien2000-06-291-1/+2 * update to portlint 2.2.2:mharo2000-04-264-75/+147 * Corrrect whitespace introduced during PORTNAME conversion and portlintmharo2000-04-222-2/+2 * remove warning, version required (no longer needed) and make portlint portmharo2000-04-201-7/+1 * Update to 2.2.1mharo2000-04-172-20/+26 * Update portlint so it supports PORTNAME/PORTVERSION. This versionmharo2000-04-172-226/+322 * Back out useful `Version required lines' that I'd blindly removed.knu2000-04-151-0/+1 * Portlint COMMENT's.knu2000-04-151-1/+1 * Remove obsolete `Version required' lines.knu2000-04-151-1/+0 * PORTNAME/PORTVERSION updatemharo2000-04-122-6/+7 * Update with the new PORTNAME/PORTVERSION variablecpiazza2000-04-102-5/+5 * warn about not supporting PORTNAME/PORTVERSION yetmharo2000-04-091-0/+6 * bump version number to reflect new featuresmharo2000-03-301-1/+1 * * Fix Makefile so portlint is more happy with this port (what a concept, themharo2000-03-282-17/+101 * - fix a bug in pkg/* checkingmharo2000-03-212-8/+44 * Change all www.freebsd.org/~user references to people.FreeBSD.org/~user,peter2000-02-081-1/+1 * I'll maintain thismharo2000-02-051-1/+1 * issue a warning when @owner or @group are found in the PLISTmharo2000-02-031-12/+2 * bump version number slightly to reflect recent changesmharo2000-01-231-1/+1 * add support for @owner and @group in PLISTmharo2000-01-231-0/+12 * Add pkg_remove.cpiazza2000-01-155-0/+31 * Fixes:shige2000-01-121-11/+17 * switch maintainer to ports@freebsd.org, as I'm unable to do it for a long time.itojun2000-01-111-1/+1 * Update to portcheckout-2.0wosch2000-01-093-3/+3 * Switch to tcl/tk 8.2jseger1999-11-261-3/+3 * added the following checking:sumikawa1999-09-292-1/+9 * Recently we must use $FreeBSD instead of $Id in Makefile.taoka1999-09-281-2/+2 * Update master site.wosch1999-09-191-1/+1 * $Id$ -> $FreeBSD$peter1999-08-311-1/+1 * $Id$ -> $FreeBSD$peter1999-08-292-2/+2 * ln -> ${LN}mharo1999-08-281-2/+2 * Change Id->FreeBSD.obrien1999-08-252-2/+2 * manpage fixitojun1999-08-143-10/+10 * typo fixitojun1999-07-241-3/+3 * #4/4 enforcing Caps, no periodhoek1999-06-271-1/+1 * As threatened, enforce the "Capital, no period" rule. Ellipses arehoek1999-06-272-2/+2 * remove the first comment lines in a section properly.itojun1999-04-221-1/+3 * remove pathname for bsd.port.mk.itojun1999-04-051-3/+11 * It seems 'sane' was not mispelled, but was a little confusing. Let's trysteve1999-04-051-2/+2 * Fix a spelling nit: sane -> same.steve1999-04-021-2/+2 * Handle x11-* categories correctly.steve1999-02-221-6/+7 * Avoid installing libTkSteal.so if it exists.steve1999-01-111-2/+2 * avoid NO_WRKDIR.itojun1999-01-071-6/+7 * remove old ftp site (ftp.foretune.co.jp) from comment.itojun1999-01-051-2/+1 * being tired of maintaining portlint only by myself, I decided toitojun1999-01-053-11/+1474 * Distfile changed (minor patch)msmith1999-01-041-1/+1 * Fix MANCOMPRESSED (=maybe) and work on standard -current.hoek1998-12-301-3/+7 * manpage != DESCRhoek1998-12-301-41/+6 * Use MAN? macro.kuriyama1998-11-222-3/+4 * No need to put name in front.asami1998-11-181-1/+1 * Change location of MASTER_SITE.steve1998-11-091-2/+2 * Says that the port uses perl5 for building and runningwosch1998-11-021-1/+3 * portcheckout - checkout ports and all depending portswosch1998-11-025-0/+60 * No need to supply a minor number for shared libraries if it is zero.steve1998-10-211-1/+1 * Ressurect RUN_DEPENDS.asami1998-09-151-1/+2 * BUILD_DEPENDS on Tk, as we need Tk headers to build the TkSteal module.msmith1998-09-041-2/+2 * Remove manpages define in MAN? fom PLIST for all the devel ports.asami1998-08-121-1/+0 * Fix up dependencies for ports that moved into the x11-toolkits category.asami1998-08-081-2/+2 * Remove NO_CONFIGURE and NO_PATCH, they never meant anything.asami1998-06-27