aboutsummaryrefslogtreecommitdiffstats
path: root/security/gpasman
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>2000-07-08 03:59:26 +0800
committersteve <steve@FreeBSD.org>2000-07-08 03:59:26 +0800
commit7879264d29ab2a706345ab21de9f9cd3139efc7a (patch)
tree0fb8a7b052271f54c6bdf617de3027472d998225 /security/gpasman
parentc691dd330a3da8e70bfc74508b9fb3b585604a4d (diff)
downloadfreebsd-ports-gnome-7879264d29ab2a706345ab21de9f9cd3139efc7a.tar.gz
freebsd-ports-gnome-7879264d29ab2a706345ab21de9f9cd3139efc7a.tar.zst
freebsd-ports-gnome-7879264d29ab2a706345ab21de9f9cd3139efc7a.zip
- Use GTK_CONFIG/GLIB_CONFIG instead of hardcoded gtk12-config/glib12-config
- Support CC/CFLAGS/PREIFX/LOCALBASE/X11BASE/MAKE/etc. properly PR: 19623 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
Diffstat (limited to 'security/gpasman')
-rw-r--r--security/gpasman/Makefile3
-rw-r--r--security/gpasman/files/patch-ab13
2 files changed, 14 insertions, 2 deletions
diff --git a/security/gpasman/Makefile b/security/gpasman/Makefile
index cda66d2fe764..b340deace0fb 100644
--- a/security/gpasman/Makefile
+++ b/security/gpasman/Makefile
@@ -14,9 +14,12 @@ MAINTAINER= domi@saargate.de
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
USE_GMAKE= yes
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= GTKCONFIG="${GTK_CONFIG}"
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/gpasman ${PREFIX}/bin
diff --git a/security/gpasman/files/patch-ab b/security/gpasman/files/patch-ab
index c24e3b261bb0..abbcf95df031 100644
--- a/security/gpasman/files/patch-ab
+++ b/security/gpasman/files/patch-ab
@@ -1,5 +1,5 @@
---- src/Makefile.in.orig Sun Sep 19 13:56:52 1999
-+++ src/Makefile.in Sun Sep 19 13:57:20 1999
+--- src/Makefile.in.orig Fri Sep 3 00:50:10 1999
++++ src/Makefile.in Sat Jul 1 18:19:43 2000
@@ -26,9 +26,9 @@
@@ -12,3 +12,12 @@
INSTALL = @INSTALL@
SRCS = librc2.c file.c gpasman.c
+@@ -39,7 +39,7 @@
+ $(CC) -o gpasman $(OBJS) $(LDFLAGS) $(LIBS)
+
+ .c.o: $(SRCS)
+- $(CC) -O2 -Wall $(CFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) -c -o $@ $<
+
+ clean:
+ rm -f $(OBJS) gpasman core *~ *.bak