aboutsummaryrefslogtreecommitdiffstats
path: root/security/heimdal/Makefile
diff options
context:
space:
mode:
authornectar <nectar@FreeBSD.org>2001-02-05 23:50:26 +0800
committernectar <nectar@FreeBSD.org>2001-02-05 23:50:26 +0800
commit48d04810cde6a7869f405677d6d482d074499fa3 (patch)
tree9d34f2425e8df43e9122f13b7c2e901fd901f428 /security/heimdal/Makefile
parent10dd6dc91d80d0f5d3e7ca14a79ace61e0d5d928 (diff)
downloadfreebsd-ports-gnome-48d04810cde6a7869f405677d6d482d074499fa3.tar.gz
freebsd-ports-gnome-48d04810cde6a7869f405677d6d482d074499fa3.tar.zst
freebsd-ports-gnome-48d04810cde6a7869f405677d6d482d074499fa3.zip
Update 0.3d -> 0.3e.
The vendor says: ``We suggest those running a ftpd to update immediately.'' Changes in release 0.3e: * rcp program included * fix buffer overrun in ftpd * handle omitted sequence numbers as zeroes to handle MIT krb5 that cannot generate zero sequence numbers * handle v4 /.k files better * configure/portability fixes * fixes in parsing of options to kadmin (sub-)commands * handle errors in kadmin load better * bug fixes
Diffstat (limited to 'security/heimdal/Makefile')
-rw-r--r--security/heimdal/Makefile35
1 files changed, 10 insertions, 25 deletions
diff --git a/security/heimdal/Makefile b/security/heimdal/Makefile
index d61c6e47ab8c..7938b84a9237 100644
--- a/security/heimdal/Makefile
+++ b/security/heimdal/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= heimdal
-PORTVERSION= 0.3d
-PORTREVISION= 2
+PORTVERSION= 0.3e
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.pdc.kth.se/pub/heimdal/src/ \
ftp://ftp.replay.com/pub/replay/crypto/APPS/kerberos/heimdal/ \
@@ -25,10 +24,13 @@ RESTRICTED= "Crypto; export-controlled"
MAN1= ftp.1 kdestroy.1 kf.1 kgetcred.1 kinit.1 klist.1 kpasswd.1 \
krb5-config.1 kx.1 otp.1 otpprint.1 pfrom.1 rxtelnet.1 \
rxterm.1 telnet.1 tenletxr.1 xnlock.1
-MAN3= editline.3 kafs.3 krb5_425_conv_principal.3 krb5_appdefault.3 \
- krb5_build_principal.3 krb5_config.3 krb5_free_principal.3 \
- krb5_openlog.3 krb5_parse_name.3 krb5_sname_to_principal.3 \
- krb5_unparse_name.3 krb5_warn.3
+MAN3= editline.3 kafs.3 krb5_425_conv_principal.3 \
+ krb5_appdefault.3 krb5_auth_context.3 \
+ krb5_build_principal.3 krb5_config.3 krb5_context.3 \
+ krb5_free_principal.3 krb5_init_context.3 \
+ krb5_openlog.3 krb5_parse_name.3 \
+ krb5_sname_to_principal.3 krb5_unparse_name.3 \
+ krb5_warn.3
MAN5= ftpusers.5 krb5.conf.5
MAN8= ftpd.8 hprop.8 hpropd.8 kadmin.8 kadmind.8 kdc.8 kerberos.8 \
kfd.8 kpasswdd.8 kstash.8 ktutil.8 kxd.8 push.8 string2key.8 \
@@ -40,7 +42,6 @@ MAN8= ftpd.8 hprop.8 hpropd.8 kadmin.8 kadmind.8 kdc.8 kerberos.8 \
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}--freebsd${OSREL}
INSTALLS_SHLIB= yes
-CONFIGURE_ENV= CPPFLAGS="${OPENSSL_INCLUDE}"
CONFIGURE_ARGS= --prefix=${PREFIX} --enable-shared
.if defined(WITH_LDAP)
CONFIGURE_ARGS+= --with-openldap=${LOCALBASE}
@@ -67,34 +68,18 @@ CONFIGURE_ARGS+= --without-krb4
.endif
# OpenSSL 0.9.6 and later have MD4 and can be used in the build
-.if exists(/usr/include/openssl/md4.h) && exists(/usr/lib/libdes.a)
-OPENSSL_INCLUDE= -I/usr/include/openssl
+.if exists(/usr/include/openssl/md4.h) && exists(/usr/lib/libcrypto.a)
OPENSSL_IN_BASE= YES
.endif
PLIST:= ${WRKDIR}/PLIST
-# The crypto APIs in the included libdes are trivially different from
-# those in OpenSSL, e.g. MD5Init versus MD5_Init. To make things simpler,
-# we normalize the API to use the latter naming convention. These are a
-# list of the files that must be munged.
-CRYPTO_FIXUP= lib/des/fcrypt.c lib/des/md4.c lib/des/md4.h \
- lib/des/md5.c lib/des/md5.h lib/des/mdtest.c \
- lib/des/sha.c lib/des/sha.h lib/gssapi/8003.c \
- lib/gssapi/get_mic.c lib/gssapi/unwrap.c \
- lib/gssapi/verify_mic.c lib/gssapi/wrap.c \
- lib/krb5/crypto.c lib/krb5/replay.c lib/otp/otp_md.c
-
+# Nuke com_err stuff, it is in the base system.
pre-configure:
@(set -e; \
cd ${CONFIGURE_WRKSRC}; \
find . -type f -name 'Makefile.in' -print | xargs perl -i -pe \
's,\$$\(top_builddir\)/lib/com_err/compile_et,compile_et,';)
- (cd ${WRKSRC} && ${PERL} -i.orig -p \
- -e 's/(SHA1|MD5|MD4)(Init|Update|Final)/$$1_$$2/g;' \
- -e 's/SHA1_CTX/SHA_CTX/g;' \
- -e 's/des_set_odd_parity/des_fixup_key_parity/g;' \
- ${CRYPTO_FIXUP})
pre-install:
@${CP} ${PKGDIR}/pkg-plist ${PLIST}