aboutsummaryrefslogtreecommitdiffstats
path: root/security/hpn-ssh
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2002-08-07 03:31:25 +0800
committerdinoex <dinoex@FreeBSD.org>2002-08-07 03:31:25 +0800
commit8d35dd03142a3c7278c048594a2222286235f6c4 (patch)
treed971c5e5102256703e96513319d94d9d6cf948a9 /security/hpn-ssh
parent36b31b42049a60a73e23655795087c6726f532c5 (diff)
downloadfreebsd-ports-gnome-8d35dd03142a3c7278c048594a2222286235f6c4.tar.gz
freebsd-ports-gnome-8d35dd03142a3c7278c048594a2222286235f6c4.tar.zst
freebsd-ports-gnome-8d35dd03142a3c7278c048594a2222286235f6c4.zip
add bugfix from CURRENT
Diffstat (limited to 'security/hpn-ssh')
-rw-r--r--security/hpn-ssh/Makefile2
-rw-r--r--security/hpn-ssh/files/patch-auth.c9
2 files changed, 10 insertions, 1 deletions
diff --git a/security/hpn-ssh/Makefile b/security/hpn-ssh/Makefile
index c9d36efb4d73..6a89bf044724 100644
--- a/security/hpn-ssh/Makefile
+++ b/security/hpn-ssh/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openssh
PORTVERSION= 3.4p1
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
ftp://ftp.op.net/pub/OpenBSD/OpenSSH/portable/ \
diff --git a/security/hpn-ssh/files/patch-auth.c b/security/hpn-ssh/files/patch-auth.c
index bcba47e64b8c..e8f640a16936 100644
--- a/security/hpn-ssh/files/patch-auth.c
+++ b/security/hpn-ssh/files/patch-auth.c
@@ -18,3 +18,12 @@
/* We found no reason not to let this user try to log on... */
return 1;
}
+@@ -490,7 +480,7 @@
+ if (pw == NULL || !allowed_user(pw))
+ return (NULL);
+ #ifdef HAVE_LOGIN_CAP
+- if ((lc = login_getclass(pw->pw_class)) == NULL) {
++ if ((lc = login_getpwclass(pw)) == NULL) {
+ debug("unable to get login class: %s", user);
+ return (NULL);
+ }