aboutsummaryrefslogtreecommitdiffstats
path: root/security/hs-RSA
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-08-03 10:30:07 +0800
committerpgj <pgj@FreeBSD.org>2012-08-03 10:30:07 +0800
commitc375ed37df92a6e58eaf54cf831525f3a49c9629 (patch)
tree8ee3a15fcf61eb9a77ce79ffe7cc567f6e56e480 /security/hs-RSA
parent9c52697bc371ab647ee6cd5811c6ca220c7f6e11 (diff)
downloadfreebsd-ports-gnome-c375ed37df92a6e58eaf54cf831525f3a49c9629.tar.gz
freebsd-ports-gnome-c375ed37df92a6e58eaf54cf831525f3a49c9629.tar.zst
freebsd-ports-gnome-c375ed37df92a6e58eaf54cf831525f3a49c9629.zip
- Teach the Haskell Cabal ports to use the new options framework
- Remove some cruft Obtained from: FreeBSD Haskell
Diffstat (limited to 'security/hs-RSA')
-rw-r--r--security/hs-RSA/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/security/hs-RSA/Makefile b/security/hs-RSA/Makefile
index 3ac87e7ca170..30aef7812354 100644
--- a/security/hs-RSA/Makefile
+++ b/security/hs-RSA/Makefile
@@ -7,6 +7,7 @@
PORTNAME= RSA
PORTVERSION= 1.2.1.0
+PORTREVISION= 1
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
@@ -17,20 +18,22 @@ LICENSE= BSD
CABAL_SETUP= Setup.hs
USE_CABAL= crypto-api>=0.10 crypto-pubkey-types monadcryptorandom SHA
-OPTIONS= MD5 "Include support for using MD5" on \
- BINARY "Use the binary package for serialization" on
+OPTIONS_DEFINE= MD5 BINARY
+OPTIONS_DEFAULT= MD5 BINARY
+
+MD5_DESC= Include support for using MD5
+BINARY_DESC= Use the binary package for serialization
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
.include <bsd.port.options.mk>
-.if defined(WITH_MD5)
+.if ${PORT_OPTIONS:MMD5}
CONFIGURE_ARGS+= --flags="IncludeMD5"
USE_CABAL+= pureMD5
.else
CONFIGURE_ARGS+= --flags="-IncludeMD5"
.endif
-.if defined(WITH_BINARY)
+.if ${PORT_OPTIONS:MBINARY}
CONFIGURE_ARGS+= --flags="UseBinary"
.else
CONFIGURE_ARGS+= --flags="-UseBinary"