aboutsummaryrefslogtreecommitdiffstats
path: root/security/hs-RSA
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-06-04 06:23:00 +0800
committerpgj <pgj@FreeBSD.org>2012-06-04 06:23:00 +0800
commita02cf02c40491943d8fcf0b73734df8f1d31039d (patch)
treed61d2e38fb7a12b5297e79f82d74da2ddb7485de /security/hs-RSA
parentb43b2eac392f06dd1c3d0e366c890c60d4258f2c (diff)
downloadfreebsd-ports-gnome-a02cf02c40491943d8fcf0b73734df8f1d31039d.tar.gz
freebsd-ports-gnome-a02cf02c40491943d8fcf0b73734df8f1d31039d.tar.zst
freebsd-ports-gnome-a02cf02c40491943d8fcf0b73734df8f1d31039d.zip
- Update to 1.2.1.0
Obtained from: FreeBSD Haskell
Diffstat (limited to 'security/hs-RSA')
-rw-r--r--security/hs-RSA/Makefile5
-rw-r--r--security/hs-RSA/distinfo4
-rw-r--r--security/hs-RSA/pkg-descr9
3 files changed, 8 insertions, 10 deletions
diff --git a/security/hs-RSA/Makefile b/security/hs-RSA/Makefile
index 7206046dbfec..3ac87e7ca170 100644
--- a/security/hs-RSA/Makefile
+++ b/security/hs-RSA/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= RSA
-PORTVERSION= 1.0.6.2
+PORTVERSION= 1.2.1.0
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
@@ -15,7 +15,7 @@ COMMENT= Implementation of RSA, using the padding schemes of PKCS#1 v2.1
LICENSE= BSD
CABAL_SETUP= Setup.hs
-USE_CABAL= SHA
+USE_CABAL= crypto-api>=0.10 crypto-pubkey-types monadcryptorandom SHA
OPTIONS= MD5 "Include support for using MD5" on \
BINARY "Use the binary package for serialization" on
@@ -32,7 +32,6 @@ CONFIGURE_ARGS+= --flags="-IncludeMD5"
.if defined(WITH_BINARY)
CONFIGURE_ARGS+= --flags="UseBinary"
-USE_CABAL+= binary
.else
CONFIGURE_ARGS+= --flags="-UseBinary"
.endif
diff --git a/security/hs-RSA/distinfo b/security/hs-RSA/distinfo
index 6899a5e0314e..0a358bd288cd 100644
--- a/security/hs-RSA/distinfo
+++ b/security/hs-RSA/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/RSA-1.0.6.2.tar.gz) = 93c34f4fd4d99530b54205d93922dc280b83cbbc92a53e6ad9d63cf93edf4b69
-SIZE (cabal/RSA-1.0.6.2.tar.gz) = 11986
+SHA256 (cabal/RSA-1.2.1.0.tar.gz) = 8a053ddce835c5ec75e69147f7522a132c68c21235fb696c7c0d67e2651fa593
+SIZE (cabal/RSA-1.2.1.0.tar.gz) = 12187
diff --git a/security/hs-RSA/pkg-descr b/security/hs-RSA/pkg-descr
index 52c822236d15..275de8ba78e9 100644
--- a/security/hs-RSA/pkg-descr
+++ b/security/hs-RSA/pkg-descr
@@ -1,8 +1,7 @@
This library implements the RSA encryption and signature algorithms for
-arbitrarily-sized ByteStrings. While the implementations work, they are
-not necessarily the fastest ones on the planet. Particularly key
-generation. The algorithms included are based of RFC 3447, or the
-Public-Key Cryptography Standard for RSA, version 2.1 (a.k.a, PKCS#1
-v2.1).
+arbitrarily-sized ByteStrings. While the implementations work, they are
+not necessarily the fastest ones on the planet. Particularly key generation.
+The algorithms included are based of RFC 3447, or the Public-Key Cryptography
+Standard for RSA, version 2.1 (a.k.a, PKCS#1 v2.1).
WWW: http://hackage.haskell.org/package/RSA