aboutsummaryrefslogtreecommitdiffstats
path: root/security/hs-crypto-api
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-02-13 10:41:08 +0800
committerpgj <pgj@FreeBSD.org>2012-02-13 10:41:08 +0800
commitb3fb6e9e35e1b750c6e0cb945ff51926e65e3a06 (patch)
tree3c2fd1c087a7d20d573ef5608a4fa9f3d8e58276 /security/hs-crypto-api
parent5005d1b2c74d99ace5e501d6470a1d48d52b1cad (diff)
downloadfreebsd-ports-gnome-b3fb6e9e35e1b750c6e0cb945ff51926e65e3a06.tar.gz
freebsd-ports-gnome-b3fb6e9e35e1b750c6e0cb945ff51926e65e3a06.tar.zst
freebsd-ports-gnome-b3fb6e9e35e1b750c6e0cb945ff51926e65e3a06.zip
A generic interface for cryptographic operations, platform independent quality
RNG, property tests and known-answer tests (KATs) for common algorithms, and a basic benchmark infrastructure. Maintainers of hash and cipher implementations are encouraged to add instances for the classes defined in Crypto.Classes. Crypto users are similarly encouraged to use the interfaces defined in the Classes module. Any concepts or functions of general use to more than one cryptographic algorithm (ex: padding) is within scope of this package. WWW: http://trac.haskell.org/crypto-api/wiki Obtained from: FreeBSD Haskell
Diffstat (limited to 'security/hs-crypto-api')
-rw-r--r--security/hs-crypto-api/Makefile21
-rw-r--r--security/hs-crypto-api/distinfo2
-rw-r--r--security/hs-crypto-api/pkg-descr9
3 files changed, 32 insertions, 0 deletions
diff --git a/security/hs-crypto-api/Makefile b/security/hs-crypto-api/Makefile
new file mode 100644
index 000000000000..6ce68a1ab270
--- /dev/null
+++ b/security/hs-crypto-api/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: hs-crypto-api
+# Date created: March 13, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= crypto-api
+PORTVERSION= 0.8
+CATEGORIES= security haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= A generic interface for cryptographic operations
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+USE_CABAL= cereal>=0.2 entropy largeword>=1.0.0 tagged>=0.1
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/security/hs-crypto-api/distinfo b/security/hs-crypto-api/distinfo
new file mode 100644
index 000000000000..573ec6111855
--- /dev/null
+++ b/security/hs-crypto-api/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/crypto-api-0.8.tar.gz) = 480cc686eb1c2f9668b67c38f255417012fd66a5b61315f24664889d965393bb
+SIZE (cabal/crypto-api-0.8.tar.gz) = 42443
diff --git a/security/hs-crypto-api/pkg-descr b/security/hs-crypto-api/pkg-descr
new file mode 100644
index 000000000000..34889f576186
--- /dev/null
+++ b/security/hs-crypto-api/pkg-descr
@@ -0,0 +1,9 @@
+A generic interface for cryptographic operations, platform independent quality
+RNG, property tests and known-answer tests (KATs) for common algorithms, and a
+basic benchmark infrastructure. Maintainers of hash and cipher implementations
+are encouraged to add instances for the classes defined in Crypto.Classes.
+Crypto users are similarly encouraged to use the interfaces defined in the
+Classes module. Any concepts or functions of general use to more than one
+cryptographic algorithm (ex: padding) is within scope of this package.
+
+WWW: http://trac.haskell.org/crypto-api/wiki