aboutsummaryrefslogtreecommitdiffstats
path: root/security/hs-skein
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-02-13 10:52:47 +0800
committerpgj <pgj@FreeBSD.org>2012-02-13 10:52:47 +0800
commit264590cfc59999d3636ea2dfbb2f48d889de41be (patch)
treeb16e999426dfa23c2aabeea5b84efaad0e7d1b23 /security/hs-skein
parent067eef4df96d44f49c7aeedcc043f15fb7d2dcab (diff)
downloadfreebsd-ports-gnome-264590cfc59999d3636ea2dfbb2f48d889de41be.tar.gz
freebsd-ports-gnome-264590cfc59999d3636ea2dfbb2f48d889de41be.tar.zst
freebsd-ports-gnome-264590cfc59999d3636ea2dfbb2f48d889de41be.zip
Skein [1] is a family of fast secure cryptographic hash functions. This
package uses bindings to the optimized C implementation of Skein. There is a high-level interface provided to some of the Skein use cases, and a low-level interface when Skein has to be used in a different way. Currently Skein is supported as cryptographic hash function as Skein as a message authentication code (Skein-MAC). [1] http://www.skein-hash.info/ WWW: http://patch-tag.com/r/felipe/skein Obtained from: FreeBSD Haskell
Diffstat (limited to 'security/hs-skein')
-rw-r--r--security/hs-skein/Makefile22
-rw-r--r--security/hs-skein/distinfo2
-rw-r--r--security/hs-skein/pkg-descr11
3 files changed, 35 insertions, 0 deletions
diff --git a/security/hs-skein/Makefile b/security/hs-skein/Makefile
new file mode 100644
index 000000000000..8bf3b0e0c0b9
--- /dev/null
+++ b/security/hs-skein/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: hs-skein
+# Date created: November 19, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= skein
+PORTVERSION= 0.1.0.5
+CATEGORIES= security haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Skein, a family of cryptographic hash functions
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+
+USE_CABAL= cereal>=0.3 crypto-api>=0.6 tagged>=0.2
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/security/hs-skein/distinfo b/security/hs-skein/distinfo
new file mode 100644
index 000000000000..4c10655f1702
--- /dev/null
+++ b/security/hs-skein/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/skein-0.1.0.5.tar.gz) = cb3b44d56e0803837b17e827454208441c0fb2bcccf14bb600486bfb9bf71e8a
+SIZE (cabal/skein-0.1.0.5.tar.gz) = 116667
diff --git a/security/hs-skein/pkg-descr b/security/hs-skein/pkg-descr
new file mode 100644
index 000000000000..7a3c2ddcd7af
--- /dev/null
+++ b/security/hs-skein/pkg-descr
@@ -0,0 +1,11 @@
+Skein [1] is a family of fast secure cryptographic hash functions. This
+package uses bindings to the optimized C implementation of Skein. There
+is a high-level interface provided to some of the Skein use cases, and a
+low-level interface when Skein has to be used in a different way.
+
+Currently Skein is supported as cryptographic hash function as Skein as
+a message authentication code (Skein-MAC).
+
+[1] http://www.skein-hash.info/
+
+WWW: http://patch-tag.com/r/felipe/skein