aboutsummaryrefslogtreecommitdiffstats
path: root/security/ike
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2016-10-01 03:24:30 +0800
committertijl <tijl@FreeBSD.org>2016-10-01 03:24:30 +0800
commitf493fce6a3261de0136fe170a7b704c4fe236b88 (patch)
tree8b44219153a720f367633c8fe248933750735b7d /security/ike
parent70cc79c60e2f5a9e208b1727c67b6fe406e80c61 (diff)
downloadfreebsd-ports-gnome-f493fce6a3261de0136fe170a7b704c4fe236b88.tar.gz
freebsd-ports-gnome-f493fce6a3261de0136fe170a7b704c4fe236b88.tar.zst
freebsd-ports-gnome-f493fce6a3261de0136fe170a7b704c4fe236b88.zip
Let USES=localbase add -L${LOCALBASE}/lib to LIBS instead of LDFLAGS.
USES=localbase:ldflags can be used to set LDFLAGS. Normally LDFLAGS appears too early on the command line causing some ports to link with their own libraries in LOCALBASE (if installed) instead of WRKSRC. Also make use of _USES_POST so -L${LOCALBASE}/lib is added as late as possible after anything a port Makefile might set. Use _USES_POST instead of .include in libedit.mk and libarchive.mk so things like 'USES=libedit localbase:ldflags' work correctly. Fix some issues with LIBS in some ports. Switch ports that don't support LIBS to localbase:ldflags. PR: 212987 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'security/ike')
-rw-r--r--security/ike/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/security/ike/Makefile b/security/ike/Makefile
index de5cb738bb88..c75cc9bd5d0c 100644
--- a/security/ike/Makefile
+++ b/security/ike/Makefile
@@ -14,7 +14,7 @@ COMMENT= Shrew Soft IKE daemon and client tools
ONLY_FOR_ARCHS= i386 amd64
USE_RC_SUBR= iked
-USES= bison cmake libedit tar:tbz2
+USES= bison cmake libedit localbase:ldflags tar:tbz2
USE_OPENSSL= yes
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}