aboutsummaryrefslogtreecommitdiffstats
path: root/security/ike
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-03-31 22:54:45 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-03-31 22:54:45 +0800
commit0cbb97be9300370b12e5682ef777407db09c7c9b (patch)
tree93420b1cda6feb35461e71ef66cc38955b96ee9b /security/ike
parente58ac8815a44cfe42e689a7bf470a01031a8e010 (diff)
downloadfreebsd-ports-gnome-0cbb97be9300370b12e5682ef777407db09c7c9b.tar.gz
freebsd-ports-gnome-0cbb97be9300370b12e5682ef777407db09c7c9b.tar.zst
freebsd-ports-gnome-0cbb97be9300370b12e5682ef777407db09c7c9b.zip
- Switch to USES=tar:tbz2
- Switch to options helpers - Fix typo - Fix plist for WITH=QTGUI case Approved by: portmgr blanket
Diffstat (limited to 'security/ike')
-rw-r--r--security/ike/Makefile42
-rw-r--r--security/ike/pkg-plist2
2 files changed, 15 insertions, 29 deletions
diff --git a/security/ike/Makefile b/security/ike/Makefile
index 6c1fb9bcf21d..de5cb738bb88 100644
--- a/security/ike/Makefile
+++ b/security/ike/Makefile
@@ -7,7 +7,6 @@ PORTREVISION= 2
CATEGORIES= security net
MASTER_SITES= https://www.shrew.net/download/ike/
DISTNAME= ${PORTNAME}-${PORTVERSION}-release
-EXTRACT_SUFX= .tbz2
MAINTAINER= mgrooms@shrew.net
COMMENT= Shrew Soft IKE daemon and client tools
@@ -15,60 +14,45 @@ COMMENT= Shrew Soft IKE daemon and client tools
ONLY_FOR_ARCHS= i386 amd64
USE_RC_SUBR= iked
-USES= bison cmake libedit tar:bzip2
+USES= bison cmake libedit tar:tbz2
USE_OPENSSL= yes
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
-CMAKE_ARGS+= -DETCDIR:PATH="${PREFIX}/etc" \
+CMAKE_ARGS= -DETCDIR:PATH="${PREFIX}/etc" \
-DBINDIR:PATH="${PREFIX}/bin" \
-DSBINDIR:PATH="${PREFIX}/sbin" \
-DLIBDIR:PATH="${PREFIX}/lib" \
-DMANDIR:PATH="${PREFIX}/man"
OPTIONS_DEFINE= QTGUI NATT LDAP DEBUG
+OPTIONS_SUB= yes
+
QTGUI_DESC= Enable QT client front end applications
NATT_DESC= Enable NAT-Traversal
LDAP_DESC= Enable LDAP XAuth daemon support
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDEBUG}
-CMAKE_ARGS+= -DDEBUG=YES
-.endif
-
-.if ${PORT_OPTIONS:MLDAP}
-USE_OPENLDAP= YES
-CMAKE_ARGS+= -DLDAP=YES
-.endif
+DEBUG_CMAKE_ON= -DDEBUG=YES
-.if ${PORT_OPTIONS:MNATT}
-CMAKE_ARGS+= -DNATT=YES
-.endif
-
-.if ${PORT_OPTIONS:MQTGUI}
-CMAKE_ARGS+= -DQTGUI=YES
-USE_QT_VER= 4
-USE_QT4= gui moc_build qmake_build rcc_build uic_build
-MAN1+= qikea.1 qikec.1
-PLIST_SUB+= QTGUI=""
-.else
-PLIST_SUB+= QTGUI="@comment "
-.endif
+LDAP_USE= OPENLDAP=yes
+LDAP_CMAKE_ON= -DLDAP=YES
+NATT_CMAKE_ON= -DNATT=YES
+QTGUI_CMAKE_ON= -DQTGUI=YES
+QTGUI_USE= QT4=gui,moc_build,qmake_build,rcc_build,uic_build
post-install:
@if ! ${SYSCTL} -a | ${GREP} -q ipsec; then \
${ECHO_MSG} "===> -------------------------------------------------------------------------"; \
- ${ECHO_MSG} "===> WARNNG: You need IPsec support in your kernel, please see:"; \
+ ${ECHO_MSG} "===> WARNING: You need IPsec support in your kernel, please see:"; \
${ECHO_MSG} "===> http://www.freebsd.org/doc/en/books/handbook/ipsec.html"; \
${ECHO_MSG} "===> -------------------------------------------------------------------------"; \
fi ;
-.if ${PORT_OPTIONS:MNATT}
+
+post-install-NATT-on:
@${ECHO_MSG} "===> -------------------------------------------------------------------------"
@${ECHO_MSG} "===> WARNING: To use NAT Traversal ( NAT-T ) support, please be sure to"
@${ECHO_MSG} "===> include the following line in your kernel config file."
@${ECHO_MSG} "===> options IPSEC_NAT_T"
@${ECHO_MSG} "===> -------------------------------------------------------------------------"
-.endif
.include <bsd.port.mk>
diff --git a/security/ike/pkg-plist b/security/ike/pkg-plist
index 4d6dad9ecdaa..f4de2536d055 100644
--- a/security/ike/pkg-plist
+++ b/security/ike/pkg-plist
@@ -16,5 +16,7 @@ lib/libss_log.so.2.2.1
lib/libss_pfk.so
lib/libss_pfk.so.2.2.1
man/man1/ikec.1.gz
+%%QTGUI%%man/man1/qikea.1.gz
+%%QTGUI%%man/man1/qikec.1.gz
man/man5/iked.conf.5.gz
man/man8/iked.8.gz