aboutsummaryrefslogtreecommitdiffstats
path: root/security/ipfcount
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-05-01 09:42:38 +0800
committeradamw <adamw@FreeBSD.org>2014-05-01 09:42:38 +0800
commit4193822cf8d93383dc8f9f6186609a67b2350005 (patch)
tree7d2afea24bed5487a0bed70a4ce863d70ee3d368 /security/ipfcount
parentad2f39a8b4fdf5d89647810e8a01030f3f768456 (diff)
downloadfreebsd-ports-gnome-4193822cf8d93383dc8f9f6186609a67b2350005.tar.gz
freebsd-ports-gnome-4193822cf8d93383dc8f9f6186609a67b2350005.tar.zst
freebsd-ports-gnome-4193822cf8d93383dc8f9f6186609a67b2350005.zip
STAGE support, and general cleanups. Some of the changes are a
bit more aggressive, but at this point, if I'm staging your port, you've likely stopped caring what's done to it.
Diffstat (limited to 'security/ipfcount')
-rw-r--r--security/ipfcount/Makefile28
1 files changed, 9 insertions, 19 deletions
diff --git a/security/ipfcount/Makefile b/security/ipfcount/Makefile
index de211c76f145..8feeb3c6f11f 100644
--- a/security/ipfcount/Makefile
+++ b/security/ipfcount/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ipfcount
PORTVERSION= 0.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://deathbeforedecaf.net/misc/ports/ \
http://users.netleader.com.au/~rob/
@@ -11,18 +11,15 @@ MASTER_SITES= http://deathbeforedecaf.net/misc/ports/ \
MAINTAINER= freebsd@deathbeforedecaf.net
COMMENT= Summarise ipf logs by counting and sorting the fields
-PLIST_FILES= bin/ipfcount
-MAN1= ipfcount.1
+PLIST_FILES= bin/ipfcount man/man1/ipfcount.1.gz
USES= perl5
-.if !defined(NOPORTDOCS)
-PLIST_DIRS= %%EXAMPLESDIR%%
-PLIST_FILES+= %%EXAMPLESDIR%%/100.ipfcount
+PORT_OPTIONS= EXAMPLES
+
+PORTEXAMPLES= 100.ipfcount
SUB_FILES= pkg-message
-.endif
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e '1s,^#![^ ]*,#!${PERL},' ${WRKSRC}/ipfcount
@@ -30,16 +27,9 @@ do-build:
cd ${WRKSRC} && pod2man ipfcount > ipfcount.1
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/ipfcount ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/ipfcount.1 ${PREFIX}/man/man1/ipfcount.1
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/100.ipfcount ${EXAMPLESDIR}
-.endif
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${CAT} ${PKGMESSAGE}
-.endif
+ ${INSTALL_SCRIPT} ${WRKSRC}/ipfcount ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/ipfcount.1 ${STAGEDIR}${PREFIX}/man/man1
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/100.ipfcount ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>