aboutsummaryrefslogtreecommitdiffstats
path: root/security/ipfcount
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-12-18 01:19:48 +0800
committermat <mat@FreeBSD.org>2015-12-18 01:19:48 +0800
commit9e7703aff1c96dce4c11180df6bfd80c536b777a (patch)
treecc6e929ebf67eee2cc8ce1692ea0663387b3a559 /security/ipfcount
parentfbcb74cea8547a229eabdb6530aecdeb2689cf82 (diff)
downloadfreebsd-ports-gnome-9e7703aff1c96dce4c11180df6bfd80c536b777a.tar.gz
freebsd-ports-gnome-9e7703aff1c96dce4c11180df6bfd80c536b777a.tar.zst
freebsd-ports-gnome-9e7703aff1c96dce4c11180df6bfd80c536b777a.zip
Fix usage of ${PERL5}.
${PERL5} points to a specific version of perl, say, perl5.22.1, it is fine to use it in a ports Makefile to do Perly things, but ports using it must use ${PERL}, that points to /usr/local/bin/perl so that if the minor version is updated, the shebang keep working. While there, make some ports use shebangfix, regen a few patches, and bump PORTREVISION where a shebang went from PERL5 to PERL. PR: 205367 With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'security/ipfcount')
-rw-r--r--security/ipfcount/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/security/ipfcount/Makefile b/security/ipfcount/Makefile
index 4e695c940b97..bf78b74b9749 100644
--- a/security/ipfcount/Makefile
+++ b/security/ipfcount/Makefile
@@ -13,16 +13,14 @@ COMMENT= Summarise ipf logs by counting and sorting the fields
PLIST_FILES= bin/ipfcount man/man1/ipfcount.1.gz
-USES= perl5
+USES= perl5 shebangfix
+SHEBANG_FILES= ipfcount
OPTIONS_DEFINE= EXAMPLES
PORTEXAMPLES= 100.ipfcount
SUB_FILES= pkg-message
-post-patch:
- @${REINPLACE_CMD} -e '1s,^#![^ ]*,#!${PERL},' ${WRKSRC}/ipfcount
-
do-build:
cd ${WRKSRC} && pod2man ipfcount > ipfcount.1