aboutsummaryrefslogtreecommitdiffstats
path: root/security/isakmpd
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-08-25 17:29:26 +0800
committeredwin <edwin@FreeBSD.org>2003-08-25 17:29:26 +0800
commitd6f0246a4166eeb2b5e56e9b69e22ad3eeb34884 (patch)
treeb91b1e23ebb9b14f887cc6c9f538f1a5db517ffa /security/isakmpd
parent259582a5102863ba84549c78031d2a50c7e52964 (diff)
downloadfreebsd-ports-gnome-d6f0246a4166eeb2b5e56e9b69e22ad3eeb34884.tar.gz
freebsd-ports-gnome-d6f0246a4166eeb2b5e56e9b69e22ad3eeb34884.tar.zst
freebsd-ports-gnome-d6f0246a4166eeb2b5e56e9b69e22ad3eeb34884.zip
isakmpd pcap support is broken
The isakmpd port comes with a pcap.h that is not compatible with the FreeBSD pcap.h. As a result, the pcap file written by isakmpd has an incorrect 'linktype' in the header. Thus, if one tries to use the pcap file with a FreeBSD tool like tcpdump, the packets are incorrectly (read: not at all) decoded. PR: ports/55940 Submitted by: James E. Flemer <jflemer@alum.rpi.edu>
Diffstat (limited to 'security/isakmpd')
-rw-r--r--security/isakmpd/Makefile1
-rw-r--r--security/isakmpd/files/patch-Makefile.sysdep14
2 files changed, 11 insertions, 4 deletions
diff --git a/security/isakmpd/Makefile b/security/isakmpd/Makefile
index 00bdcfce18b3..6f8eec259181 100644
--- a/security/isakmpd/Makefile
+++ b/security/isakmpd/Makefile
@@ -10,6 +10,7 @@
PORTNAME= isakmpd
PORTVERSION= 20021118
+PORTREVISION= 1
CATEGORIES= security net
MASTER_SITES= ${MASTER_SITE_NETBSD}
MASTER_SITE_SUBDIR= LOCAL_PORTS
diff --git a/security/isakmpd/files/patch-Makefile.sysdep b/security/isakmpd/files/patch-Makefile.sysdep
index 21d994fef786..0560c8c85233 100644
--- a/security/isakmpd/files/patch-Makefile.sysdep
+++ b/security/isakmpd/files/patch-Makefile.sysdep
@@ -1,6 +1,8 @@
---- sysdep/freebsd/Makefile.sysdep.orig Fri Feb 21 10:14:47 2003
-+++ sysdep/freebsd/Makefile.sysdep Thu Aug 29 01:39:36 2002
-@@ -42,7 +42,7 @@
+$FreeBSD$
+
+--- sysdep/freebsd/Makefile.sysdep.orig Thu Aug 29 02:39:36 2002
++++ sysdep/freebsd/Makefile.sysdep Sun Aug 24 18:30:45 2003
+@@ -42,10 +42,10 @@
LIBSYSDEPDIR= ${.CURDIR}/sysdep/common/libsysdep
.endif
@@ -8,4 +10,8 @@
+LDADD+= ${LIBSYSDEPDIR}/libsysdep.a -lipsec -L/usr/local/lib
DPADD+= ${LIBGMP} ${LIBSYSDEPDIR}/libsysdep.a
- CFLAGS+= -DHAVE_GETNAMEINFO -DHAVE_GETIFADDRS \
+-CFLAGS+= -DHAVE_GETNAMEINFO -DHAVE_GETIFADDRS \
++CFLAGS+= -DHAVE_GETNAMEINFO -DHAVE_GETIFADDRS -DHAVE_PCAP \
+ -I${.CURDIR}/sysdep/common -I/usr/include \
+ -I/usr/local/include -I/usr/local/include/openssl
+