aboutsummaryrefslogtreecommitdiffstats
path: root/security/john/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-08-12 06:10:50 +0800
committerpav <pav@FreeBSD.org>2004-08-12 06:10:50 +0800
commitd615cc564cc40d0eac14fa4e2f345ce00317f38d (patch)
tree37210c4573a39ade497e9439ed2ca547b2838579 /security/john/Makefile
parent5d8e8cd10116f6c8c853200d247ef2dbc6de31d2 (diff)
downloadfreebsd-ports-gnome-d615cc564cc40d0eac14fa4e2f345ce00317f38d.tar.gz
freebsd-ports-gnome-d615cc564cc40d0eac14fa4e2f345ce00317f38d.tar.zst
freebsd-ports-gnome-d615cc564cc40d0eac14fa4e2f345ce00317f38d.zip
- Install additional documentation
- Portlint PR: ports/69627 Submitted by: Radim Kolar <hsn@netmag.cz> Approved by: maintainer timeout (14 days)
Diffstat (limited to 'security/john/Makefile')
-rw-r--r--security/john/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/security/john/Makefile b/security/john/Makefile
index 7c9eb2372d84..779c6235bc87 100644
--- a/security/john/Makefile
+++ b/security/john/Makefile
@@ -8,6 +8,7 @@
PORTNAME= john
PORTVERSION= 1.6.37
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.openwall.com/john/a/ \
ftp://ftp.ru.openwall.com/pub/projects/john/
@@ -18,19 +19,20 @@ MAINTAINER= dom@helenmarks.co.uk
COMMENT= Featureful Unix password cracker
USE_REINPLACE= yes
+PORTDOCS= *
.include <bsd.port.pre.mk>
OSNAME= ${OPSYS:S/F/f/:S/N/n/:S/O/o/:S/B/b/:S/S/s/:S/D/d/}
ALL_TARGET= generic
-.if ${MACHINE_ARCH} == "i386"
+.if ${ARCH} == "i386"
. if ${MACHINE_CPU:Mmmx}
ALL_TARGET= ${OSNAME}-x86-mmx-elf
. else
ALL_TARGET= ${OSNAME}-x86-any-elf
. endif
-.elif ${MACHINE_ARCH} == "alpha"
+.elif ${ARCH} == "alpha"
ALL_TARGET= ${OSNAME}-alpha
.endif
@@ -60,6 +62,7 @@ do-install:
${DATADIR}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${OLDSRC}/../doc/* ${DOCSDIR}
@${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/doc/* ${DOCSDIR}
.endif