aboutsummaryrefslogtreecommitdiffstats
path: root/security/keepassx2
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2015-10-24 21:10:50 +0800
committerriggs <riggs@FreeBSD.org>2015-10-24 21:10:50 +0800
commit193caee1641dd2c0f8f574add870540a6c4b42c6 (patch)
treeb497b7ef97952675e7f516a21119464b84fe74f6 /security/keepassx2
parent809fbb07bd9c10d6e9e6dbd9f3a8f57ae30a0630 (diff)
downloadfreebsd-ports-gnome-193caee1641dd2c0f8f574add870540a6c4b42c6.tar.gz
freebsd-ports-gnome-193caee1641dd2c0f8f574add870540a6c4b42c6.tar.zst
freebsd-ports-gnome-193caee1641dd2c0f8f574add870540a6c4b42c6.zip
Un-break build on systems where cxx does not support c++11
PR: 203992 Submitted by: eric@camachat.org (maintainer)
Diffstat (limited to 'security/keepassx2')
-rw-r--r--security/keepassx2/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/security/keepassx2/Makefile b/security/keepassx2/Makefile
index f78a119815be..31d460bf414f 100644
--- a/security/keepassx2/Makefile
+++ b/security/keepassx2/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt
CONFLICTS_INSTALL= keepassx-0.*
-USES= cmake desktop-file-utils shared-mime-info
+USES= cmake compiler:features desktop-file-utils shared-mime-info
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
USE_QT4= corelib gui xml qtestlib uic_build moc_build \
@@ -23,4 +23,10 @@ USE_QT4= corelib gui xml qtestlib uic_build moc_build \
USE_XORG= ice inputproto sm x11 xcursor xext xfixes xi xrandr xrender \
xt xtst
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if !${COMPILER_FEATURES:Mc++0x}
+CMAKE_ARGS+= -DWITH_CXX11:BOOL=OFF
+.endif
+
+.include <bsd.port.post.mk>