aboutsummaryrefslogtreecommitdiffstats
path: root/security/kgpg-kde4/Makefile
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2004-08-11 09:27:37 +0800
committerlofi <lofi@FreeBSD.org>2004-08-11 09:27:37 +0800
commit864e9b668c7ed19626e92e91ce653b0426e8a652 (patch)
tree790eb38840233721a33b0ae2dcaaebb416020301 /security/kgpg-kde4/Makefile
parent73eb1b5f64621d1b69dbde88fc44e81f1bd5f32d (diff)
downloadfreebsd-ports-gnome-864e9b668c7ed19626e92e91ce653b0426e8a652.tar.gz
freebsd-ports-gnome-864e9b668c7ed19626e92e91ce653b0426e8a652.tar.zst
freebsd-ports-gnome-864e9b668c7ed19626e92e91ce653b0426e8a652.zip
Factor out all but one of the build switches of the KDE main module ports
into separate ports. The OPTIONS will remain as of yet and trigger dependencies now, for easy transition. Update KOffice to version 1.3.2. Add patches to fix a number of issues, including: - fix kxkb on Xorg - fix kdemultimedia WITH_MPEGLIB (now mpeglib_artsplug) compilation on gcc 3.4.2 with optimizations greater than -O Add security related patches and entries to portaudit.txt.
Diffstat (limited to 'security/kgpg-kde4/Makefile')
-rw-r--r--security/kgpg-kde4/Makefile20
1 files changed, 8 insertions, 12 deletions
diff --git a/security/kgpg-kde4/Makefile b/security/kgpg-kde4/Makefile
index f56bc6dbd9e4..a141191c4ea4 100644
--- a/security/kgpg-kde4/Makefile
+++ b/security/kgpg-kde4/Makefile
@@ -7,6 +7,7 @@
PORTNAME= kdeutils
PORTVERSION= ${KDE_VERSION}
+PORTREVISION= 1
CATEGORIES?= misc kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
@@ -23,29 +24,24 @@ CONFLICTS= kgpg-*
USE_KDELIBS_VER=3
USE_KDEBASE_VER=3
PREFIX= ${KDE_PREFIX}
-KDE_BUILD_PLIST=yes
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
-DO_NOT_COMPILE+=kmilo
+DO_NOT_COMPILE+=klaptopdaemon kmilo
CONFIGURE_ENV+= DO_NOT_COMPILE="${DO_NOT_COMPILE}"
-CONFLICTS= kgpg-*
+CONFLICTS= kgpg-[0-9]*
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
-#klaptop needs APM, which is i386 only
-.if ${MACHINE_ARCH} != "i386"
-WITHOUT_KLAPTOP=yes
-.endif
+.include <bsd.port.pre.mk>
-.if defined(WITHOUT_KLAPTOP)
-DO_NOT_COMPILE+=klaptopdaemon
-.else
-PLIST_APPEND+= plist.klaptop
+#klaptop needs APM, which is i386 only
+.if ${ARCH} == "i386"
+RUN_DEPENDS+= klaptop_check:${PORTSDIR}/sysutils/klaptopdaemon
.endif
post-configure:
@@ -53,4 +49,4 @@ post-configure:
${WRKSRC}/config.h
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>