aboutsummaryrefslogtreecommitdiffstats
path: root/security/kovpn
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-09-26 16:54:26 +0800
committermiwi <miwi@FreeBSD.org>2008-09-26 16:54:26 +0800
commit71e8cc2af9bb37df44bb18113ea29e1680ac7539 (patch)
treedb872a47256bcafd32c336bd702d101c4c8a7fdf /security/kovpn
parenta5972283b82afd623a374f8e2e0f5507e71e19cf (diff)
downloadfreebsd-ports-gnome-71e8cc2af9bb37df44bb18113ea29e1680ac7539.tar.gz
freebsd-ports-gnome-71e8cc2af9bb37df44bb18113ea29e1680ac7539.tar.zst
freebsd-ports-gnome-71e8cc2af9bb37df44bb18113ea29e1680ac7539.zip
- Update to 0.3-pre7
PR: 127325 Submitted by: Anderson S. Ferreira <anderson@cnpm.embrapa.br> (maintainer)
Diffstat (limited to 'security/kovpn')
-rw-r--r--security/kovpn/Makefile16
-rw-r--r--security/kovpn/distinfo6
-rw-r--r--security/kovpn/files/README4
-rw-r--r--security/kovpn/files/patch-src-traywindow.cpp20
-rw-r--r--security/kovpn/pkg-plist4
5 files changed, 18 insertions, 32 deletions
diff --git a/security/kovpn/Makefile b/security/kovpn/Makefile
index ca33c935edff..1e5ebf2bf9a1 100644
--- a/security/kovpn/Makefile
+++ b/security/kovpn/Makefile
@@ -7,10 +7,10 @@
PORTNAME= kovpn
PORTVERSION= 0.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= security kde
-MASTER_SITES= http://home.bawue.de/~lighter/www.enlighter.de/files/
-DISTNAME= ${PORTNAME}-${PORTVERSION}_pre6
+MASTER_SITES= https://projects.fslab.de/projects/kovpn/chrome/site/
+DISTNAME= ${PORTNAME}-${PORTVERSION}.pre7
MAINTAINER= anderson@cnpm.embrapa.br
COMMENT= A simple GUI for OpenVPN clients
@@ -26,11 +26,17 @@ USE_GETTEXT= yes
INSTALLS_ICONS= yes
USE_GMAKE= yes
USE_XORG= xpm
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= autoconf:262:env automake:19:env libtool:15:env
-USE_AUTOTOOLS= libtool:15
+.include <bsd.port.pre.mk>
+
+pre-configure:
+ @cd ${WRKSRC}/admin && ${RM} -f ltmain.sh && ${CP} -f ${LTMAIN} .
+ @cd ${WRKSRC} && ${GMAKE} -f admin/Makefile.common
post-install:
${MKDIR} ${PREFIX}/share/doc/kovpn; \
${CP} ${FILESDIR}/README ${PREFIX}/share/doc/kovpn
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/kovpn/distinfo b/security/kovpn/distinfo
index cd14cd4f0c48..aadcefef88cc 100644
--- a/security/kovpn/distinfo
+++ b/security/kovpn/distinfo
@@ -1,3 +1,3 @@
-MD5 (kovpn-0.3_pre6.tar.bz2) = 5cb3ddf5248d3d83b96d831555ef1cf7
-SHA256 (kovpn-0.3_pre6.tar.bz2) = 98644c91c89e682fd0804337ad0d12eb5b2ef57f88104805492ca23d64c3f75b
-SIZE (kovpn-0.3_pre6.tar.bz2) = 860206
+MD5 (kovpn-0.3.pre7.tar.bz2) = 19b61cf9f84088baffbd5bb0a287422c
+SHA256 (kovpn-0.3.pre7.tar.bz2) = a5fa750a255399bab9c486e5d15e2e7262c543d7910d8aed9f8fc1a316552c2d
+SIZE (kovpn-0.3.pre7.tar.bz2) = 277578
diff --git a/security/kovpn/files/README b/security/kovpn/files/README
index 749873fb44d4..ef802affbe3e 100644
--- a/security/kovpn/files/README
+++ b/security/kovpn/files/README
@@ -22,7 +22,7 @@ modifying its configuration file or by adding command line options.
o Restart OpenVPN server
-The next thing you have to to is to configure kovpn itself.
+The next thing you have to do is to configure kovpn itself.
o Start kovpn
o right-click on kovpn's icon in the system tray to open the popup menu.
o left-click on the "Configure kovpn" menu item.
@@ -36,4 +36,4 @@ The next thing you have to to is to configure kovpn itself.
(the management option in the first step)
o The other options are not important for kovpn to work but can raise your
comfort.
- o That's it click on all OKs and your done.
+ o That's it ! Click on all OKs and you're done.
diff --git a/security/kovpn/files/patch-src-traywindow.cpp b/security/kovpn/files/patch-src-traywindow.cpp
deleted file mode 100644
index 1510dba18c41..000000000000
--- a/security/kovpn/files/patch-src-traywindow.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/traywindow.cpp Mon Mar 26 10:41:03 2007
-+++ src/traywindow.cpp Mon Mar 26 10:41:27 2007
-@@ -116,7 +116,7 @@
- delete mDisconnectMenuItems[ manager->id() ];
-
- /* I think (int) manager is unique and static enough to be used as id for the menu */
-- mContextMenu->removeItem( ( int ) manager );
-+ mContextMenu->removeItem( ( size_t ) manager );
- mManagerMenus.remove( manager->id() );
- mOvpnManagers.remove( manager );
- }
-@@ -134,7 +134,7 @@
-
- mManagerMenus[ manager->id() ] = new KPopupMenu( mContextMenu );
- /* I think (int) manager is unique and static enough to be used as id for the menu */
-- mContextMenu->insertItem( manager->id() , mManagerMenus[ manager->id() ] , ( int ) manager, 5 );
-+ mContextMenu->insertItem( manager->id() , mManagerMenus[ manager->id() ] , ( size_t ) manager, 5 );
-
- mManagerMenus[ manager->id() ] ->insertTitle( i18n( "Status: Unavailable" ), 0 );
-
diff --git a/security/kovpn/pkg-plist b/security/kovpn/pkg-plist
index 11909c50e6f0..4e63e6c3b18c 100644
--- a/security/kovpn/pkg-plist
+++ b/security/kovpn/pkg-plist
@@ -3,6 +3,7 @@ bin/kovpnsetup
share/doc/HTML/en/kovpn/common
share/doc/HTML/en/kovpn/index.docbook
share/doc/HTML/en/kovpn/index.cache.bz2
+share/doc/kovpn/README
share/apps/kovpn/pics/kovpn.png
share/apps/kovpn/pics/kovpn_connected.png
share/apps/kovpn/pics/kovpn_connecting.png
@@ -14,11 +15,10 @@ share/apps/kovpn/kovpnui.rc
share/icons/hicolor/16x16/apps/kovpn.png
share/icons/hicolor/32x32/apps/kovpn.png
share/applnk/Utilities/kovpn.desktop
-%%PORTDOCS%%%%DOCSDIR%%/README
@dirrm share/doc/HTML/en/kovpn
+@dirrm share/doc/kovpn
@dirrm share/apps/kovpn/pics
@dirrm share/apps/kovpn
-@dirrm %%PORTDOCS%%%%DOCSDIR%%
@dirrmtry share/icons/hicolor/16x16/apps
@dirrmtry share/icons/hicolor/32x32/apps
@dirrmtry share/applnk/Utilities