aboutsummaryrefslogtreecommitdiffstats
path: root/security/kpcli
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-05-01 09:42:38 +0800
committeradamw <adamw@FreeBSD.org>2014-05-01 09:42:38 +0800
commit4193822cf8d93383dc8f9f6186609a67b2350005 (patch)
tree7d2afea24bed5487a0bed70a4ce863d70ee3d368 /security/kpcli
parentad2f39a8b4fdf5d89647810e8a01030f3f768456 (diff)
downloadfreebsd-ports-gnome-4193822cf8d93383dc8f9f6186609a67b2350005.tar.gz
freebsd-ports-gnome-4193822cf8d93383dc8f9f6186609a67b2350005.tar.zst
freebsd-ports-gnome-4193822cf8d93383dc8f9f6186609a67b2350005.zip
STAGE support, and general cleanups. Some of the changes are a
bit more aggressive, but at this point, if I'm staging your port, you've likely stopped caring what's done to it.
Diffstat (limited to 'security/kpcli')
-rw-r--r--security/kpcli/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/security/kpcli/Makefile b/security/kpcli/Makefile
index 51fc647cd0c5..d65ab8c20857 100644
--- a/security/kpcli/Makefile
+++ b/security/kpcli/Makefile
@@ -24,21 +24,17 @@ RUN_DEPENDS= p5-Crypt-Rijndael>=1.08:${PORTSDIR}/security/p5-Crypt-Rijndael \
BUILD_DEPENDS:= ${RUN_DEPENDS}
USES= perl5
-MAN1= ${PORTNAME}.1
-MANCOMPRESSED= yes
-PLIST_FILES= bin/kpcli
+PLIST_FILES= bin/kpcli man/man1/${PORTNAME}.1.gz
-NO_STAGE= yes
do-extract:
@${MKDIR} ${WRKSRC}
- @${CP} ${DISTDIR}/${PORTNAME}-${PORTVERSION}.pl ${WRKSRC}/${PORTNAME}
+ ${CP} ${DISTDIR}/${PORTNAME}-${PORTVERSION}.pl ${WRKSRC}/${PORTNAME}
do-build:
${LOCALBASE}/bin/pod2man ${WRKSRC}/${PORTNAME} ${WRKSRC}/${PORTNAME}.1
- ${GZIP_CMD} ${WRKSRC}/${PORTNAME}.1
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1.gz ${MAN1PREFIX}/man/man1/
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
.include <bsd.port.mk>