aboutsummaryrefslogtreecommitdiffstats
path: root/security/krb5-113
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2017-03-14 11:09:16 +0800
committercy <cy@FreeBSD.org>2017-03-14 11:09:16 +0800
commit699c6f51175839bf3e95e8cbd4ff081b8bf2deef (patch)
tree42624933d31428b8966208214499eb7a9b5b5a97 /security/krb5-113
parent0fe7be57dc12ed78ea083934f08083af1d11e04b (diff)
downloadfreebsd-ports-gnome-699c6f51175839bf3e95e8cbd4ff081b8bf2deef.tar.gz
freebsd-ports-gnome-699c6f51175839bf3e95e8cbd4ff081b8bf2deef.tar.zst
freebsd-ports-gnome-699c6f51175839bf3e95e8cbd4ff081b8bf2deef.zip
New READLINE_PORT option to select to use readline in base or
readline in ports. PR: 217552 Submitted by: John W. O'brien <john@saltant.com> Differential Revision: D9889
Diffstat (limited to 'security/krb5-113')
-rw-r--r--security/krb5-113/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/security/krb5-113/Makefile b/security/krb5-113/Makefile
index edb814fbc35d..83539ffb9edb 100644
--- a/security/krb5-113/Makefile
+++ b/security/krb5-113/Makefile
@@ -42,7 +42,7 @@ CPE_PRODUCT= kerberos
OPTIONS_DEFINE= KRB5_PDF KRB5_HTML DNS_FOR_REALM LDAP
OPTIONS_DEFAULT= KRB5_PDF KRB5_HTML READLINE
OPTIONS_RADIO= CMD_LINE_EDITING
-OPTIONS_RADIO_CMD_LINE_EDITING= READLINE LIBEDIT
+OPTIONS_RADIO_CMD_LINE_EDITING= READLINE READLINE_PORT LIBEDIT
KRB5_PDF_DESC= Install krb5 PDF documentation
KRB5_HTML_DESC= Install krb5 HTML documentation
DNS_FOR_REALM_DESC= Enable DNS lookups for Kerberos realm names
@@ -50,6 +50,9 @@ DNS_FOR_REALM_CONFIGURE_ENABLE= dns-for-realm
LDAP= Enable LDAP support
LDAP_USE= OPENLDAP=yes
LDAP_CONFIGURE_WITH= ldap
+READLINE_USES= readline
+READLINE_PORT_DESC= Command line editing via devel/readline
+READLINE_PORT_USES= readline:port
LIBEDIT_USES= libedit
LIBEDIT_CONFIGURE_WITH= libedit
@@ -81,8 +84,8 @@ LDFLAGS:= -Wl,-rpath,${_RPATH}${F:S/-Wl,-rpath,//} \
BROKEN= LIB_DEPENDS when using KRB5_HOME is broken
.endif
-.if ${PORT_OPTIONS:MREADLINE}
-USES+= readline
+# OPTIONS helper causes conflicting with/without
+.if ${PORT_OPTIONS:MREADLINE} || ${PORT_OPTIONS:MREADLINE_PORT}
CONFIGURE_ARGS+= --with-readline
.else
CONFIGURE_ARGS+= --without-readline