aboutsummaryrefslogtreecommitdiffstats
path: root/security/l0phtcrack
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-06-16 10:16:43 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-06-16 10:16:43 +0800
commit348f6ff980f0291652bf00adea516f2cab90fc35 (patch)
tree2923cf3a58854800b94fe3336628d4e176dc79b4 /security/l0phtcrack
parent50b7df05797895cb1503d16db089e8d85ca25117 (diff)
downloadfreebsd-ports-gnome-348f6ff980f0291652bf00adea516f2cab90fc35.tar.gz
freebsd-ports-gnome-348f6ff980f0291652bf00adea516f2cab90fc35.tar.zst
freebsd-ports-gnome-348f6ff980f0291652bf00adea516f2cab90fc35.zip
- Simplify docs and plist handling
Diffstat (limited to 'security/l0phtcrack')
-rw-r--r--security/l0phtcrack/Makefile18
1 files changed, 6 insertions, 12 deletions
diff --git a/security/l0phtcrack/Makefile b/security/l0phtcrack/Makefile
index 765c36dec4b3..ebf961acf090 100644
--- a/security/l0phtcrack/Makefile
+++ b/security/l0phtcrack/Makefile
@@ -13,11 +13,12 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Cracks SAMBA or Windows NT passwords
USES= dos2unix perl5 zip
-DOCDIR= share/doc/${PORTNAME}
+USE_PERL5= build
RESTRICTED= uses GNU getopt with BSDish-licensed code from OpenSSL
NO_WRKSUBDIR= yes
-PLIST= ${WRKDIR}/pkg-plist
-USE_PERL5= build
+
+PLIST_FILES= bin/lc_CLI
+PORTDOCS= *
OPTIONS_DEFINE= DOCS
@@ -28,16 +29,9 @@ post-extract:
do-build:
cd ${WRKDIR} && ${CC} ${CFLAGS} -DMPU8086 *.c -o lc_CLI
-pre-install:
- ${ECHO_CMD} bin/lc_CLI > ${PLIST}
- for i in `${FIND} ${WRKDIR} -name '*txt'`; \
- do ${ECHO_CMD} ${DOCDIR}/`${BASENAME} $${i}` >> ${PLIST}; \
- done
- ${ECHO_CMD} @dirrm ${DOCDIR} >> ${PLIST}
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/lc_CLI ${STAGEDIR}${PREFIX}/bin
- ${MKDIR} ${STAGEDIR}${PREFIX}/${DOCDIR}
- cd ${WRKSRC} && ${PAX} -r -w *txt ${STAGEDIR}${PREFIX}/${DOCDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${PAX} -r -w *txt ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>